Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

pcre2-10.40-5.el9 RPM for aarch64

From CentOS Stream 9 BaseOS for aarch64

Name: pcre2 Distribution: CentOS
Version: 10.40 Vendor: CentOS
Release: 5.el9 Build date: Sat Feb 17 20:51:32 2024
Group: Unspecified Build host: aarch64-02.stream.rdu2.redhat.com
Size: 664154 Source RPM: pcre2-10.40-5.el9.src.rpm
Packager: builder@centos.org
Url: https://www.pcre.org/
Summary: Perl-compatible regular expression library
PCRE2 is a re-working of the original PCRE (Perl-compatible regular
expression) library to provide an entirely new API.

PCRE2 is written in C, and it has its own API. There are three sets of
functions, one for the 8-bit library, which processes strings of bytes, one
for the 16-bit library, which processes strings of 16-bit values, and one for
the 32-bit library, which processes strings of 32-bit values. There are no C++
wrappers. This package provides support for strings in 8-bit and UTF-8
encodings. Install pcre2-utf16 or pcre2-utf32 packages for the other ones.

The distribution does contain a set of C wrapper functions for the 8-bit
library that are based on the POSIX regular expression API (see the pcre2posix
man page). These can be found in a library called libpcre2posix. Note that
this just provides a POSIX calling interface to PCRE2; the regular expressions
themselves still follow Perl syntax and semantics. The POSIX API is
restricted, and does not give full access to all of PCRE2's facilities.

Provides

Requires

License

BSD

Changelog

* Fri Feb 16 2024 Lukas Javorsky <ljavorsk@redhat.com> - 10.40-5
  - Rebuilt for added pcre2-tools into CRB
* Mon Nov 13 2023 Lukas Javorsky <ljavorsk@redhat.com> - 10.40-4
  - Fix an issue with restoring originally unset entries in recursion
  - Resolves: BZ#2248133
* Tue Oct 17 2023 Lukas Javorsky <ljavorsk@redhat.com> - 10.40-3
  - Fix issue in the backtracking optimization of character in JIT
* Wed May 18 2022 Lukas Javorsky <ljavorsk@redhat.com> - 10.40-2
  - Explicitly require uft subpackages in tools subpackage
* Fri May 13 2022 Lukas Javorsky <ljavorsk@redhat.com> - 10.40-1
  - Rebase to the 10.40
  - Resolves multiple Out-of-bounds read errors
* Fri May 13 2022 Lukas Javorsky <ljavorsk@redhat.com> - 10.39-1
  - Rebase to the 10.39
* Fri May 13 2022 Lukas Javorsky <ljavorsk@redhat.com> - 10.38-1
  - Rebase to the 10.38
  - Patch 1 upstreamed

Files

/usr/lib/.build-id
/usr/lib/.build-id/77
/usr/lib/.build-id/77/d4074a0c96e9a675f928f5e80261797820a744
/usr/lib/.build-id/d7
/usr/lib/.build-id/d7/810868985f6e056d6046d083fadfde59cab53c
/usr/lib64/libpcre2-8.so.0
/usr/lib64/libpcre2-8.so.0.11.0
/usr/lib64/libpcre2-posix.so.3
/usr/lib64/libpcre2-posix.so.3.0.2


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Jul 16 02:51:18 2024