Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

perl-ExtUtils-PkgConfig-1.160000-1.16 RPM for noarch

From OpenSuSE Tumbleweed for noarch

Name: perl-ExtUtils-PkgConfig Distribution: openSUSE Tumbleweed
Version: 1.160000 Vendor: openSUSE
Release: 1.16 Build date: Sun Sep 26 00:39:15 2021
Group: Development/Libraries/Perl Build host: lamb02
Size: 19622 Source RPM: perl-ExtUtils-PkgConfig-1.160000-1.16.src.rpm
Packager: https://bugs.opensuse.org
Url: http://search.cpan.org/dist/ExtUtils-PkgConfig/
Summary: Simplistic Interface to Pkg-Config
The pkg-config program retrieves information about installed libraries,
usually for the purposes of compiling against and linking to them.

ExtUtils::PkgConfig is a very simplistic interface to this utility,
intended for use in the Makefile.PL of perl extensions which bind libraries
that pkg-config knows. It is really just boilerplate code that you would've
written yourself.

Provides

Requires

License

LGPL-2.1+

Changelog

* Sat Apr 22 2017 coolo@suse.com
  - updated to 1.16
    see /usr/share/doc/packages/perl-ExtUtils-PkgConfig/Changes
    1.16  Thu Apr 20 18:51:36 PDT 2017
    - Add exists() method, and update README (RT#77880)
    - Handle removal of '.' from @INC for Perl 5.24 (RT#120819)
* Thu Apr 23 2015 coolo@suse.com
  - extend version to 6 digits to avoid problems with >= 1.121
* Fri Oct 04 2013 coolo@suse.com
  - updated to 1.15
    - Gracefully handle empty fields in pkg-config files.
* Tue Jun 04 2013 coolo@suse.com
  - updated to 1.14
    - Skip tests for pkg-config binary with the '--max-version' switch on
      OpenBSD 5.2, due to a bug in OpenBSD's implemenation of 'pkg-config'
    - Updated Makefile.PL to use a META_MERGE block with WriteMakefile(); this
      block is what MetaCPAN reads when generating page output
    - Correctly handle major-only versions, like '2' (RT #68246).
    - Updated FSF address and copyrights
* Fri Nov 18 2011 coolo@suse.com
  - use original .tar.gz
* Tue Nov 30 2010 coolo@novell.com
  - switch to perl_requires macro
* Wed Nov 24 2010 chris@computersalat.de
  - recreated by cpanspec 1.78
    o fix deps
  - noarch pkg
* Tue Oct 19 2010 coolo@novell.com
  - add perl as explicit buildrequire
* Sun Jan 10 2010 jengelh@medozas.de
  - enable parallel build
* Tue Jan 20 2009 anicka@suse.cz
  - update to 1.12
    * Try to fix a test failure.

Files

/usr/lib/perl5/vendor_perl/5.34.0/ExtUtils
/usr/lib/perl5/vendor_perl/5.34.0/ExtUtils/PkgConfig.pm
/usr/share/doc/packages/perl-ExtUtils-PkgConfig
/usr/share/doc/packages/perl-ExtUtils-PkgConfig/Changes
/usr/share/doc/packages/perl-ExtUtils-PkgConfig/README
/usr/share/doc/packages/perl-ExtUtils-PkgConfig/perl-ExtUtils-PkgConfig.doap
/usr/share/man/man3/ExtUtils::PkgConfig.3pm.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Oct 21 23:18:09 2021