Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

perl-App-cpanminus-1.7044-1.7 RPM for noarch

From OpenSuSE Tumbleweed for noarch

Name: perl-App-cpanminus Distribution: openSUSE Tumbleweed
Version: 1.7044 Vendor: openSUSE
Release: 1.7 Build date: Sun Sep 26 04:12:46 2021
Group: Development/Libraries/Perl Build host: goat03
Size: 255145 Source RPM: perl-App-cpanminus-1.7044-1.7.src.rpm
Packager: https://bugs.opensuse.org
Url: https://metacpan.org/release/App-cpanminus
Summary: Get, unpack, build and install modules from CPAN
cpanminus is a script to get, unpack, build and install modules from CPAN
and does nothing else.

It's dependency free (can bootstrap itself), requires zero configuration,
and stands alone. When running, it requires only 10MB of RAM.

Provides

Requires

License

Artistic-1.0 OR GPL-1.0-or-later

Changelog

* Wed Oct 28 2020 Dirk Stoecker <opensuse@dstoecker.de>
  - updated to 1.7044
    see /usr/share/doc/packages/perl-App-cpanminus/Changes
* Tue Jun 06 2017 sriedel@suse.com
  - fix missing dependency on perl-Parse-PMFile
* Tue Apr 04 2017 coolo@suse.com
  - updated to 1.7043
    see /usr/share/doc/packages/perl-App-cpanminus/Changes
    1.7043  2017-04-02 20:56:06 PDT
      [Improvements]
    - Set PERL_USE_UNSAFE_INC for 5.26+ (haarg) #521
    - Strictly match module NAME in Bundle
* Sat May 28 2016 coolo@suse.com
  - updated to 1.7042
    see /usr/share/doc/packages/perl-App-cpanminus/Changes
    1.7042  2016-05-24 00:48:13 PDT
      [Improvements]
    - Merge configure dependencies with cpanfile requirements too
    1.7041  2016-05-08 11:28:31 PDT
      [Improvements]
    - Add environment variables to man pages (Doug Bell) #481
    - Support --with-configure and --without-condfigure (zebardy) #482
    - Make file mirror faster (Matthew Horsfall) #499
* Wed Jan 13 2016 coolo@suse.com
  - updated to 1.7040
    see /usr/share/doc/packages/perl-App-cpanminus/Changes
    1.7040  2016-01-07 11:28:07 PST
      [Improvements]
    - Removed a workaround to skip tests for config dependencies such as Module::Build #462
    - Various doc improvements
* Tue Jun 30 2015 coolo@suse.com
  - updated to 1.7039
    see /usr/share/doc/packages/perl-App-cpanminus/Changes
    1.7039  2015-06-28 18:05:10 PDT
      [Improvements]
    - Only enable softening of MakeMaker dependency when Module::Install is present (reported by haarg)
    - Support .git URL with http protocol (shoichikaji) #468
* Tue Jun 23 2015 coolo@suse.com
  - updated to 1.7038
    see /usr/share/doc/packages/perl-App-cpanminus/Changes
    1.7038  2015-06-22 18:04:44 PDT
      [Releng]
    - bump minimum perl requirement to 5.8.1 in META files
* Sun Jun 21 2015 coolo@suse.com
  - updated to 1.7037
    see /usr/share/doc/packages/perl-App-cpanminus/Changes
    1.7037  2015-06-18 14:37:32 PDT
      [Improvements]
    - Bump CPAN-Meta-Check to 0.012 #465
    - Bump HTTP-Tiny to 0.056
    - Bump CPAN-Meta to 2.150005
    - Bump CPAN-Meta-YAML to 0.016
* Sun Jun 07 2015 coolo@suse.com
  - updated to 1.7036
    see /usr/share/doc/packages/perl-App-cpanminus/Changes
    1.7036  2015-06-05 22:07:50 PDT
      [Improvements]
    - Also soften MakeMaker depenency in runtime prereq, which is just a weird bug in an old
      Module::Install pre 1.0
    1.7035  2015-06-05 10:51:17 PDT
      [Improvements]
    - Add a workaround for distributions with an old (buggy) Module::Install, now that the problems
      occur more frequently with 5.22.0 shipping with a dev version of ExtUtils::MakeMaker #463
* Fri May 08 2015 coolo@suse.com
  - updated to 1.7034
    see /usr/share/doc/packages/perl-App-cpanminus/Changes
    1.7034  2015-05-07 14:20:57 PDT
      [Improvements]
    - Improved an error message when dependency requirement in cpanfile get conflict with prereqs
      in sub dependencies.

Files

/usr/bin/cpanm
/usr/lib/perl5/vendor_perl/5.34.0/App
/usr/lib/perl5/vendor_perl/5.34.0/App/cpanminus
/usr/lib/perl5/vendor_perl/5.34.0/App/cpanminus.pm
/usr/lib/perl5/vendor_perl/5.34.0/App/cpanminus.pod
/usr/lib/perl5/vendor_perl/5.34.0/App/cpanminus/Dependency.pm
/usr/lib/perl5/vendor_perl/5.34.0/App/cpanminus/fatscript.pm
/usr/lib/perl5/vendor_perl/5.34.0/App/cpanminus/script.pm
/usr/share/doc/packages/perl-App-cpanminus
/usr/share/doc/packages/perl-App-cpanminus/Changes
/usr/share/doc/packages/perl-App-cpanminus/README
/usr/share/licenses/perl-App-cpanminus
/usr/share/licenses/perl-App-cpanminus/LICENSE
/usr/share/man/man1/cpanm.1.gz
/usr/share/man/man3/App::cpanminus.3pm.gz
/usr/share/man/man3/App::cpanminus::fatscript.3pm.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Oct 18 23:27:06 2021