Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

yast2-update-4.5.2-1.1 RPM for i586

From OpenSuSE Tumbleweed for i586

Name: yast2-update Distribution: openSUSE Tumbleweed
Version: 4.5.2 Vendor: openSUSE
Release: 1.1 Build date: Fri Nov 18 16:22:57 2022
Group: System/YaST Build host: lamb09
Size: 174488 Source RPM: yast2-update-4.5.2-1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/yast/yast-update
Summary: YaST2 - Update
Use this component if you wish to update your system.

Provides

Requires

License

GPL-2.0-only

Changelog

* Wed Nov 16 2022 Ladislav Slezák <lslezak@suse.cz>
  - Display a warning in the upgrade summary when removing orphaned
    3rd party packages (bsc#1202007)
  - 4.5.2
* Thu Apr 28 2022 Ladislav Slezák <lslezak@suse.cz>
  - Use the "norecovery" mount option when searching the root
    partitions (bsc#1195894)
  - 4.5.1
* Wed Apr 06 2022 Ladislav Slezák <lslezak@suse.cz>
  - Bump version to 4.5.0 (bsc#1198109)
* Wed Dec 01 2021 Imobach Gonzalez Sosa <igonzalezsosa@suse.com>
  - Do not crash after selecting the system to upgrade when using
    the full medium (bsc#1193212).
  - 4.4.6
* Fri Nov 26 2021 David Diaz <dgonzalez@suse.com>
  - Remove obsolete code for treating /var differently when mounting
    partitions, avoiding calling old storage code and crashing
    (related to bsc#1186268).
  - 4.4.5
* Mon Nov 15 2021 Imobach Gonzalez Sosa <igonzalezsosa@suse.com>
  - Adapt to the ProductSpec API (bsc#1192626).
  - 4.4.4
* Mon Sep 06 2021 Ladislav Slezák <lslezak@suse.cz>
  - Fixed crash during system upgrade (synchronize the YaST and
    libzypp repositories to avoid deleting caches for used
    repositories) (bsc#1189590)
  - 4.4.3
* Fri Jul 23 2021 José Iván López González <jlopez@suse.com>
  - Avoid to bind-mount /run twice (bsc#1181066).
  - 4.4.2
* Thu Jun 10 2021 Imobach Gonzalez Sosa <igonzalezsosa@suse.com>
  - Do not crash when an /etc/fstab file does not contain any
    entry (bsc#1186895).
  - 4.4.1
* Tue Apr 20 2021 Ladislav Slezák <lslezak@suse.cz>
  - 4.4.0 (bsc#1185510)
* Wed Feb 10 2021 Imobach Gonzalez Sosa <igonzalezsosa@suse.com>
  - Do not rely on the 'installation-helper' binary to create
    snapshots after installation or offline upgrade (bsc#1180142).
  - Do not crash when it is not possible to create a snapshot before
    upgrading the system (related to bsc#1180142).
  - 4.3.2
* Thu Sep 17 2020 schubi@suse.de
  - Adding additional compatible vendors which are defined in the
    control file (jsc#SLE-14807).
  - 4.3.1
* Wed Jun 03 2020 Josef Reidinger <jreidinger@suse.com>
  - Replace anyxml agent with rubygem-nokogiri as yast2 already
    depends on nokogiri, to reduce amount of used xml parsers.
    (related to bsc#1170886)
  - 4.3.0
* Thu Mar 12 2020 Ladislav Slezák <lslezak@suse.cz>
  - Do not remove the installation repositories in the "Previously
    Used Repositories" step (bsc#1163081)
  - 4.2.18
* Fri Feb 21 2020 Ladislav Slezák <lslezak@suse.cz>
  - Fixed repository loading to not remove the initial installation
    repository (bsc#1163081)
  - 4.2.17
* Wed Feb 19 2020 Ladislav Slezák <lslezak@suse.cz>
  - Switch from Autotools based build to Rake
* Wed Feb 19 2020 Stefan Hundhammer <shundhammer@suse.com>
  - Fixed user-visible messages (bsc#1084015)
  - 4.2.16
* Mon Feb 17 2020 mls@suse.de
  - Also accept Packages.db as valid rpm database (bsc#1162485)
  - 4.2.15
* Tue Jan 28 2020 Ladislav Slezák <lslezak@suse.cz>
  - Store the original repository setup early in the upgrade workflow
    so YaST can easily differ between the old and new repositories
    (bsc#1159433)
  - 4.2.14
* Fri Jan 03 2020 schubi@suse.de
  - Aborting upgrade: Restoring old settings e.g. RPM database
    (bsc#1158914).
  - mount /run and efivars into target to fix hanging LVM (bsc#1148500)
    by Steffen Winterfeldt <snwint@suse.com>
  - 4.2.13
* Wed Dec 04 2019 Josef Reidinger <jreidinger@suse.com>
  - fix upgrade for online medium (bsc#1158056 and bsc#1157636)
  - 4.2.12
* Tue Nov 19 2019 schubi@suse.de
  - Using Y2Packager::Resolvable.any? and Y2Packager::Resolvable.find
    in order to decrease the required memory (bsc#1132650,
    bsc#1140037).
  - 4.2.11
* Thu Nov 07 2019 Ladislav Slezák <lslezak@suse.cz>
  - Fixed too eager Rubocop cleanup resulting in "No fstab found"
    error after selecting a partition to upgrade (related to
    jsc#SLE-7101)
  - 4.2.10
* Thu Nov 07 2019 Ladislav Slezák <lslezak@suse.cz>
  - Implement upgrade for Full medium (jsc#SLE-7101)
  - 4.2.9
* Tue Nov 05 2019 Josef Reidinger <jreidinger@suse.com>
  - Add support for online auto_upgrade (jsc#SLE-7214)
  - 4.2.8
* Wed Oct 09 2019 Martin Vidner <mvidner@suse.com>
  - At upgrade time, mount also /run and efivars in the target,
    to fix hanging LVM tools (bsc#1148500)
  - 4.2.7
* Mon Sep 30 2019 José Iván López González <jlopez@suse.com>
  - Use new API to save encryption names from crypttab file (part of
    jsc#SLE-7376).
  - 4.2.6
* Thu Aug 22 2019 schubi@suse.de
  - Using rb_default_ruby_abi tag in the spec file in order to
    handle several ruby versions (bsc#1146403).
  - 4.2.5
* Thu Jun 06 2019 schubi@suse.de
  - Going back and forward in the update workflow: Initialize
    add-on products and system packages correctly (bsc#1136012).
  - 4.2.4
* Fri May 31 2019 Stasiek Michalski <hellcp@mailbox.org>
  - Add metainfo (fate#319035)
  - Revamp spec
  - Replace GenericName with Comment
  - 4.2.3
* Fri Apr 26 2019 Ladislav Slezák <lslezak@suse.cz>
  - Uninstall the "SUSE-Manager-Proxy" product when upgrading from
    SLES12 + SUMA Proxy + SUMA Branch Server (bsc#1133215)
  - 4.2.2
* Fri Apr 05 2019 José Iván López González <jlopez@suse.com>
  - Remove obsolete code.
  - 4.2.1
* Tue Mar 26 2019 José Iván López González <jlopez@suse.com>
  - Remove code related to device name translations.
  - 4.2.0
* Thu Jan 24 2019 lslezak@suse.cz
  - Added URL tag to the spec file (bsc#1097957)
  - 4.1.8

Files

/usr/share/YaST2/clients/backup_proposal.rb
/usr/share/YaST2/clients/inst_backup.rb
/usr/share/YaST2/clients/inst_rootpart.rb
/usr/share/YaST2/clients/inst_update_partition.rb
/usr/share/YaST2/clients/inst_update_partition_auto.rb
/usr/share/YaST2/clients/packages_proposal.rb
/usr/share/YaST2/clients/rootpart_proposal.rb
/usr/share/YaST2/clients/update_proposal.rb
/usr/share/YaST2/include
/usr/share/YaST2/include/update
/usr/share/YaST2/include/update/rootpart.rb
/usr/share/YaST2/lib
/usr/share/YaST2/lib/update
/usr/share/YaST2/lib/update/clients
/usr/share/YaST2/lib/update/clients/inst_update_partition_auto.rb
/usr/share/YaST2/modules
/usr/share/YaST2/modules/RootPart.rb
/usr/share/YaST2/modules/SUSERelease.rb
/usr/share/YaST2/modules/Update.rb
/usr/share/doc/packages/yast2-update
/usr/share/doc/packages/yast2-update/README.md


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Feb 9 00:21:52 2023