Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libdirac_decoder0-1.0.2-33.20 RPM for i586

From OpenSuSE Tumbleweed for i586

Name: libdirac_decoder0 Distribution: openSUSE Tumbleweed
Version: 1.0.2 Vendor: openSUSE
Release: 33.20 Build date: Sat Sep 18 13:45:56 2021
Group: System/Libraries Build host: old-cirrus1
Size: 363705 Source RPM: dirac-1.0.2-33.20.src.rpm
Packager: https://bugs.opensuse.org
Url: https://sourceforge.net/projects/dirac/
Summary: Dirac Video Codec Decoder Library
Dirac is an open source video codec. It uses a traditional hybrid video
codec architecture, but with the wavelet transform instead of the usual
block transforms.  Motion compensation uses overlapped blocks to reduce
block artefacts that would upset the transform coding stage.

Dirac can code just about any size of video, from streaming up to HD
and beyond, although certain presets are defined for different
applications and standards.  These cover the parameters that need to be
set for the encoder to work, such as block sizes and temporal
prediction structures, which must otherwise be set by hand.

Provides

Requires

License

MPL-1.1

Changelog

* Tue Jul 04 2017 tchvatal@suse.com
  - Cleanu pwith spec-cleaner
  - Switch to upstream tarball instead of repacking
  - Update dependencies to match reality
  - Explicitely enable configuration switches
  - Disable docu building as they are kinda empty unless we would
    add latex and dot
* Tue May 26 2015 jkeil@suse.com
  - Add baselibs.conf as Source
* Sun Apr 12 2015 plinnell@opensuse.org
  - added existing baselibs.conf to fix build
* Sat Apr 04 2015 dmueller@suse.com
  - remove unneeded texlive-latex dependency
* Sat Dec 07 2013 matz@suse.de
  - Don't buildrequire valgrind-devel anywhere, it's unused.
* Thu Dec 20 2012 ro@suse.de
  - buildrequire pkg-config regardless of build-architecture
* Fri Dec 09 2011 coolo@suse.com
  - fix license to be in spdx.org format
* Fri Sep 30 2011 coolo@suse.com
  - add libtool as buildrequire to make the spec file more reliable
* Sun Sep 18 2011 jengelh@medozas.de
  - Remove redundant tags/sections from specfile
    (cf. packaging guidelines)
  - Use %_smp_mflags for parallel build
  - Add dirac-devel to baselibs
* Thu Apr 14 2011 toddrme2178@gmail.com
  - added 32bit compatibility libraries
* Mon May 24 2010 davejplater@gmail.com
  - Split off doc subpackage
* Mon May 24 2010 davejplater@gmail.com
  - Added Provides: and Obsoletes: for packman libdirac-devel
  - Included patch from dirac git to fix uninitialised memory read
    that causes the encoder to crash when using non-overlapping blocks.
* Sun May 09 2010 davejplater@gmail.com
  - Fixed factory build with patch from git dirac-1.0.2-gcc45.patch
* Fri Dec 18 2009 jengelh@medozas.de
  - exclude valgrind-devel on SPARC
* Sun Jul 12 2009 coolo@novell.com
  - fix build in disabling as-needed
* Wed Jul 01 2009 sbrabec@suse.cz
  - Updated to version 1.0.2:
    * minor release complying with the latest Dirac Bytestream
      Specification 2.2.3.
    * Improved compression performance for small picture sizes.
    * Improved compression performance at low bit-rates.
    * Included macros to check the API version.
    * Improved motion estimation.
    * New 422 <-> 420 conversion utilities for interlaced video.
    * New functionality added to encoder API.
    * Fixed bugs in handling DC subband.
* Wed Apr 29 2009 sbrabec@suse.cz
  - Worked around internal compiler error on 11.0-x86_64.
* Tue Nov 25 2008 ro@suse.de
  - do not buildrequire valgrind on ia64 s390 s390x
    (does not exist on these platforms)
* Thu Nov 06 2008 sbrabec@suse.cz
  - New SuSE package (bnc#441855).

Files

/usr/lib/libdirac_decoder.so.0
/usr/lib/libdirac_decoder.so.0.1.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Nov 29 23:26:08 2021