Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

crypto-policies-scripts-20210225.05203d2-1.3 RPM for noarch

From OpenSuSE Ports Tumbleweed for noarch

Name: crypto-policies-scripts Distribution: openSUSE:Factory:zSystems
Version: 20210225.05203d2 Vendor: obs://build.opensuse.org/openSUSE:Factory:zSystems
Release: 1.3 Build date: Fri May 28 01:07:17 2021
Group: Productivity/Networking/Security Build host: s390zp24
Size: 156412 Source RPM: crypto-policies-20210225.05203d2-1.3.src.rpm
Url: https://gitlab.com/redhat-crypto/fedora-crypto-policies
Summary: Tool to switch between crypto policies
This package provides a tool update-crypto-policies, which applies
the policies provided by the crypto-policies package. These can be
either the pre-built policies from the base package or custom policies
defined in simple policy definition files.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Thu Feb 25 2021 Pedro Monreal <pmonreal@suse.com>
  - Update to version 20210225.05203d2:
    * Disable DTLS0.9 protocol in the DEFAULT policy.
    * policies/FIPS: insignificant reformatting
    * policygenerators/libssh: respect ssh_certs
    * policies/modules/OSPP: tighten to follow RHEL 8
    * crypto-policies(7): drop not-reenableable comment
    * follow up on disabling RC4
* Thu Feb 25 2021 Pedro Monreal <pmonreal@suse.com>
  - Remove not needed scripts: fips-finish-install fips-mode-setup
* Wed Feb 24 2021 Pedro Monreal <pmonreal@suse.com>
  - Disable DTLS0.9 protocol in GnuTLS DEFAULT policy. [bsc#1180938]
    * The minimum DTLS protocol version in the DEFAULT and FUTURE
      policies is DTLS1.2.
    * Fixed upstream: 05203d21f6d0ea9bbdb351e4600f1e273720bb8e
* Wed Feb 17 2021 Pedro Monreal <pmonreal@suse.com>
  - Update to version 20210213.5c710c0: [bsc#1180938]
    * setup_directories(): perform safer creation of directories
    * save_config(): avoid re-opening output file for each iteration
    * save_config(): break after first match to avoid unnecessary stat() calls
    * CryptoPolicy.parse(): actually stop parsing line on syntax error
    * ProfileConfig.parse_string(): correctly extended subpolicies
    * Exclude RC4 from LEGACY
    * Introduce rc4_md5_in_krb5 to narrow AD_SUPPORT
    * code style: fix 'not in' membership testing
    * pylintrc: tighten up a bit
    * formatting: avoid long lines
    * formatting: use f-strings instead of format()
    * formatting: reformat all python code with autopep8
    * nss: postponing the version check again, to 3.61
    * Revert "Unfortunately we have to keep ignoring the openssh check for sk-"
* Tue Feb 09 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Use tar_scm service, not obs_scm: With crypto-policies entering
    Ring0 (distro bootstrap) we want to be sure to keep the buildtime
    deps as low as possible.
  - Add python3-base BuildRequires: previously, OBS' tar service
    pulled this in for us.
* Mon Feb 08 2021 Pedro Monreal <pmonreal@suse.com>
  - Add a BuildIgnore for crypto-policies
* Mon Feb 08 2021 Pedro Monreal <pmonreal@suse.com>
  - Use gzip instead of xz in obscpio and sources
* Fri Feb 05 2021 Pedro Monreal <pmonreal@suse.com>
  - Do not build the manpages to avoid build cycles
  - Add crypto-policies-no-build-manpages.patch
* Tue Feb 02 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Convert to use a proper git source _service:
    + To update, one just needs to update the commit/revision in the
      _service file and run `osc service dr`.
    + The version of the package is defined by the commit date of the
      revision, followed by the abbreviated git hash (The same
      revision used before results thus in a downgrade to 20210118,
      but as this is a alltime new package, this is acceptable.
* Tue Feb 02 2021 Pedro Monreal <pmonreal@suse.com>
  - Update to git version 20210127
    * Bump Python requirement to 3.6
    * Output sigalgs required by nss >=3.59
    * Do not require bind during build
    * Break build cycles with openssl and gnutls
* Thu Jan 21 2021 Pedro Monreal <pmonreal@suse.com>
  - Update to git version 20210118
    * Output sigalgs required by nss >=3.59
    * Bump Python requirement to 3.6
    * Kerberos 5: Fix policy generator to account for macs
    * Add AES-192 support (non-TLS scenarios)
    * Add documentation of the --check option
* Thu Jan 21 2021 Pedro Monreal <pmonreal@suse.com>
  - Fix the man pages generation
  - Add crypto-policies-asciidoc.patch
* Thu Jan 21 2021 Pedro Monreal <pmonreal@suse.com>
  - Test only supported modules
  - Add crypto-policies-test_supported_modules_only.patch
* Tue Dec 22 2020 Pedro Monreal <pmonreal@suse.com>
  - Add crypto-policies-typos.patch to fix some typos
* Thu Nov 12 2020 Vítězslav Čížek <vcizek@suse.com>
  - Initial packaging, git version 20200918 (jsc#SLE-15832)

Files

/usr/bin/update-crypto-policies
/usr/share/crypto-policies/python
/usr/share/crypto-policies/python/__pycache__
/usr/share/crypto-policies/python/__pycache__/build-crypto-policies.cpython-38.pyc
/usr/share/crypto-policies/python/__pycache__/update-crypto-policies.cpython-38.pyc
/usr/share/crypto-policies/python/build-crypto-policies.py
/usr/share/crypto-policies/python/cryptopolicies
/usr/share/crypto-policies/python/cryptopolicies/__init__.py
/usr/share/crypto-policies/python/cryptopolicies/__pycache__
/usr/share/crypto-policies/python/cryptopolicies/__pycache__/__init__.cpython-38.pyc
/usr/share/crypto-policies/python/cryptopolicies/__pycache__/cryptopolicies.cpython-38.pyc
/usr/share/crypto-policies/python/cryptopolicies/cryptopolicies.py
/usr/share/crypto-policies/python/policygenerators
/usr/share/crypto-policies/python/policygenerators/__init__.py
/usr/share/crypto-policies/python/policygenerators/__pycache__
/usr/share/crypto-policies/python/policygenerators/__pycache__/__init__.cpython-38.pyc
/usr/share/crypto-policies/python/policygenerators/__pycache__/bind.cpython-38.pyc
/usr/share/crypto-policies/python/policygenerators/__pycache__/configgenerator.cpython-38.pyc
/usr/share/crypto-policies/python/policygenerators/__pycache__/gnutls.cpython-38.pyc
/usr/share/crypto-policies/python/policygenerators/__pycache__/java.cpython-38.pyc
/usr/share/crypto-policies/python/policygenerators/__pycache__/krb5.cpython-38.pyc
/usr/share/crypto-policies/python/policygenerators/__pycache__/libreswan.cpython-38.pyc
/usr/share/crypto-policies/python/policygenerators/__pycache__/libssh.cpython-38.pyc
/usr/share/crypto-policies/python/policygenerators/__pycache__/nss.cpython-38.pyc
/usr/share/crypto-policies/python/policygenerators/__pycache__/openssh.cpython-38.pyc
/usr/share/crypto-policies/python/policygenerators/__pycache__/openssl.cpython-38.pyc
/usr/share/crypto-policies/python/policygenerators/bind.py
/usr/share/crypto-policies/python/policygenerators/configgenerator.py
/usr/share/crypto-policies/python/policygenerators/gnutls.py
/usr/share/crypto-policies/python/policygenerators/java.py
/usr/share/crypto-policies/python/policygenerators/krb5.py
/usr/share/crypto-policies/python/policygenerators/libreswan.py
/usr/share/crypto-policies/python/policygenerators/libssh.py
/usr/share/crypto-policies/python/policygenerators/nss.py
/usr/share/crypto-policies/python/policygenerators/openssh.py
/usr/share/crypto-policies/python/policygenerators/openssl.py
/usr/share/crypto-policies/python/update-crypto-policies.py
/usr/share/man/man8/update-crypto-policies.8.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 14:55:06 2021