Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

suse-module-tools-legacy-16.0.11-1.1 RPM for armv7hl

From OpenSuSE Ports Tumbleweed for armv7hl

Name: suse-module-tools-legacy Distribution: openSUSE Tumbleweed
Version: 16.0.11 Vendor: openSUSE
Release: 1.1 Build date: Fri Oct 8 00:08:59 2021
Group: System/Base Build host: obs-arm-11
Size: 9073 Source RPM: suse-module-tools-16.0.11-1.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://github.com/openSUSE/suse-module-tools
Summary: Legacy "weak-modules" script for Code10
This package contains the legacy "weak-modules" script for kernel
module package (KMP) support. It was replaced by "weak-modules2" in
SLE 11 and later. It is still used by the DKMS module packaging framework.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Mon Oct 04 2021 Martin Wilck <mwilck@suse.com>
  - Update to version 16.0.11:
    * inkmp-script(postun): don't pass  existing files to weak-modules2
      (boo#1191200)
    * kernel-scriptlets: skip cert scriptlet on non-UEFI systems
      (boo#1191260)
* Tue Sep 14 2021 obs-service-tar-scm@invalid
  - Update to version 16.0.10+7:
    * rpm-script: link config also into /boot (boo#1189879)
    * weak-modules2: accept modules under /usr/lib/modules on stdin
      (for support of usr-merged KMPs)
    * fix scriptlet path (bsc#1189441)
* Tue Sep 14 2021 Martin Wilck <mwilck@suse.com>
  - Update to version 16.0.10:
    * Import kernel scriptlets from kernel-source (bsc#1189441)
    * README.md: document environment variables for weak-modules2
* Mon Aug 30 2021 Martin Wilck <mwilck@suse.com>
  - Update to version 16.0.9:
    * weak_modules2: fix "warning: %post(kernel-...) scriptlet failed,
      exit status 1" message from rpm (boo#1189881)
    * weak-modules2: add logging at verbose level 2
    * weak-modules2: control logging with environment variables
      WM2_VERBOSE, WM2_DEBUG, WM2_LOGFILE
    * regenerate-initrd-posttrans: friendly notice if dracut not found
      (boo#1123721)
* Fri Aug 20 2021 Martin Wilck <mwilck@suse.com>
  - Update to version 16.0.8+1:
    * spec file: fix BuildRequires
* Thu Aug 19 2021 Martin Wilck <mwilck@suse.com>
  - Update to version 16.0.8:
    * fix problem that initrd may not be rebuilt after installing
      kernel-$flavor-extra (bsc#1189441)
* Thu Aug 19 2021 Martin Wilck <mwilck@suse.com>
  - Update to version 16.0.7:
    * add kernel-sysctl.service and boot-sysctl.service for applying
      kernel-specific sysctl settings (bsc#1184804)
    * add support for zstd-compressed kernel modules
* Mon Jul 05 2021 Martin Wilck <mwilck@suse.com>
  - Update to version 16.0.6:
    * modprobe.d: Remove dma=none setting for parport_pc
      (bsc#1177695)
* Thu Jul 01 2021 Martin Wilck <mwilck@suse.com>
  - Update to version 16.0.5
    * moved config files to /usr/lib/modprobe.d and /usr/lib/depmod.d
    * "modprobe $FS" for a blacklisted file system now offers to
      unblacklist the module permanently
    * disabled automatic un-blacklisting of filesystem modules loaded
      at installation time
    * added faster substitute for lsinitrd to speed up weak-modules2
    * added README.md
    * modprobe.conf cleanup
* Thu Jun 17 2021 mwilck@suse.com
  - Update to version 16.0.4:
    * re-add legacy subpackage with "weak-modules", and add a
      "Supplements" dependency on dkms, which needs it
* Thu Jun 17 2021 mwilck@suse.com
  - Update to version 16.0.3:
    * Fix treatment of compressed modules (bsc#1187093)
* Thu Jun 10 2021 mwilck@suse.com
  - Update to version 16.0.2:
    * fix kernel version in dracut invocation (bug in 16.0.0)
    * spec file: really fix ppc64/ppc64le
* Thu May 27 2021 mwilck@suse.com
  - Update to version 16.0.1:
    * fix ppc64/ppc64le build
* Thu May 27 2021 mwilck@suse.com
  - Update to version 16.0.0
  - modprobe.conf cleanup (bsc#1161343)
    * Unify ppc64 and ppc64le
    * Delete files for obsolete architectures
    * Remove obsolete SUSE_INITRD statements (bsc#1161343)
    * Add dependency on dracut 049.1 (bsc#1142152, ltc#176292, FATE#327775)
  - Replace mkinitrd with dracut everywhere
  - Remove obsolete "weak-modules" script
* Thu Apr 22 2021 obs-service-tar-scm@invalid
  - Update to version 15.4.1:
    * dm-crypt requires essiv in SLE15 SP3 (boo#1183063 bsc#1184134 ltc#192244).
* Tue Apr 13 2021 obs-service-tar-scm@invalid
  - Update to version 15.4.0:
    * Enable f2fs (bsc#1184415)
* Mon Nov 02 2020 mwilck@suse.com
  - Update to version 15.3.5:
    * Skip coldplug for memory devices on ppc64le, using generator
      (bsc#1174287, bsc#1172745)
* Tue Aug 25 2020 mwilck@suse.com
  - Update to version 15.3.4:
    * spec: rework dependencies
* Mon Aug 03 2020 mwilck@suse.com
  - Update to version 15.3.4:
    * rework dependencies to reduce system size for small OS
* Fri Jun 05 2020 Martin Wilck <mwilck@suse.com>
  - Reverted back to tar_scm source service
    (obs_scm doesn't work well for Ring0 packages)
* Wed May 27 2020 mwilck@suse.com
  - Update to version 15.3.3:
    * spec: remove SLE/openSUSE difference in allow_unsupported_modules
    (jsc#SLE-12255)
    * spec: use same fs_blacklist on SLE and openSUSE
    (jsc#SLE-12255, jsc#SLE-3926)
    * spec: use br_netfilter softdep only for SLE12
    (jsc#SLE-12255, bsc#1166531, boo#1158817, bsc#937216)
* Fri Apr 17 2020 mwilck@suse.com
  - Update to version 15.3.2:
    * modprobe.conf.common: eliminate circular uas/usb-storage dependency
    (bsc#1168661)
* Mon Jan 20 2020 mwilck@suse.com
  - Update to version 15.2.10:
    * ppc64le: fix dependency of papr_scm
      (bsc#1142152, ltc#176292, FATE#327775).
* Wed Jan 15 2020 mwilck@suse.com
  - Update to version 15.2.9:
    * 00-system.conf: move br_netfilter softdep to separate file
      (boo#1158817)
* Thu Jan 09 2020 mwilck@suse.com
  - Update to version 15.2.8:
    * Add modprobe.conf.s390x (bsc#1132798)
* Thu Nov 07 2019 mwilck@suse.com
  - Update to version 15.2.7:
    * spec file: avoid %{_libexecdir}
* Thu Nov 07 2019 mwilck@suse.com
  - Update to version 15.2.6:
    * modprobe.conf: add dependency of papr_scm on libnvdimm
      (bsc#1142152, ltc#176292, FATE#327775).
* Fri Aug 16 2019 mwilck@suse.com
  - Update to version 15.2.5:
    * remove 'modhash' - moved to mokutil package (jsc#SLE-6094)
* Mon Jul 15 2019 mwilck@suse.com
  - Update to version 15.2.4:
    * sg.conf: avoid file conflict with system-tuning-common-SUSE
* Mon Jul 01 2019 mwilck@suse.com
  - Update to version 15.2.3:
    * softdep of bridge on br_netfilter (bsc#937216, bsc#1134819)
* Tue Jun 18 2019 mwilck@suse.com
  - Update to version 15.2.2:
    * kmp-install, driver-check.sh, weak-modules2:
      Support for compressed kernel modules (bsc#1135854)
* Fri Jun 14 2019 mwilck@suse.com
  - Update to version 15.2.1:
  - Install sg.conf under /usr/lib/modules-load.d (bsc#1036463)
    * sg.conf: avoid file conflict with systemd
* Fri Jun 14 2019 mwilck@suse.com
  - Update to version 15.2.0:
    * weak-modules2: emit "inconsistent" warning only if replacement fails
    (bsc#1127155)
* Fri May 17 2019 Dominique Leuenberger <dimstar@opensuse.org>
  - Only ship RPM macros up to suse_version 1500: after that, the
    macros can be found in the rpm-config-SUSE package.
* Fri May 10 2019 Dominique Leuenberger <dimstar@opensuse.org>
  - Move RPM macros to %_rpmmacrodir.
* Thu Mar 14 2019 mwilck@suse.com
  - Update to version 15.1.13:
    * spec file: add conflicts for dracut < 44.2 (bsc#1127891)
* Thu Mar 14 2019 mwilck@suse.com
  - Update to version 15.1.12 (git 1ab0b84):
    * modprobe.conf.common: add csiostor->cxgb4 dependency
      (bsc#1100989)
    * Load fbcon together with virtio_gpu on s390 (bsc#1121996,
      fate#327159)
* Mon Feb 18 2019 mwilck@suse.com
  - Update to version 15.1.11 (git 54df192):
    * spec file: use more gentle wording in blacklist files
    * spec file: drop jffs2 and ubifs from blacklist
* Fri Feb 08 2019 mwilck@suse.com
  - Update to version 15.1.10 (git b28b13d):
  - implemented fs blacklisting logic (jsc#SLES-4085, fate#326832)
* Thu Jan 31 2019 mwilck@suse.com
  - Update to version 15.1.0 (git 6b07b88):
    * 50-blacklist.conf is not added in Leap before 15.1.
    fix conditionals and bump version accordingly.
* Wed Jan 30 2019 mwilck@suse.com
  - Update to version 15.0.20 (git 1396df5):
  - Fix driver-check.sh (boo#1123697, boo#1123704)
  - add /etc/modprobe.d/50-blacklist.conf from sysconfig package
    (boo#1107611)
  - Remove hard dependency on mkinitrd (boo#1123721)
  - Make sure code works also without kmod-compat
  - Replace file dependency on /sbin/depmod by weak package dependency
* Mon Dec 10 2018 Martin Wilck <mwilck@suse.com>
  - Move "weak-modules" script to -legacy subpackage to avoid
    dependency on binutils (bsc#1116665)
* Fri Dec 07 2018 Adrian Schröter <adrian@suse.de>
  - Require mkinitrd (provided also by dracut) directly instead of
    file requires. This is fixing image build failures
* Wed Nov 07 2018 mwilck@suse.com
  - Update to version 15.0.1 (git 5c63319):
  - Use /etc/modules-load.d/sg.conf for sg driver autoloading
    (bsc#1036463)
    * added /etc/modules-load.d/sg.conf
* Mon Nov 05 2018 mwilck@suse.com
  - version 15.0 (git 6ce3011)
  - modsign-verify: support for parsing PKCS#7 signatures
    (bsc#1111300, bsc#1105495)
  - Fix logic for unsupported modules (bsc#1111183)
    * SLES15: allow unsupported modules only if kernel-default-extra
    from SLE-WE module is installed
    * Always allow unsupported modules on Leap 15 and Factory
    * No change for SLE12 / Leap 42.x and below
    * 10-unsupported-modules.conf: improved comments
    * fix %config(noreplace) logic for 10-unsupported-modules.conf
  - added udev rule 81-sg.rules to make sure the sg module is
    always loaded (bsc#1036463)
* Wed Jul 26 2017 tchvatal@suse.com
  - Use path dependency that is not parsed by obs to ensure we
    are not pulling systemd everywhere
* Mon Jun 19 2017 tchvatal@suse.com
  - Set url to github project and repack using obs service
  - Cleanup a bit with spec-cleaner
  - Grep os-release and not deprecated SuSE-release
* Thu Sep 08 2016 dmueller@suse.com
  - blacklist efifb on aarch64 (bsc#996080)
* Fri May 27 2016 mmarek@suse.cz
  - Run dos2unix on the modhash script.
* Thu May 26 2016 jlee@suse.com
  - Add modhash tool to calculate hash of signed module.
    It strips X.509 or PKCS#7 signature before hash kernel module.
    (fate#319460)
* Wed May 25 2016 mmarek@suse.cz
  - Remove -x bit from 50-kernel-uname_r.conf (bsc#981291).
* Fri Apr 29 2016 mmarek@suse.cz
  - Ignore failures when loading the kernel sysctl (bsc#977715).
* Thu Apr 28 2016 mmarek@suse.com
  - Add a systemd service to load /boot/sysctl.conf-`uname -r`
    (bsc#977715).
* Fri Apr 01 2016 mmarek@suse.cz
  - Skip KMPs built from the kernel spec file directly (fate#319339)
  - Bump version number to 12.4
* Tue Feb 23 2016 lnussel@suse.de
  - add missing requirements on module-init-tools, findutils and gzip,
    mkinitrd (bnc#965830)
* Fri Jan 15 2016 bpoirier@suse.com
  - Add module option ib_mthca.catas_reset_disable=1 on ppc64le (bsc#456389).
* Tue Oct 13 2015 mmarek@suse.cz
  - Revert change for fate#319339, as some 3rd party KMPs are built
    with a modified template (bsc#949862).
* Tue Sep 08 2015 trenn@suse.de
  - Use /run instead of deprecated /var/run
    This can have sever consequences if this package uses /var/run. It may
    be installed before filesystem package generating the /run tmpfs and
    predict it to generate the link /var/run -> /run. Later dracut convertfs
    kicks in to generate it, but it has issues. bsc#922676
* Thu Aug 13 2015 mmarek@suse.cz
  - Only handle KMPs that are built using the %kernel_module_package
    macro (preparatory work for fate#319339).
* Tue Jun 23 2015 mmarek@suse.cz
  - Use absolute path to mkinitrd (bsc#935566)
* Fri May 16 2014 mmarek@suse.cz
  - Add kgraft/ to the depmod search list (fate#313296)
* Mon May 05 2014 tonyj@suse.com
  - Add support for ARM zImage to weak-modules2
* Tue Apr 15 2014 mmarek@suse.cz
  - weak-modules2: Use lsinitrd to list the modules in an initrd, so
    that initrds with early microcode work (bnc#873209, bnc#873113).
* Fri Apr 04 2014 mmarek@suse.cz
  - weak-modules2: Run mkinitrd in posttrans if $INITRD_IN_POSTTRANS
    is set (fate#313506)
* Fri Apr 04 2014 mmarek@suse.cz
  - regenerate-initrd-posttrans: Run mkinitrd_setup
* Fri Apr 04 2014 mmarek@suse.cz
  - Add macros for regenerating the initrd in %posttrans
    (fate#313506).
* Mon Mar 31 2014 mmarek@suse.cz
  - Use softdep to order {u,o,e}hci-hcd drivers.
  - Drop ia64 modprobe config.
* Fri Mar 28 2014 mmarek@suse.cz
  - Add kmp-install tool for easier installation of SolidDriver KMPs
    (fate#314581).
* Tue Mar 11 2014 mmarek@suse.cz
  - Add modsign-verify tool to verify signatures of modules
    (fate#314507).
* Tue Mar 11 2014 mmarek@suse.cz
  - weak-modules2: Support XZ compressed initrds (bnc#778119,
    bnc#867312)
* Mon Mar 10 2014 mmarek@suse.cz
  - The package cannot be noarch, because it installs different
    configs for different architectures.
  - Install 10-unsupported-modules.conf unconditionally, kmod has
    been patched.
* Fri Feb 07 2014 rsalevsky@suse.com
  - load the uas driver simulsimultaneously with the usb_storage driver and vice versa (bnc#862397)
* Wed May 29 2013 schwab@suse.de
  - weak-modules{,2}: also look for Image-$krel for aarch64
* Sun Mar 17 2013 crrodriguez@opensuse.org
  - The "allow_unsupported_modules" feature, does not belong too
    openSUSE, kmod (and hence udev and systemd) do not understand
    it in anyway. limit to SLE only.
* Wed Nov 14 2012 jengelh@inai.de
  - New package. Split SUSE-specific scripts from module-init-tools,
    so that we can actually get a system with kmod-compat running.

Files

/usr/lib/module-init-tools/weak-modules


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Oct 27 23:27:34 2021