Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

spamassassin-3.4.6-71.2 RPM for armv7hl

From OpenSuSE Ports Tumbleweed for armv7hl

Name: spamassassin Distribution: openSUSE Tumbleweed
Version: 3.4.6 Vendor: openSUSE
Release: 71.2 Build date: Sun Sep 26 06:27:32 2021
Group: Productivity/Networking/Email/Utilities Build host: obs-arm-11
Size: 456150 Source RPM: spamassassin-3.4.6-71.2.src.rpm
Packager: http://bugs.opensuse.org
Url: https://spamassassin.apache.org/
Summary: Extensible email filter which is used to identify spam
spamassassin adds a header line that shows if the mail has been
determined spam or not. This way, you can decide what to do with the
mail within the scope of your own filtering rules in your MUA (Mail
User Agent, your mail program) or your LDA (Local Delivery Agent).

See the files in the documentation directory
/usr/share/doc/packages/spamassassin/ for more information on how to
use the filter.

Provides

Requires

License

Apache-2.0

Changelog

* Thu Sep 09 2021 Peter Varkoly <varkoly@suse.com>
  - spamassassin: sa-update.timer does not work
    (bsc#1175375)
    Remove sence less SPAM_SA_UPDATE
    Document how to use sa-update.service
* Tue Apr 13 2021 Arjen de Korte <suse+build@de-korte.org>
  - update spamassassin to 3.4.6
    * Fixed URIDNSBL not triggering meta rules
    * Fix false positive in T_KAM_HTML_FONT_INVALID on CSS color !important
* Wed Mar 24 2021 Arjen de Korte <suse+build@de-korte.org>
  - update spamassassin to 3.4.5
    * In this release, there are bug fixes for one CVE:
      CVE-2020-1946 for Malicious rule configuration (.cf) files can
      be configured to run system commands (boo#1184221)
    * Improvements to OLEVBMacro and AskDNS plugins
    * Received and EnvelopeFrom headers matching improvements
    * userpref SQL schema fixes
    * rbl and hashbl evaluation improvements
    * fix for non working TxRep tag names
    * man page fixes
  - Update download links
* Fri Feb 12 2021 Pedro Monreal <pmonreal@suse.com>
  - Relax the crypto policies for the test-suite. This will allow the
    tests that use certificates with small key lengths to pass.
* Wed Dec 23 2020 Arjen de Korte <suse+build@de-korte.org>
  - Require perl(Mail::SpamAssassin) instead of perl-spamassassin
  - Don't use BerkeleyDB (not even for unit test)
  - Don't use is_opensuse conditional
* Sat Dec 19 2020 Thorsten Kukuk <kukuk@suse.com>
  - Move spamc into an own sub-package to avoid the full spamassassin
    installation on every client if there is a spamd server
* Thu Dec 17 2020 Arjen de Korte <suse+build@de-korte.org>
  - Compile rules in %post if Perl and/or spamassassin version changed
    and SPAM_SA_COMPILE=yes
  - Enable test (add basic-lint-without-sandbox.patch)
  - Ignore known warnings (add spamassassin-rpmlintrc)
* Wed Jan 29 2020 Arjen de Korte <suse+build@de-korte.org>
  - update spamassassin to 3.4.4
    * In this release, there are bug fixes for two CVEs:
      CVE-2020-1931 for Nefarious rule configuration (.cf) files can
      be configured to run system commands with warnings.
      (boo#1162200)
      CVE-2020-1930 for Nefarious rule configuration (.cf) files can
      be configured to run system commands with sa-compile.
      (boo#1162197)
    * Improvements to OLEVBMacro
    * Fix for CRLF handling with SpamAssMilter & DKIM
    * Small fix for a regexp to provide Perl 5.8.x compatability again
    * Increased fns_extrachars default value to 50
    * Fixed nosubject and maxhits tflags when sa-compile is used
    * Limited the Bayes parsed token count
    * Improvements to whitespace trimming
* Sat Dec 14 2019 Arjen de Korte <suse+build@de-korte.org>
  - remove old (compiled) rules in /var/lib/spamassassin directory
    after package upgrade and remove entirely upon package removal
  - add BuildRequires for perl(Archive::Zip) and perl(IO::String)
* Thu Dec 12 2019 Arjen de Korte <suse+build@de-korte.org>
  - update spamassassin to 3.4.3
    * There is one new plugin (disabled by default)
      OLEVBMacro - Detects both OLE macros and VB code inside Office
      documents
    * Two CVE security bug fixes are included in this release
      CVE-2019-12420 for Multipart Denial of Service Vulnerability
      (boo#1159133)
      CVE-2018-11805 for nefarious CF files can be configured to
      run system commands without any output or errors
      (boo#1118987)
    * Safer and faster scanning of large emails using
      body_part_scan_size and rawbody_part_scan_size settings.
    * New tflag "nosubject" for 'body' rules, to stop matching the
      Subject header which is part of the body text.
    * Security updates include deprecation of the unsafe sa-update
      '--allowplugins' option, which now prints a warning that
      '--reallyallowplugins' is required to use it.
* Tue Dec 10 2019 Dirk Stoecker <opensuse@dstoecker.de>
  - Increase maximum size for spampd to 7168
* Sat Nov 09 2019 Arjen de Korte <suse+build@de-korte.org>
  - Change architecture of perl modules to 'noarch'
* Fri Nov 08 2019 Arjen de Korte <suse+build@de-korte.org>
  - Fix extraction command for default rules (proper fix for
    boo#911355, rather than a workaround)
  - Don't unconditionally run sa-update on spamd and spampd service
    start as this doesn't honor the settings in /etc/sysconfig/spamd
  - After running sa-update, only restart services if they were
    running before
  - Fix name in logging timed-sa-update (suse.cron-sa-update
    doesn't exist anymore)
* Sun Oct 27 2019 Arjen de Korte <suse+build@de-korte.org>
  - update spampd to 2.53
    * Fix LMTP delivery with multiple recipients
    * Fix Warning for "Use of uninitialized value in string"
    update spampd to 2.52
    * Override Net::Server's HUP handling, just restart children
    * Add --version option to print information about SpamPD,
      Net::Server, SpamAssassin, and Perl.
    * Add warnings about using deprecated options.
    * Documentation updates and code cosmetics.
  - Update download links (add for spampd and iXhash2 sources)
  - Add source verification (add spamassassin.keyring)
  - Add %{perl_requires} for perl-Mail-SpamAssassin
  - Fix "PIDFile= references a path below legacy directory /var/run/"
    (change /var/run/ -> /run/)
  - Don't package README.SuSE which documents an init script that
    was never bundled boo#1068469
* Tue Jun 11 2019 Dominique Leuenberger <dimstar@opensuse.org>
  - BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
    shortcut the build queues by allowing usage of systemd-mini
* Wed Jan 16 2019 Jan Engelhardt <jengelh@inai.de>
  - Reduce boilerplate generated by %service_*.
* Wed Jan 16 2019 Peter Varkoly <varkoly@suse.com>
  - bsc#1115411 spamassassin: migrate from cron to systemd timers
  - Apply %license macro
* Tue Sep 18 2018 Arjen de Korte <suse+build@de-korte.org>
  - update spamassassin to 3.4.2
    * There are four new plugins (disabled by default)
      HashBL - interface to The Email Blocklist (EBL)
      ResourceLimits - assure your spamd child processes do not exceed
      specified CPU or memory limit
      FromNameSpoof - detection of the From:name field being used to
      mislead
      Phishing - finds uris used in phishing campaigns detected by
      OpenPhish (https://openphish.com) or PhishTank
      (https://phishtank.com) feeds
    * For security reasons SSLv3 support has been removed from spamc(1).
    * Four CVE security bug fixes are included in this release for
      PDFInfo.pm and the SA core: CVE-2017-15705, CVE-2016-1238,
      CVE-2018-11780 & CVE-2018-11781.
    * In sa-update script, optional support for SHA-256 / SHA-512 in
      addition to or instead of SHA1 has been added for better validation
      of rules.
    * GeoIP2 support has been added to RelayCountry and URILocalBL plugins
      due to GeoIP legacy API deprecations.
    * several new or enhanced configuration options
  - update spampd to 2.51
    * Replace IO::Socket::INET with IO::Socket::IP for IPv6 support
    * Unix ports (ability to listen on UNIX sockets)
    * Add X-Envelope-* headers before Received
    * Add /usr/local/bin and /usr/local/sbin to PATH
    * Add --setsid option to start server with setsid if running in
      background
  - Removed patches (are now in upstream):
    * 0001-bug-7361-Allow-building-against-OpenSSL-1.1.0.patch
    * 0001-Fix-bug-7367-Don-t-assume-cwd-.-is-in-INC-it-may-be-.patch
    * DNS-resolver-recursion-desired-not-set.patch
    * spamassassin-dont_use_SSLv3_methods.patch
    * spampd-2.42_git_20170226.patch
    * Unescaped_left_brace_in_regex_is_deprecated.patch
* Mon Sep 17 2018 Arjen de Korte <suse+build@de-korte.org>
  - Revert incompatibility-with-NET-DNS.patch (this patch attempts to
    fix a problem that was already solved by bsc#1059210)
* Thu Sep 13 2018 varkoly@suse.com
  - bsc#1107765 - spamassassin: incompatibility with Net::DNS >= 1.01
    - Add upstream patch:
    incompatibility-with-NET-DNS.patch
* Sun Sep 09 2018 varkoly@suse.com
  - bsc#1069831 Running sa-update from spamassassin gives warning
    about deprecated regex
    o remove deprecated-regex.patch and apply upstream patch:
      Unescaped_left_brace_in_regex_is_deprecated.patch
    This patch also fixes the bug PerMsgStatus Warning
    https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7196
* Mon Feb 19 2018 varkoly@suse.com
  - bsc#1069831 Running sa-update from spamassassin gives warning about deprecated regex
    o add deprecated-regex.patch
* Thu Jan 18 2018 varkoly@suse.com
  - bsc#1059210 spamassassin perl dns resolver recursion desired not set
    o add DNS-resolver-recursion-desired-not-set.patch

Files

/usr/bin/sa-awl
/usr/bin/sa-check_spamd
/usr/bin/sa-compile
/usr/bin/sa-learn
/usr/bin/sa-update
/usr/bin/spamassassin
/usr/lib/systemd/system/sa-update.service
/usr/lib/systemd/system/sa-update.timer
/usr/lib/systemd/system/spamd.service
/usr/lib/systemd/system/spampd.service
/usr/sbin/rcspamd
/usr/sbin/rcspampd
/usr/sbin/spamd
/usr/sbin/spampd
/usr/sbin/timed-sa-update
/usr/share/doc/packages/spamassassin
/usr/share/doc/packages/spamassassin/PROTOCOL
/usr/share/doc/packages/spamassassin/README
/usr/share/doc/packages/spamassassin/README.SUSE
/usr/share/doc/packages/spamassassin/README.vpopmail
/usr/share/fillup-templates/sysconfig.spamd
/usr/share/fillup-templates/sysconfig.spampd
/usr/share/man/man1/sa-awl.1.gz
/usr/share/man/man1/sa-check_spamd.1.gz
/usr/share/man/man1/sa-compile.1.gz
/usr/share/man/man1/sa-learn.1.gz
/usr/share/man/man1/sa-update.1.gz
/usr/share/man/man1/spamassassin-run.1.gz
/usr/share/man/man1/spamassassin.1.gz
/usr/share/man/man1/spamd.1.gz
/var/lib/spamassassin


Generated by rpm2html 1.8.1

Fabrice Bellet, Fri Nov 19 23:17:08 2021