Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

lua-libprelude-5.2.0-1.9 RPM for armv7hl

From OpenSuSE Ports Tumbleweed for armv7hl

Name: lua-libprelude Distribution: openSUSE Tumbleweed
Version: 5.2.0 Vendor: openSUSE
Release: 1.9 Build date: Sun Sep 26 00:43:37 2021
Group: Development/Languages/Lua Build host: obs-arm-10
Size: 334453 Source RPM: libprelude-5.2.0-1.9.src.rpm
Packager: http://bugs.opensuse.org
Url: https://www.prelude-siem.org
Summary: Lua bindings for libprelude
Lua bindings for libprelude generated by SWIG.

Provides

Requires

License

LGPL-2.1-only AND LGPL-2.1-or-later

Changelog

* Sun Oct 25 2020 Andreas Stieger <andreas.stieger@gmx.de>
  - libprelude 5.2.0:
    * license switched to LGPL
    * Add Python 3.7/3.8 suppo
    * Update to SWIG 4.0.1
    * Implement prelude_msg_clone()
    * Update libprelude-error for GAWK 5.0
    * Various IDMEF criteria improvements
  - drop upstreamed patches:
    * libprelude-linking.patch
    * libprelude-fix_awk_error.patch
    * libprelude-fix_py38.patch
  - add libprelude-5.2.0-ruby2.7.patch on Tumbleweed to fix build
    with ruby 2.7
  - package license with every package
  - add upstream signing key and verify source signature
* Fri Oct 25 2019 thomas.andrejak@gmail.com
  Bump version 5.1.1
    - Update internal dependencies (SWIG, ...)
    - Better support for unicode
    - Fully support Python3
    - Better features for debugging
    - Fix various bugs
  - CPP Soname bump 8 to 12
  - Add patchs:
    - libprelude-fix_awk_error.patch
    - Support of recents awk versions
    - libprelude-fix_gtkdoc_1.32.patch
    - Support of recents gtkdoc versions
    - libprelude-fix_py38.patch
    - Add support for Python3.8
  - Remove patch:
    - libprelude-disable_gnulib_test_lock.patch
    - Fixed upstream
  - Remove Python 2 support
    - Python 2 will be removed step by step in all Linux distributions
* Fri Mar 01 2019 thomas.andrejak@gmail.com
  Bump version 5.0.0
  - Remove patchs included in new version
    - libprelude-fix_compatibility_gnutls_3_6.patch
    - libprelude-gtk-doc.patch
  - Add new patch for 64bit portability
    - libprelude-fix_64bit_portability_issues.patch
* Wed Oct 04 2017 thomas.andrejak@gmail.com
  - Bump to libprelude 4.0.0
  - Add patchs:
    - libprelude-disable_gnulib_test_lock.patch: Known bug on gnulib side and
      will be fixed
    - libprelude-fix_prelude_tests_timer.patch: Wrong test
    - libprelude-fix_pthread_atfork.patch: pthread_atfork was automatically
      linked before but not anymore
    - libprelude-fix_timegm.patch: Fix time comparaison
    - libprelude-fsf-address.patch: Wrong FSF address
    - libprelude-gtk-doc.patch: gtk-doc removed gtkdoc-tmpl so gtk-doc.make and
      gtk-doc.m4 need to be updated
    - libprelude-linking.patch: Correctly link for Perl bindings
    - libprelude-fix_compatibility_gnutls_3_6.patch: Fix compatibility with
      GnuTLS 3.6
  - Remove libgcrypt-devel from BuildRequires since upstream totally move to
    gnutls
  - Rename python-prelude to python2-prelude
* Tue Apr 25 2017 thomas.andrejak@gmail.com
  - Rename %soname to %sover to better reflect its use
* Sun Nov 27 2016 thomas.andrejak@gmail.com
  - Update to 3.1.0 (Prelude 3.1.0 released on 14 Sept 2016)
  - Remove unnecessary patches
    - libprelude-fsf-address.patch
    - libprelude-rpm-opt-flags.patch
    - libprelude-ruby-include-path.patch
    - libprelude-python-swig.patch
    - libprelude-ruby-swig.patch
  - Use a lib directory with soname
  - Spec-Cleaner
* Mon May 02 2016 thomas.andrejak@gmail.com
  - Update to 3.0.0 (Prelude 3.0.0 released on 22 Apr 2016)
  - Add few patches to build with all bindings and reduce rpmlint
    notices :
    * libprelude-fsf-address.patch
    * Correct the Free Software Foundation address
    * libprelude-python-swig.patch
    * Regenerate swig file to compile with Python 3.4 and newer
    * libprelude-ruby-swig.patch
    * Temporary fix http://bugs.ruby-lang.org/issues/11962
    * libprelude-ruby-include-path.patch
    * Fix ruby include path. Instead, we can not turn ruby
      binding on
    * libprelude-rpm-opt-flags.patch
    * Fix libprelude do not load global CFLAGS for
      libprelude-error
  - We now build all bindings, adding :
    * lua-libprelude
    * python3-libprelude
    * ruby-libprelude
  - Create a new package with only tools files because packages
    started with "lib" do not have to come with tools. Name of the
    package : prelude-tools
  - Precise license :
    * Prelude is GPL-2.0+
    * libmissing is LGPL-2.1+
    * libmissing/test is GPL-3.0+
  - Remove support for older SUSE than 12 since libprelude do not
    compile on it
* Sat Nov 14 2015 mardnh@gmx.de
  - update to 1.2.6
  - removed patches (all fixed upstream)
    * opensuse12_compile.patch
    * libprelude-1.0.1-fixgnulib.patch
    * libprelude-1.0.0-gcc46.patch
    * libprelude-sles12sp2.patch
    * libprelude-fixlibgnutls3.0.5.patch
    * libprelude-ruby1.9.patch
    * libprelude-fsf-address.patch
    * libprelude-swig-3.0.patch
  - disabled lua and ruby bindings for now
* Mon Jan 26 2015 dimstar@opensuse.org
  - Add libprelude-swig-3.0.patch: Fix build with swig 3.0.
* Tue Jul 09 2013 schwab@suse.de
  - Override broken configure checks
* Tue Apr 09 2013 Greg.Freemyer@gmail.com
  - change license to GPLv3.0+ due to libmissing being incorporated (bnc#814000)
  - remove requirement for libgnutls-devel as done previously (see below)
* Fri Apr 05 2013 pth@suse.de
  - Add a definition of perl_gen_filelist for SLE11 to the spec file.
* Thu Mar 28 2013 Greg.Freemyer@gmail.com
  - Update to v1.0.1
  - Add these patches
    * libprelude-1.0.1-fixgnulib.patch
    * libprelude-1.0.0-gcc46.patch
    * libprelude-fixlibgnutls3.0.5.patch
    * libprelude-ruby1.9.patch
    * libprelude-fsf-address.patch
    * libprelude-sles12sp2.patch
  - Create new subpackages
    * libprelude-doc
    * ruby-libprelude
    * perl-libprelude
    * python-libprelude
* Mon Dec 05 2011 aldemir.akpinar@airties.com
  - Added a simple patch file to fix the compile error for OpenSUSE 12.1
* Mon Nov 07 2011 lars@linux-schulserver.de
  - build require libgcrypt-devel
  - use gnutls-devel instead of libgnutls-devel to build on old
    distributions (package provides both names)
* Wed Oct 20 2010 jooop.boonen@opensuse.org
  - fixed to used pkg-config in stead of libgnutls-config
    so it builds with >= gnutls-2.7.0
* Sat Jul 24 2010 bitshuffler@opensuse.org
  - Initial package

Files

/usr/lib/lua/5.4/prelude.so
/usr/share/licenses/lua-libprelude
/usr/share/licenses/lua-libprelude/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 23:48:49 2021