Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libtcnative-1-0-1.2.23-2.6 RPM for armv7hl

From OpenSuSE Ports Tumbleweed for armv7hl

Name: libtcnative-1-0 Distribution: openSUSE Tumbleweed
Version: 1.2.23 Vendor: openSUSE
Release: 2.6 Build date: Sat May 29 03:12:10 2021
Group: Productivity/Networking/Web/Servers Build host: armbuild16
Size: 198834 Source RPM: libtcnative-1-0-1.2.23-2.6.src.rpm
Packager: http://bugs.opensuse.org
Url: https://tomcat.apache.org/tomcat-7.0-doc/apr.html
Summary: JNI wrappers for Apache Portable Runtime for Tomcat
Tomcat can use the Apache Portable Runtime to provide superior
scalability, performance, and better integration with native server
technologies. The Apache Portable Runtime is a highly portable library
that is at the heart of Apache HTTP Server 2.x. APR has many uses,
including access to advanced IO functionality (such as sendfile, epoll
and OpenSSL), OS level functionality (random number generation, system
status, etc), and native process handling (shared memory, NT pipes and
Unix sockets).

These features allows making Tomcat a general purpose webserver, will
enable much better integration with other native web technologies, and
overall make Java much more viable as a full fledged webserver platform
rather than simply a backend focused technology.

Provides

Requires

License

Apache-2.0

Changelog

* Thu Nov 07 2019 Matei Albu <malbu@suse.com>
  - Add GPG keyring.
* Mon Aug 12 2019 Matei Albu <malbu@suse.com>
  - Version update to version 1.2.23:
    * See changelog.html for in-depth upstream changes
* Thu Jun 06 2019 Matei <malbu@suse.com>
  - Version update to version 1.2.21:
    * See changelog.html for in-depth upstream changes
    * Fix incompatibility with Tomcat (bsc#1130843)
* Mon Nov 27 2017 fstrba@suse.com
  - Version update to version 1.2.16:
    * See changelog.html for in-depth upstream changes
    * Fixes build breakage with newer version of openssl
* Wed Feb 03 2016 tchvatal@suse.com
  - Version update to version 1.2.4:
    * See changelog.html for in-depth upstream changes
    * This connector to properly work requires openssl 1.0.2 or newer
      so do not backport to other codestreams.
* Wed Feb 25 2015 tchvatal@suse.com
  - Remove keyring file as there is new keyring and I didn't find it
    on the web
* Thu Feb 19 2015 p.drouand@gmail.com
  - Update to version 1.1.32
    * Fix: 53952: Add support for TLSv1.2 and TLSv1.1.
    * Fix: 56844: Use OpenSSL 1.0.1j with Windows binaries.
    * Update: Use APR 1.5.1 with Windows binaries
  - Remove tomcat-native-nosslv2.patch; merged on upstream release
  - Remove %gpg_verify tag and gpg-offline require; let OBS handles
    gpg verification
* Sun Apr 27 2014 crrodriguez@opensuse.org
  - version 1.1.30
    * Fixed double-free in ssl_ocsp_request. Patch provided by
    Aristotelis.
    * Other minor bugfixes.
  - openSUSE: Fix build when openssl does not have SSLv2 support.
    (tomcat-native-nosslv2.patch)
* Fri Sep 13 2013 mvyskocil@suse.com
  - Update to 1.1.27 (bugfix release)
    * fix high CUP usage on client's IP address change
    * add CPU information to OS info for Linux
    * fix FIPS mode for listeners; resolves 'Low level API
      call to digest MD5 forbidden in FIPS mode!' errors.
    * update add clearOptions function to allow access to
      OpenSSL's SSL_CTX_clear_options function.
    * fix regression in pollset return value.
  - add gpg verification
  - add javapackages-tools
  - drop config-guess-sub-update.patch
* Sun Mar 31 2013 schwab@suse.de
  - config-guess-sub-update.patch: update config.guess/sub for aarch64

Files

/usr/lib/libtcnative-1.so
/usr/lib/libtcnative-1.so.0
/usr/lib/libtcnative-1.so.0.2.23
/usr/share/doc/packages/libtcnative-1-0
/usr/share/doc/packages/libtcnative-1-0/CHANGELOG.txt
/usr/share/doc/packages/libtcnative-1-0/LICENSE
/usr/share/doc/packages/libtcnative-1-0/NOTICE
/usr/share/doc/packages/libtcnative-1-0/README.txt


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 30 23:41:30 2021