Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libjavascriptcoregtk-4_1-0-2.44.2-2.1 RPM for aarch64

From OpenSuSE Ports Tumbleweed for aarch64

Name: libjavascriptcoregtk-4_1-0 Distribution: openSUSE Tumbleweed
Version: 2.44.2 Vendor: openSUSE
Release: 2.1 Build date: Fri May 17 22:40:00 2024
Group: System/Libraries Build host: reproducible
Size: 16958953 Source RPM: webkit2gtk3-2.44.2-2.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://webkitgtk.org
Summary: JavaScript Core Engine, GTK+ Port
WebKit is a web content engine, derived from KHTML and KJS from KDE,
and used primarily in Apple's Safari browser.  It is made to be
embedded in other applications, such as mail readers, or web browsers.

It is able to display content such as HTML, SVG, XML, and others. It
also supports DOM, XMLHttpRequest, XSLT, CSS, Javascript/ECMAscript and
more.

Provides

Requires

License

BSD-3-Clause AND LGPL-2.0-or-later

Changelog

* Fri May 17 2024 Michael Gorse <mgorse@suse.com>
  - Update to version 2.44.2 (boo#1225071):
    + Make gamepads visible on axis movements, and not only on
      button presses.
    + Disable the gst-libav AAC decoder.
    + Make user scripts and style sheets visible in the Web
      Inspector.
    + Use the geolocation portal where available, with the existing
      geoclue as fallback if the portal is not usable.
    + Use the printing portal when running sandboxed.
    + Use the file transfer portal for drag and drop when running
      sandboxed.
    + Avoid notifying an empty cursor rectangle to input methods.
    + Remove empty bar shown in detached inspector windows.
    + Consider keycode when activating application accelerators.
    + Fix the build with ENABLE_WEBAUDIO disabled.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2024-27834.
  - Update keyring (taken from rawhide).
* Tue Apr 16 2024 Michael Gorse <mgorse@suse.com>
  - Update to version 2.44.1:
    + Fix handling of lifetime of web view child dialogs in GTK4.
    + Do not schedule layer flushes when drawing area size is empty.
    + Fix videos with alpha when using the DMA-BUF sink.
    + Fix the build with USE_GBM=OFF.
    + Fix the build in 32bit platforms
    + Fix several crashes and rendering issues.
  - Drop webkit2gtk3-271108.patch: fixed upstream.
* Wed Mar 20 2024 Michael Gorse <mgorse@suse.com>
  - Use WebAssembly on aarch64. It is the upstream default and no
    longer makes the build fail. Stop passing -DENABLE_C_LOOP=ON,
    - DENABLE_WEBASSEMBLY=OFF and -DENABLE_SAMPLING_PROFILER=OFF for
    the same reason.
  - Drop webkit2gtk3-llint-build-fix.patch: no longer needed.
  - Update some version requirements to match cmake checks.
* Mon Mar 18 2024 Dominique Leuenberger <dimstar@opensuse.org>
  - Add webkit2gtk3-271108.patch: Fix build on 32bit archs
    (https://bugs.webkit.org/show_bug.cgi?id=271108).
* Sat Mar 16 2024 Dominique Leuenberger <dimstar@opensuse.org>
  - Update to version 2.44.0 (boo#1222010):
    + Make the DOM accessibility tree reachable from UI process with
      GTK4.
    + Removed the X11 and WPE renderers in favor of DMA-BUF.
    + Improved vblank synchronization when rendering.
    + Removed key event reinjection in GTK4 to make keyboard
      shortcuts work in web sites.
    + Fix gamepads detection by correctly handling focused window in
      GTK4.
    + Security fixes: CVE-2024-23252, CVE-2024-23254, CVE-2024-23263,
    CVE-2024-23280, CVE-2024-23284, CVE-2023-42950, CVE-2023-42956,
    CVE-2023-42843.
  - Rebase webkit2gtk3-disable-dmabuf-nvidia.patch.
* Tue Mar 05 2024 Dominique Leuenberger <dimstar@opensuse.org>
  - baselibs.conf: Do not build libjavascriptcoregtk-4_1-0-32bit and
    libwebkit2gtk-4_1-0-32bit: they are not used, and in fact not
    built in Factory (build excluded).
* Thu Feb 29 2024 Dominique Leuenberger <dimstar@opensuse.org>
  - Update to version 2.43.4:
    + Remove key event reinjection in GTK4 to make keyboard shortcuts
      work in web sites.
    + Use the new GTK API to create a GdkTexture from a DMA-BUF
      buffer when available.
    + Fix rendering when GTK is using the vulkan renderer.
    + Fix gamepads detection by correctly handling focused window in
      GTK4.
    + Fix rendering after history navigation.
    + Write bwrapinfo.json to disk for xdg-desktop-portal.
    + Fixed several memory leaks in media backend.
    + Fix several crashes and rendering issues.
  - Changes from version 2.43.3:
    + Show vblank monitor information in webkit://gpu.
    + Fallback to timer based vblank monitor if drmWaitVBlank fails.
    + Fix several memory leaks in media backend.
    + Fix several crashes and rendering issues.
  - Changes from version 2.43.2?
    + Remove the X11 and WPE renderers.
    + Release unused buffers when the view is hidden.
    + Fix flickering while playing videos with DMA-BUF sink.
    + Do not special case the "sans" font family name.
    + Fix webkit_web_context_allow_tls_certificate_for_host() for
      IPv6 URIs produced by SoupURI.
    + Fix several crashes and rendering issues.
  - Changes from version WebKitGTK 2.43.1?
    + Improve vblank synchronization when rendering.
    + Improve DMA-BUF buffers handling for video frames.
    + Use the buffer format preferred by the driver in DMA-BUF
      renderer.
    + Do not block the compositing thread waiting for rendering
      threads.
    + Improve performance when scaling images in a canvas.
    + Fix several crashes and rendering issues.
    + Updated translations.
  - Drop webkit2gtk3-create-destroy-egl-image.patch: fixed upstream.
  - Add libbacktrace-devel BuildRequires (for gtk4 flavor).
* Fri Feb 16 2024 Michael Gorse <mgorse@suse.com>
  - Increase mem_per_process again to match what is in SLE. The build
    was sporadically failing there (bsc#1198743).
  - Require libwaylandclient0 >= 1.20. 15.4 originally had 1.19.0,
    but webkitgtk uses a function added in 1.20.0, so we need to
    ensure that the wayland update is pulled in (bsc#1215072).
* Thu Feb 15 2024 Michael Gorse <mgorse@suse.com>
  - Fix package names for v6, and obsolete old packages.
* Wed Feb 14 2024 Michael Gorse <mgorse@suse.com>
  - Use gcc 11 on SLE, to match what is currently used on SP4, and
    adjust version check to include SP6. Also, use system malloc
    there; the build currently fails without this (webkit#243535).
  - Require gcc >= 10.2 to match the current cmake test.
  - Disable jpegxl on SLE; it isn't currently available there.
* Mon Feb 05 2024 Michael Gorse <mgorse@suse.com>
  - Update to version 2.42.5 (boo#1219604):
    + Fix webkit_web_context_allow_tls_certificate_for_host to
      handle IPv6 URIs produced by SoupURI.
    + Ignore stops with offset zero before last one when rendering
      gradients with cairo.
    + Write bwrapinfo.json to disk for xdg-desktop-portal.
    + Fix gamepads detection by correctly handling focused window in
      GTK4.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2024-23222, CVE-2024-23206, CVE-2024-23213.
  - Drop webkit2gtk3-CVE-2024-23222.patch: fixed upstream.
  - Add webkit2gtk3-llint-build-fix.patch: fix the build for non-x86
    architectures.
* Wed Jan 24 2024 Michael Gorse <mgorse@suse.com>
  - Add webkit2gtk3-CVE-2024-23222.patch: fix a type confusion issue
    (bsc#1219113 CVE-2024-23222).
* Sat Dec 16 2023 Michael Gorse <mgorse@suse.com>
  - Update to version 2.42.4 (boo#1218032):
    + Fix incorrect random images incorrectly displayed as
      backgrounds of <div> elements.
    + Fix videos displayed aliased after being resized e.g. in
      YouTube.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2023-42883.
* Wed Dec 06 2023 Michael Gorse <mgorse@suse.com>
  - Update to version 2.42.3 (boo#1217844):
    + Fix flickering while playing videos with DMA-BUF sink.
    + Fix color picker being triggered in the inspector when typing
      "tan".
    + Do not special case the "sans" font family name.
    + Fix build failure with libxml2 version 2.12.0 due to an API
      change.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2023-42916, CVE-2023-42917.
* Tue Nov 28 2023 Dominique Leuenberger <dimstar@opensuse.org>
  - Adjust path to (openSUSE renamed) gst-plugin-scanner in the code
    using sed.
* Tue Nov 21 2023 Dominique Leuenberger <dimstar@opensuse.org>
  - Ensure max_link_jobs and max_compile_jobs have valid values even
    when %{jobs} is not defined (like when building outside of OBS).
* Thu Nov 16 2023 Michael Gorse <mgorse@suse.com>
  - Update to version 2.42.2 (boo#1217210):
    + Bump Safari version in user agent header.
    + Fix CSP regression that broke Unity WebGL applications.
    + Fix the build with GBM disabled.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2023-41983, CVE-2023-42852.
* Wed Nov 01 2023 Mike Gorse <mgorse@suse.com>
  - Add webkit2gtk3-disable-dmabuf-nvidia.patch: disable DMABuf
    renderer for NVIDIA proprietary drivers (boo#1216778).
* Mon Oct 23 2023 Mike Gorse <mgorse@suse.com>
  - Add webkit2gtk3-create-destroy-egl-image.patch: fix "No provider
    of EglDestroyImage Found" (boo#1216483).
* Fri Sep 29 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.42.1 (boo#1215661 boo#1215866 boo#1215867
    boo#1215868 boo#1215869 boo#1215870):
    + Fix enable-html5-database setting to properly enable/disable
      IndexedDB API.
    + Fix the build with GBM disabled.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2023-41993, CVE-2023-40414.
* Thu Sep 28 2023 Marcus Meissner <meissner@suse.com>
  - switch to pkgconfig(icu-i18n) instead of libicu-devel, to allow
    switching to a different libicu*-devel (jsc#PED-6193)
* Fri Sep 15 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.42.0 (boo#1218033 boo#1222905):
    + New renderer based on DMA-BUF shared buffers.
    + Add new permission request to handle DOM paste access requests.
    + Add API to configure experimental features at runtime.
    + Add API to set the percentage of volume space that can be used
      for data storage.
    + GBM is no longer required for WebGL implementation.
    + Security fixes: CVE-2023-39928, CVE-2023-41074, CVE-2023-32359,
      CVE-2023-42890, CVE-2014-1745, CVE-2024-23226.
* Mon Sep 11 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.41.92:
    + Fix render updates after cross origin history navigation with
      GTK4.
    + Fix flickering in non accelerated compositing mode.
    + Fix pixelated accelerated blur filter.
    + Fix web process launching when xdg-dbus-proxy is not installed.
    + Pass GBM_BO_USE_RENDERING to gbm_bo_create.
    + Fix several crashes and rendering issues.
* Fri Sep 01 2023 Luciano Santos <luc14n0@opensuse.org>
  - Expand lang sub-package in spec file unconditionally to handle
    previous name change from WebKit2GTK-lang to WebKitGTK-lang. This
    change affected the automatic generated Requires tag on
    WebKit2GTK-%{_apiver}, then getting out of sync of what's being
    required and what's being provided. Now, any sub-package that was
    providing WebKit2GTK-%{_apiver} will provide WebKitGTK-%{_apiver}
    instead (boo#1214835, boo#1214640, boo#1214093).
* Thu Aug 31 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Add explicit pkgconfig(epoxy) and pkgconfig(xdamage)
    BuildRequires: meson setup checks for them, so we should list
    them.
* Mon Aug 21 2023 Michael Gorse <mgorse@suse.com>
  - Update to version 2.41.91:
    + Properly handle toplevel window state changes in GTK4.
    + Do not keep processing frames while the view is unrealized
      when using DMA-BUF renderer.
    + Fallback to first render node returned by DRM when failing to
      get using EGLDevice.
    + Fix the build with libjxl < 0.7.0.
    + Fix several crashes and rendering issues.
* Sun Aug 13 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.41.90:
    + Fix the popup menu always shown in github when logged in.
    + Add API to replace and retrieve the entire cookie jar.
    + Apply the device scale factor when changed after web view is
      created.
    + Do not expose media devices that can’t be used in
      enumerateDevices.
    + Add support for P010 video format.
    + Fix non-accelerated rendering that broke web inspector.
    + Fix several crashes and rendering issue
  - Temp disable LTO during build via define.
* Wed Aug 02 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.41.6:
    + Add API to set the percentage of volume space that can be used
      for data storage.
    + Do not use GBM and DMA-BUF for WebGL implementation.
    + Use EGL_MESA_image_dma_buf_export if available when GBM is
      disabled.
    + Fix AV1 video with the dav1d decoder when using the DMA-BUF
      sink.
    + Use three buffers for DMA-BUF renderer.
    + Fix several crashes and rendering issues.
  - Changes from version 2.41.5:
    + Include key modifiers in wheel events.
    + Remove support for OpenGL API in the web process.
    + Native DASH support is now opt-in, like HLS.
    + Fix scrollbar jumping to top when drag released outside window
      in GTK4.
    + Fix contents not rendered in new web view when realized after
      configure and frame with DMA-BUF renderer.
    + Fix several crashes and rendering issues.
  - Changes from version 2.41.4:
    + Add new API to configure experimental features at runtime.
    + Add support for prefers-reduced-motion media query.
    + Split hardware acceleration information in webkit://gpu.
    + Fix CPU usage on autoplaying videos.
    + Fix video rendering when GL is disabled.
    + Choose amount of painting threads depending on available CPU
      cores on GTK4.
    + Add memory usage of images in web inspector memory timeline.
    + Fix the build with X11 target disabled.
    + Fix several crashes and rendering issues.
  - Changes from version 2.41.3:
    + Ensure the same GPU device is used by GBM in all processes.
    + Fix memory corruption causing glitches in several web sites.
    + Use more reliable generated application ID.
    + Show DRM device and render node files when available in
      webkit://gpu.
    + Fix the build on i386.
    + Fix several crashes and rendering issues.
  - Changes from version 2.41.2:
    + Properly handle the modifier value when exporting/importing
      DMA-BUF buffers.
    + Don’t require GApplication for bubblewrap sandbox.
    + Fix cap height calculation in font metrics.
    + Fix the build on i386.
    + Fix the build with libgbm disabled.
    + Fix several crashes and rendering issues.
    + Updated translations.
  - Changes from version 2.41.1:
    + Use DMABuf and WebKit IPC for rendering instead of wpe/x11.
    + Calculate scroll step depending on scrollable area size when
      scrolling with the mouse wheel or arrow keys.
    + Add WebKitClipboardPermissionRequest to handle DOM paste access
      requests.
    + Remove support for rendering with GLX in the web process.
    + Fix several crashes and rendering issues.
  - Add pkgconfig(libjxl) BuildRequires: New dependency.
* Wed Aug 02 2023 Michael Gorse <mgorse@suse.com>
  - Update to version 2.40.5 (boo#1213905 boo#1215230):
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2023-38133, CVE-2023-38572, CVE-2023-38592,
      CVE-2023-38594, CVE-2023-38595, CVE-2023-38597, CVE-2023-38599,
      CVE-2023-38600, CVE-2023-38611, CVE-2023-40397, CVE-2023-39434,
      CVE-2023-40451.
* Fri Jul 21 2023 Michael Gorse <mgorse@suse.com>
  - Update to version 2.40.4 (boo#1213379):
    + Fix a bug in JavaScript reading variable arguments in a call.
    + Security fixes: CVE-2023-37450.
* Wed Jun 28 2023 Michael Gorse <mgorse@suse.com>
  - Update to version 2.40.3 (boo#1212863):
    + Make memory pressure monitor honor memory.memsw.usage_in_bytes
      if exists.
    + Include key modifiers in wheel events.
    + Apply cookie blocking policy to WebSocket handshakes.
    + Remove accidental dependency on GLib 2.70.
    + Fix the build with BUBBLEWRAP_SANDBOX disabled.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2023-32439.
* Wed May 31 2023 Michael Gorse <mgorse@suse.com>
  - Update to version 2.40.2 (boo#1211846):
    + Fix scrollbar jumping to top when drag released outside window
      in GTK4.
    + Fix video rendering when GL is disabled.
    + Fix flickering on looped videos when starting again.
    + Fix CPU usage on autoplaying videos.
    + Choose amount of painting threads depending on available CPU
      cores on GTK4.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2023-28204, CVE-2023-32373 (boo#1211658
      boo#1211659).
  - Drop gcc13-fix.patch: fixed upstream.
* Thu Apr 20 2023 Michael Gorse <mgorse@suse.com>
  - Update to version 2.40.1 (boo#1210295 boo#1210731):
    + The Bubblewrap sandbox no longer requires setting an
      application identifier via GApplication to operate correctly.
      Using GApplication is still recommended, but optional.
    + Adjust the scrolling speed for mouse wheels to make it feel
      more natural.
    + Allow pasting content using the Asynchronous Clipboard API when
      the origin is the same as the clipboard contents.
    + Improvements to the GStreamer multimedia playback, in
      particular around MSE, WebRTC, and seeking.
    + Make all supported image types appear in the Accept HTTP
      header.
    + Fix text caret blinking when blinking is disabled in the GTK
      settings.
    + Fix default database quota size definition.
    + Fix application of all caps tags listed in the
      font-feature-settings CSS property.
    + Fix the build with journald support enabled when using elogind
      instead of the systemd libraries.
    + Fix the build when libgcrypt provides a libgcrypt-config script
      instead of a pkg-config module file.
    + Fix font height calculations for the font-size-adjust CSS
      property.
    + Fix the build when ccache is used in certain setups.
    + Fix the build for RISC-V 64-bit targets.
    + Fix the build with GCC 13.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2022-0108, CVE-2023-28205, CVE-2022-32885,
      CVE-2023-27932, CVE-2023-27954, CVE-2023-28198, CVE-2023-32370.
  - Drop regression-fix.patch and fix-gst-crash.patch: fixed
      upstream.
  - Rebase gcc13-fix.patch.
* Tue Mar 28 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Add fix-gst-crash.patch: Fix crash in
    webkit_media_stream_src_class_init().
    https://bugs.webkit.org/show_bug.cgi?id=254025
  - Add reproducibility.patch: Make build more reproducible. Still
    not there yet though. Inject fixed year in file.
* Fri Mar 24 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Tweak constraints.
* Fri Mar 24 2023 Martin Liška <mliska@suse.cz>
  - Add gcc13-fix.patch fix that handles invalid code as reported here:
    https://github.com/WebKit/WebKit/pull/11910.
* Tue Mar 21 2023 Dominique Leuenberger <dimstar@opensuse.org>
  - Fix provides of libwebkit2gtk-4.[01]: Provide WebKitGTK-4.x. This
    symbol is only needed by the lang packages and those have been
    renamed from WebKit2GTK to WebKitGTK.
* Fri Mar 17 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.40.0 (boo#1213581):
    + New GTK4 API is now stable.
    + Use ANGLE for WebGL implementation and enable WebGL2.
    + Prefer EGL over X11, intead of GLX, where available.
    + Add support for speech synthesis using Flite.
    + Enable the async clipboard API.
    + Add API to query the permission state of web features.
    + Add API to support asynchronously returning values from user
      script messages.
    + Make it possible to handle WebKitDownload::decide-destination
      signal asynchronously.
    + Add new JavaScript execution APIs.
    + Make webkit://gpu output exportable as JSON.
    + Fix large memory allocation when uploading content.
  - Add regression-fix.patch: [GLib] Broke
    WebKitUserContentManager::script-message-received
    + Security fixes: CVE-2023-32393, CVE-2023-32435, CVE-2023-35074.
* Wed Mar 08 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.39.91:
    + Rename WebKitWebExtension to WebKitWebProcessExtension in GTK4
      API.
    + Remove WebKitJavascriptResult in favor of using JSCValue
      directly in GTK4 API.
    + Add new API to get the request body of WebKitURISchemeRequest.
    + Make it possible to handle WebKitDownload::decide-destination
      signal asynchronously.
    + Allow WebKitDownload destination to be a path instead of a URI.
    + Make webkit://gpu output exportable as JSON.
    + Improve scrolling performance in accelerated compositing mode.
    + Implement KeyboardEvent.repeat.
    + Fix a crash in MiniBrowser when the favicon is updated.
    + Fix the build in Ubuntu 20.04 and Debian Stable.
    + Fix several crashes and rendering issues.
    + Updated translations.
  - Drop no-forced-sse.patch: Due to changes in the code, trying to
    build without SSE2 support fails even with this patch. We are
    forced to give up on this, SSE2 support is now mandatory for all
    build targets.
  - Add new defines and sub-packages in conditional ways, upstream
    did a lot of changes for new gtk4 variant.
* Sun Feb 26 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.39.90:
    + Add new JavaScript execution APIs.
    + Merge functions of registering and unregistering script message
      handler in GTK4 API.
    + Mark non-derivable types as final and make instance and class
      struct declarations private in GTK4 API.
    + Make favicon and snapshot API use GdkTexture instead of cairo
      surfaces in GTK4 API.
    + Fix scrolling after a history navigation with PSON enabled.
    + Fix criticals from webkitOptionMenuSetEvent when opening any
      combo box.
    + Fix large memory allocation when uploading content.
    + Always update the active uri of WebKitFrame.
    + Fix several crashes and rendering issues.
    + Updated translations.
  - Drop webkit2gtk3-missing-include.patch: Fixed upstream
* Wed Feb 15 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.39.7:
    + Fix the webkit.h public header causing applications to fail to
      build.
    + Fix several crashes and rendering issues.
  - Changes from version 2.39.6:
    + Add support for speech synthesis using Flite.
    + Bring back WebKitConsoleMessage API implementation.
    + Fix async scroll event propagation for GTK4.
    + Add network session API when building with GTK4.
    + Make most public types final when building with GTK4.
    + Remove WebKitPrintCustomWidget when building with GTK4.
    + Remove most of the webkit_web_view_new_with_*() constructors
      when building with GTK4.
    + Remove webkit_web_context_get/set_process_model when building
      with GTK4.
    + Do not allow the sandbox to mount the entire home directory.
    + Fix several crashes and rendering issues.
  - Add pkgconfig(gstreamer-transcoder-1.0) and pkgconfig(openssl)
    BuildRequires: New dependencies.
  - Pass conditional ENABLE_WEBDRIVER=ON/OFF to cmake, enable/disable
    build of webdriver where apropiate.
* Wed Feb 15 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.39.5:
    + Enable WebGL2 by default again that was disabled by mistake.
    + Fix the build with WebGL disabled.
    + Fix the webkit.h public header causing applications to fail to
      build.
  - Changes from version 2.39.4:
    + Fix WebGL when sandbox is enabled.
    + Fix loading of media documents.
    + Add new API disable web security.
    + Disable support for HLS in media backend by default.
    + Fix several crashes and rendering issues.
    + Updated translations.
  - Changes from version 2.39.3:
    + Add new API to query the permission state of web features.
    + Deprecate all web extension DOM APIs (WebKitDOMDocument,
      WebKitDOMElement, WebKitDOMNode).
    + Add webkit_web_hit_test_result_get_js_node() to get the
      JSCValue for the node.
    + Add WebKitWebFormManager and deprecate WebKitWebPage form
      related signals.
    + Don’t perform position queries on video sink when the player is
      for audio only.
    + Fix gibberish text when loading alternate data.
    + Fix several crashes and rendering issues.
  - Changes from version 2.39.2:
    + Add API to support asynchronously returning values from user
      script messages.
    + Deprecate WebKitConsoleMessage API.
    + Deprecate event parameter of WebKitWebView::context-menu and
      WebKitWebView::show-option-menu signals in favor of a getter in
      WebKitConextMenu and WebKitOptionMenu.
    + Do not emit context-menu signals for media settings popup menu.
    + Use async scrolling also for keyboard scrolling.
    + Add support for client side certificates on WebSocket
      connections.
    + Fix first party for cookies set on every media request.
    + Fix a crash on authentication dialog with GTK4.
    + Fix web process leak when webkit_download_set_destination is
      called with empty destination.
    + Fix several warnings when building for ARMv7 (32-bits).
    + Fix several crashes and rendering issues.
  - Changes from version 2.39.1:
    + Use ANGLE for WebGL implementation and enable WebGL2.
    + Remove internal nested wayland compositor making libwpe
      mandatory when building with wayland enabled.
    + Prefer EGL over X11, intead of GLX, where available.
    + Add support for background-repeat: space.
    + Add API to check if a response policy decision is for the main
      resource.
    + Fix rendering of checkbox and radio buttons in black
      backgrounds.
    + Make checkbox, radio and inner spin button scale along by page
      zoom.
    + Add support for get computed label and get computed role
      WebDriver commands.
    + Fix several crashes and rendering issues.
  - Rebase patches with quilt.
  - Add unifdef BuildRequires: New dependency.
* Wed Feb 15 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.38.5 (boo#1208328):
    + Fix large memory allocation when uploading content.
    + Fix scrolling after a history navigation with PSON enabled.
    + Always update the active uri of WebKitFrame.
    + Fix the build on Ubuntu 20.04.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2023-23529.
* Thu Feb 02 2023 Michael Gorse <mgorse@suse.com>
  - Update to version 2.38.4 (boo#1207997):
    + Improve GStreamer multimedia playback across the board with
      improved codec selection logic, better handling of latency, and
      improving frame discard to avoid audio/video
      desynchronizationg, among other fixes.
    + Disable HLS media playback by default, which makes web sites
      use MSE instead. If needed WEBKIT_GST_ENABLE_HLS_SUPPORT=1 can
      be set in the environment to enable it back.
    + Disable threaded rendering in GTK4 builds by default, as it was
      causing crashes.
    + Fix MediaSession API not showing artwork images.
    + Fix MediaSession MPRIS usage when running inside a Flatpak
      sandbox.
    + Fix input element controls to correctly scale when applying a
      zoom factor different than the default.
    + Fix leakage of Web processes in certain situations.
    + Fix the injected bundle not being found when running inside a
      sandbox.
    + Fix the build with ENABLE_INTROSPECTION when cross-compiling.
    + FIx the build with ENABLE_WEBGL disabled.
    + Fix the build with GStreamer-based WebRTC enabled.
    + Fix the build with USE_GTK4 enabled.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2023-23517, CVE-2023-23518, CVE-2022-42826,
      CVE-2022-32919, CVE-2022-46705, CVE-2022-46725.
* Fri Jan 27 2023 Michael Gorse <mgorse@suse.com>
  - Add webkit2gtk3-missing-include.patch: fix the build with gcc 13.
* Thu Dec 22 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.38.3 (boo#1206474 boo#1206750):
    + Fix runtime critical warnings from media player.
    + Fix network process crash when fetching website data on
      ephemeral session.
    + Fix the build with Ruby 3.2.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2022-42852, CVE-2022-42856, CVE-2022-42867,
      CVE-2022-46692, CVE-2022-46698, CVE-2022-46699, CVE-2022-46700.
  - Drop b7ac5d0c.patch: fixed upstream.
* Wed Dec 14 2022 Dominique Leuenberger <dimstar@opensuse.org>
  - Add upstream patch b7ac5d0c.patch: Fix build with Ruby 3.2.
* Thu Nov 17 2022 Guillaume GARDET <guillaume.gardet@opensuse.org>
  - Update _constraints for webkit2gtk3:gtk3-soup2 on aarch64 to
    avoid slow workers and OOM
* Mon Nov 07 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.38.2 (boo#1205120 boo#1205123 boo#1205124):
    + Fix scrolling issues in some sites having fixed background.
    + Fix prolonged buffering during progressive live playback.
    + Fix the build with accessibility disabled.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2022-42799, CVE-2022-42823, CVE-2022-42824.
* Mon Oct 24 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.38.1:
    + Make xdg-dbus-proxy work if host session bus address is an
      abstract socket.
    + Use a single xdg-dbus-proxy process when sandbox is enabled.
    + Fix high resolution video playback due to unimplemented
      changeType operation.
    + Ensure GSubprocess uses posix_spawn() again and inherit file
      descriptors.
    + Fix player stucking in buffering (paused) state for progressive
      streaming.
    + Do not try to preconnect on link click when link preconnect
      setting is disabled.
    + Fix close status code returned when the client closes a
      WebSocket in some cases.
    + Fix media player duration calculation.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2022-46691.
* Fri Sep 16 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.38.0 (boo#1203530 boo#1205121 boo#1205122):
    + New media controls UI style.
    + Add new API to set WebView’s Content-Security-Policy for web
      extensions support.
    + Make it possible to use the remote inspector from other
      browsers using WEBKIT_INSPECTOR_HTTP_SERVER env var.
    + MediaSession is enabled by default, allowing remote media
      control using MPRIS.
    + Add support for PDF documents using PDF.js.
    + Security fixes: CVE-2022-32886, CVE-2022-32888, CVE-2022-32912,
      CVE-2022-32923, CVE-2022-42863, CVE-2023-25358, CVE-2023-25360,
      CVE-2023-25361, CVE-2023-25362, CVE-2023-25363, CVE-2022-48503,
      CVE-2022-32933, CVE-2023-42833.
* Mon Sep 05 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.37.91:
    + Cache and reuse image-based backing stores to improve memory
      consumption.
    + Fix printing with bubblewrap sandbox enabled.
    + Deprecate enable-frame-flattening setting because the
      functionality will be removed for 2.40.
    + Fix deadlock when disposing player while handling rotation tag.
    + Fix several crashes and rendering issues.
    + Updated translations.
* Fri Aug 26 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.37.90:
    + Remove libnotify dependency.
    + Add support for service worker notifications.
    + Add support for loading the notification icon.
    + Add support for pac proxy type in WebDriver.
    + Fix several crashes and rendering issues.
    + Updated translations.
  - Changes from version 2.37.1:
    + Add initial implementation of WebRTC using GstWebRTC if
      GStreamer 1.20 is available, disabled by default via web view
      settings.
    + Add new API to set WebView’s Content-Security-Policy for web
      extensions support.
    + Add new API to run async JavaScript functions.
    + Expose typed arrays in JavaScriptCore GLib API.
    + Add support for PDF documents using PDF.js.
    + Show font name and font variant settings in the inspector.
    + MediaSession is enabled by default, allowing remote media
      control using MPRIS.
    + Modernized media controls UI.
    + Add Support Google Dynamic Ad Insertion (DAI).
    + Add support for capturing encoded video streams from a webcam.
    + Make it possible to use the remote inspector from other
      browsers using WEBKIT_INSPECTOR_HTTP_SERVER env var.
    + Add support for IPv6 in the remote inspector.
    + Update form elements style to match libadwaita.
    + Fix canvas animations and images with threaded rendering
      enabled.
    + Switch to use gi-docgen for API documentation instead of
      gtk-doc.
    + Remove the ATK a11y implementation that has been replaced by
      AT-SPI DBus interfaces.
    + Fix several crashes and rendering issues.
  - Update no-forced-sse.patch with quilt.
  - Pass -DENABLE_DOCUMENTATION=OFF to configure, we did not build
    the API docs in the past, and I see no reason to start now.
  - Drop pkgconfig(libnotify) BuildRequires: No longer needed, nor
    used if available.
* Fri Aug 26 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.36.7 (boo#1202807):
    - Fix several crashes and rendering issues.
    + Security fixes: CVE-2022-32893.
* Sun Aug 07 2022 Andreas Stieger <andreas.stieger@gmx.de>
  - Update to version 2.36.6
    + Fix handling of touchpad scrolling on GTK4 builds
    + Fix WebKitGTK not allowing to be used from non-main threads
      (boo#1202169)
    + Fix several crashes and rendering issues
* Fri Jul 29 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.36.5 (boo#1201980):
    + Add support for PAC proxy in the WebDriver implementation.
    + Fix video playback when loaded through custom URIs, this fixes
      video playback in the Yelp documentation browser.
    - Fix WebKitWebView::context-menu when using GTK4.
    - Fix LTO builds with GCC.
    - Fix several crashes and rendering issues.
    + Security fixes: CVE-2022-32792, CVE-2022-32816, CVE-2022-32891.
  - Drop webkit2gtk3-fix-build.patch: fixed upstream.
* Tue Jul 05 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.36.4 (boo#1201221):
    + Fix the new ATSPI accessibility implementation to add the
      missing Collection interface for the loaded document.
    + Fix the MediaSession implementation to make the MPRIS object
      names more sandbox friendly, which plays better with Flatpak
      and WebKit's own Bubblwrap-based sandboxing.
    + Fix leaked Web Processes in some particular situations.
    + Fix the build with media capture support enabled.
    + Fix cross-compilation when targeting 64-bit ARM.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2022-22677, CVE-2022-26710.
  - Add webkit2gtk3-fix-build.patch: fix the build.
* Sun May 29 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.36.3 (boo#1200106):
    + Support capturing already encoded video streams, which takes
      advantage of encoding done in hardware by devices which support
      this feature.
    + Avoid using experimental GStreamer elements for video demuxing.
    + Avoid using the legacy GStreamer VA-API decoding plug-ins,
      which often cause rendering issues and are not much maintained.
      Their usage can be re-enabled setting
      WEBKIT_GST_ENABLE_LEGACY_VAAPI=1 in the environment.
    + Fix playback of YouTube streams which use dynamic ad insertion.
    + Fix display capture with Pipewire.
    + Fix the build without the X11 target when X11 headers are not
      present.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2022-26700, CVE-2022-26709, CVE-2022-26716,
      CVE-2022-26717, CVE-2022-26719.
* Fri May 20 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.36.2:
    + Fix some pages showing empty content boxes when using GTK4.
    + Fix the build with accessibility disabled.
    + Fix the build with newer Ruby versions.
    + Fix several crashes and rendering issues.
* Mon May 02 2022 Martin Liška <mliska@suse.cz>
  - Remove dependency on binutils-gold as the package will be removed
    in the future. Gold linker is unmaintained by the upstream
    project.
* Thu Apr 21 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.36.1 (boo#1199287):
    + Fix the build with accessibility disabled.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2022-30293.
* Wed Apr 06 2022 Michael Gorse <mgorse@suse.com>
  - Drop webkit2gtk3-gcc12.patch. It isn't needed anymore, since the
    relevant gcc change has been reverted for now.
  - Update some minimum version requirements to match cmake checks.
  - Remove build requirements on geoclue and libbrotlidec: they are
    no longer build-time dependencies. Add geoclue2 to Recommends.
* Wed Mar 30 2022 Michael Gorse <mgorse@suse.com>
  - Add webkit2gtk3-gcc12.patch: fix the build with gcc 12.
* Tue Mar 29 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Disabled usage of gold linker for all targets via existing
    define.
* Mon Mar 21 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.36.0 (boo#1198290):
    + Add new accessibility implementation using ATSPI DBus
      interfaces instead of ATK.
    + Add support for requestVideoFrameCallback.
    + Change hardware-acceleration-policy setting default value to
      always.
    + Add support for media session.
    + Add new API to set HTTP response information to custom uri
      schemes.
    + Make user interactive threads (event handler, scrolling, …)
      real time in linux.
    + Security fixes: CVE-2022-22624, CVE-2022-22628, CVE-2022-22629,
      CVE-2022-22662.
* Mon Feb 28 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.35.90:
    + Fix scrolling with the mouse wheel on sites using
      overscroll-behavior.
    + Suspend web processes after some time in the process cache.
    + Fix renderning of horizontal scrollbars with themes enabling
      steppers.
    + Ensure EGL displays are terminated before web process exits.
    + Deinitialize gstreamer before web process exits.
    + Make fonts under XDG_DATA_DIRS available in web process sanbox.
    + Canonicalize paths passed to bubblewrap launcher.
    + Fix several crashes and rendering issues.
    + Updated translations.
* Thu Feb 17 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.35.3:
    + Fix a crash at startup when bubblewrap sandbox is enabled.
    + Fix a crash when starting a drag an drop on touchscreen.
    + Fix several crashes and rendering issues.
  - Changes from version 2.35.2:
    + Add new accessibility implementation using ATSPI DBus
      interfaces instead of ATK.
    + Use native GtkWidgets for form validation popups.
    + Add support for requestVideoFrameCallback.
    + Add support for accent colors.
    + Fix pinch zooming from a link to not activate the link.
    + Fix kinetic scrolling via touch screen.
    + Fix several crashes and rendering issues.
  - Changes from version 2.35.1:
    + Make user interactive threads (event handler, scrolling, …)
      real time in linux.
    + Add new API to set HTTP response information to custom uri
      schemes.
    + Add support for media session.
    + Change hardware-acceleration-policy setting default value to
      always.
    + Fix jsc_value_object_define_property_accessor() to work with
      objects not having a wrapped instance.
    + Fix several crashes and rendering issues.
  - Add gstreamer-plugins-good, gstreamer-plugins-bad and
    xdg-desktop-portal-gtk Recommends: Needed for mediaplayback and
    features in the mandatory sandbox.
  - Add flex BuildRequires: Optional dependency.
  - Rebase no-forced-sse.patch: Not sure this makes sense anymore,
    we are building for i686, and the number of cpu of that class not
    supporting SSE2 can probably be counted on one hand.
  - Drop patches fixed upstream:
    + fix-warnings.patch
    + webkit2gtk3-link-fix.patch
* Thu Feb 17 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.34.6 (boo#1196133):
    + Fix accessibility not working when the Bubblewrap sandbox is
      enabled.
    + Fix rendering of scrollbars when overlay scrollbars are
      disabled.
    + Fix the build when the X11 support is disabled.
    + Fix the build in a number of situations where the main OpenGL
      library is not called libGL or libgl, as is the case on
      systems that use libglvnd.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2022-22620.
* Wed Feb 09 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.34.5 (boo#1195735):
    + Improve VP8 codec selection when using GStreamer 1.20.
    + Fix connecting to the accessiblity bus when using the
      Bubblewrap sandbox.
    + Fix links being incorrectly activated when starting a pinch
      zoom gesture.
    + Fix touch-based scrolling.
    + Fix the build with recent toolchains based on GCC 12 and on
      older ones as included e.g. in Ubuntu 18.04.
    + Fix the build with ICU 60, version 61 is no longer required.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2022-22589, CVE-2022-22590, CVE-2022-22592.
    + Drop webkit2gtk3-gcc12.patch: fixed upstream.
* Mon Jan 31 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update constraints for disk space even more, now at 20 gig.
* Mon Jan 24 2022 Michael Gorse <mgorse@suse.com>
  - Add webkit2gtk3-gcc12.patch: fix the build with gcc 12.
  - Require glib2 2.44 to match source.
* Fri Jan 21 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.34.4 (boo#1195064):
    + Fix several crashes and rendering issues.
    + This release fixes numerous security issues, including an
      especially severe issue that allowed websites to read the names
      of IndexedDB databases created by other websites.
    + Security fixes: CVE-2021-30934, CVE-2021-30936, CVE-2021-30951,
      CVE-2021-30952, CVE-2021-30953, CVE-2021-30954, CVE-2021-30984,
      CVE-2022-22594, CVE-2022-22637.
* Wed Jan 19 2022 Frederic Crozat <fcrozat@suse.com>
  - Update _constraints, needs more disk space to build.
* Tue Dec 21 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.34.3 (boo#1194019):
    + Make audio tools (like mixers) display the actual name of the
      application producing sound, instead of a generic one.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2021-30887, CVE-2021-30890.
* Tue Dec 14 2021 Yifan Jiang <yfjiang@suse.com>
  - Typo fix for %define usegcc10.
* Tue Dec 14 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Introduce usegcc10 %define in order to have the condition
    (0%{?sle_version} && 0%{?sle_version} <= 150400) only at one
    point.
  - Correct a very old "Obsoletes: webkit2gtk3-plugin-process-gtk2"
    to be a versioned obsoletes.
* Tue Dec 14 2021 Yifan Jiang <yfjiang@suse.com>
  - Make the earlier Obsoletes: libwebkit2gtk3-lang compliant with:
    https://en.opensuse.org/openSUSE:Upgrade_dependencies_explanation#Renaming_a_package
* Wed Dec 08 2021 Yifan Jiang <yfjiang@suse.com>
  - Add Obsoletes of the old-name -lang package to be ready for
    updating from it. This change is necessary for the gtk3-soup2
    flavor.
* Sat Nov 27 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.34.2:
    + Fix scrolling issues when pressing Home and PgDown keys.
    + Update effective appearance after web process switch on
      navigation.
    + Fix the build with video disabled.
* Mon Nov 01 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Add pkgconfig(libavif) BuildRequires and pass USE_AVIF=ON to
    cmake, build avif decoding support.
* Mon Nov 01 2021 Michael Gorse <mgorse@suse.com>
  - Add wayland-protocols to BuildRequires.
* Tue Oct 26 2021 Michael Gorse <mgorse@suse.com>
  - Add webkit2gtk3-link-fix.patch: taken from upstream, fixes the
    build on SLE-15-SP4.
  - Use gcc10 package on SLE <= 15-SP4. Gcc 7 is currently the
    default there.
  - Update gcc-c++ version requirement to match the cmake check.
* Thu Oct 21 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.34.1 (boo#1191937):
    + Update user agent browser versions.
    + Fix a crash with GTK >= 3.24.30.
    + Fix a crash when loading videos on reddit.
    + Fix file type detection when application calls
      g_desktop_app_info_set_as_default_for_extension() passing html.
    + Security fixes: CVE-2021-42762.
* Wed Sep 29 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Add libjavascriptcoregtk-4_0-18 and llibwebkit2gtk-4_0-37 to
    baselibs.conf: provide those libraries as multilib version.
* Wed Sep 29 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Rename -lang packages to WebKit2GTK-%{_apiver}, making the
    translations between the three flavors co-exist.
* Wed Sep 22 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Update to version 2.34.0 (boo#1192063):
    + Fix another regression in JavaScriptCore on 32bit systems.
    + Security fixes: CVE-2021-30846, CVE-2021-30851, CVE-2021-30818,
      CVE-2021-30823, CVE-2021-30884, CVE-2021-30888, CVE-2021-30889,
      CVE-2021-30897, CVE-2021-45481, CVE-2021-45483.
* Mon Sep 20 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.33.91:
    + Use the right display refresh monitor for animations in
      accelerated compositng mode.
    + Fix several issues in JavaScriptCore on 32bit systems.
    + Prefer python3 over python2 in CMake.
* Mon Sep 20 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.33.90:
    + Show TLS protocol version and ciphersuite name in the
      inspector when building with libsoup3.
    + Add multi-track support to media backend.
    + Avoid strong alias computations in font fallback code.
    + Fix deadlock tearing down pipeline when using fallback sink.
    + Fix the build with gtk-doc enabled.
    + Fix several crashes and rendering issues.
  - Add fix-warnings.patch: silence return-type warnings.
* Mon Sep 20 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Add a 3rd flavor: gtk3 with libsoup2 (which retains compatibility
    to the olderversions, identified as API version 4.0).
* Mon Sep 20 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Add _multibuild file and enable build of webkit2gtk4.
* Mon Sep 20 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Update to version 2.33.3:
    + Add support for display capture.
    + Add new API to access/modify capture devices states.
    + Add new API to configure the memory pressure handler.
    + Add support for client side certifiates authentication.
    + Add support color-schemes CSS property.
    + Add support for dark scrollbars.
    + Keep GtkSettings used by web processes in sync with the
      settings set in the UI process.
    + Add support for drawing the scrollbars corner.
    + Allow to opt-out of GL rendering at runtime for media player.
    + Add support for A420 compositing in media player.
    + Improve pinch to zoom gesture in accerlerated compositing mode.
    + Fix cookies configuration after a network process crash.
    + Fix touchscreen navigation swipe when the page scrolls
      horizontally.
    + Fix rendering of elliptic radial gradients.
    + Fix several crashes and rendering issues.
    + Updated translations.
  - Drop fix-lto.patch: fixed upstream.
  - Add pkgconfig(lcms2) BuildRequires: new dependency.
  - Replace pkgconfig(libsoup-2.4) BuildRequires with
    pkgconfig(libsoup-3.0): Follow upstreams port to Libsoup 3.0.
* Sun Sep 19 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.32.4 (boo#1190701):
    + Do not append .asc extension to downloaded text/plain files.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2021-30848, CVE-2021-30849, CVE-2021-30858,
      CVE-2021-30809, CVE-2021-30836, CVE-2021-45482.
  - Drop fix-lto.patch: fixed upstream.
* Tue Aug 10 2021 Martin Liška <mliska@suse.cz>
  - Enable LTO by using upstream patch fix-lto.patch.
* Thu Aug 05 2021 Yifan Jiang <yfjiang@suse.com>
  - Drop unneeded patch on Leap and SLE by now:
    webkit2gtk3-restore-npapi.patch (bsc#1189105).
* Thu Jul 29 2021 Yifan Jiang <yfjiang@suse.com>
  - Add BuildRequires pkgconfig(glproto) for SLE and Leap which have
    not included the new packaging of the relevant headers.
* Mon Jul 26 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.32.3 (boo#1188697):
    + Properly set the cookies settings after a network process
      crash.
    + Fix accessibility tree after a cross site navigation with PSON
      enabled.
    + Ensure WebKitScriptWorld::window-object-cleared signal is
      always emitted.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2021-21775, CVE-2021-21779, CVE-2021-30663,
      CVE-2021-30665, CVE-2021-30689, CVE-2021-30720, CVE-2021-30734,
      CVE-2021-30744, CVE-2021-30749, CVE-2021-30795, CVE-2021-30797,
      CVE-2021-30799.
  - Fix webkit2gtk3-restore-npapi.patch to install the plugin
      process.
  - Disable WPE renderer: our FDO backend is now too old.
* Mon Jul 19 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.32.2:
    + Improve calculation of initial WebKitWebView size.
    + Fix kinetic scrolling on touchpad with async scrolling off.
    + Fix a crash on empty drag operation in X11.
    + Fix rendering on HiDPI /4k screen and scaling.
    + Handle null native surface for for surfaceless rendering.
    + Fix JavaScriptCore crash on 32-bit big endian systems.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2021-30758.
* Wed May 19 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.32.1:
    + Support building against the Musl C library.
    + Support building against ICU version 69 or newer.
    + Improve handling of Media Capture devices.
    + Improve WebAudio playback.
    + Improve video orientation handling.
    + Improve seeking support for MSE playback.
    + Improve flush support in EME decryptors.
    + Fix HTTP status codes for requests done through a custom URI
      handler.
    + Fix the Bubblewrap sandbox in certain 32-bit systems.
    + Fix inconsistencies between the WebKitWebView.is-muted property
      state and values returned by
      webkit_web_view_is_playing_audio().
    + Fix the build with ENABLE_VIDEO=OFF.
    + Fix wrong timestamps for long-lived cookies.
    + Fix UI process crash when failing to load favicons.
    + Fix several crashes and rendering issues.
    + Updated translations.
  - Drop webkit2gtk3-icu69.patch: fixed upstream.
* Wed Apr 28 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Add webkit2gtk3-icu69.patch: Fix build with ICU 69:
    + ICU 69 deprecates ubrk_safeClone in favor of ubrk_clone.
* Mon Apr 12 2021 Michael Gorse <mgorse@suse.com>
  - Per discussion with maintenance, let's not remove features that
    customers could possibly be using:
  - Add webkit2gtk3-restore-npapi.patch: restore NPAPI plugin
    support. Reverts webkit#215503.
* Tue Apr 06 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.32.0 (boo#1184155):
    + Fix the authentication request port when URL omits the port.
    + Fix iframe scrolling when main frame is scrolled in async
      scrolling mode.
    + Stop using g_memdup.
    + Show a warning message when overriding signal handler for
      threading suspension.
    - Fix the build on RISC-V with GCC 11.
    - Fix several crashes and rendering issues.
    + Security fixes: CVE-2021-1788, CVE-2021-1844, CVE-2021-1871
    + Changes in version 2.30.6 (boo#1184262):
    + Update user agent quirks again for Google Docs and Google Drive.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2020-27918, CVE-2020-29623, CVE-2021-1765,
    CVE-2021-1789, CVE-2021-1799, CVE-2021-1801, CVE-2021-1870.
  - Remove webkit-font-scaling.patch: contained in upstream
  - Drop original SLE 15 support from the spec. Drop
    webkit-process.patch and old-wayland-scanner.patch; they are not
    needed for SP2.
  - Pass ENABLE_GAMEPAD=OFF to cmake, since we don't have manette.
  - Add glproto-devel to BuildRequires: now needed for the build on
    SLE 15.
* Fri Apr 02 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.32.0 (boo#1184155):
    + Fix the authentication request port when URL omits the port.
    + Fix iframe scrolling when main frame is scrolled in async
      scrolling mode.
    + Stop using g_memdup.
    + Show a warning message when overriding signal handler for
      threading suspension.
    - Fix the build on RISC-V with GCC 11.
    - Fix several crashes and rendering issues.
    + Security fixes: CVE-2021-1788, CVE-2021-1844, CVE-2021-1871,
      CVE-2021-30682.
  - Drop old-wayland-scanner.patch and webkit-process.patch, and also
    drop support for Leap 15.0 and 15.1, since they are no longer
    supported.
* Tue Mar 23 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.31.91:
    + Make WebKitSecurityOrigin a simple data store for <protocol,
      host, port> and deprecate webkit_security_origin_is_opaque().
    + Fix user agent again to work on several google websites.
    + Fix web view url on web process terminate signals.
    + Fix preferred language overrides sent to the web process.
    + Fix the build in i386.
    + Translation updates: Simplified Chinese.
  - Drop webkitgtk-i586-build-fix.patch: fixed upstream.
  - Disable webkit-process.patch: needs to be rebased or dropped.
* Mon Mar 22 2021 Michael Gorse <mgorse@suse.com>
  - Add webkitgtk-i586-build-fix.patch: fix build on i586
    (webkit#222480).
* Mon Mar 22 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.31.90:
    + Add permission request API for MediaKeySystem access.
    + Fix rendering when using opacity filters on hardware
      accelerated layers.
    + Fix flatpak-spawn subsandbox to not clear environment
      variables.
    + Ensure a URI scheme handler can't be registered multiple times.
    + Fix several crashes and rendering issues.
    + The minimum required GStreamer version is now 1.14.
    + CEA-608 closed captions support (requires
      WEBKIT_GST_USE_PLAYBIN3=1 environment variable).
    - Advertise CBCS decryption and VP9 support in Thunder.
    - Advertise DASH as supported in the media player.
    - Improved support for playbin3.
    - Translation updates: Ukrainian.
  - Up required gstreamer and gtk3 versions.
* Mon Mar 22 2021 Callum Farmer <gmbr3@opensuse.org>
  - Update to version 2.31.1:
    + Remove support for NPAPI plugins.
    + Enable the web process cache when PSON is enabled too.
    + TLS errors and proxy settings APIs have been moved from
      WebKitContext to WebKitWebsiteDataManager.
    + Add new API to remove individual scripts/stylesheets using
      WebKitUserContentManager.
    + Correctly apply the system font scaling factor.
    + Show main loop frames information in the web inspector.
  - Remove webkit-font-scaling.patch: contained in upstream
  - New build requirement: pkgconfig(manette-0.2).
* Sun Mar 21 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.30.6 (boo#1184262):
    + Update user agent quirks again for Google Docs and Google Drive.
    + Fix several crashes and rendering issues.
    + Security fixes: CVE-2020-27918, CVE-2020-29623, CVE-2021-1765
      CVE-2021-1789, CVE-2021-1799, CVE-2021-1801, CVE-2021-1870,
      CVE-2021-21806.
* Fri Feb 19 2021 Guillaume GARDET <guillaume.gardet@opensuse.org>
  - Update _constraints for armv6/armv7 (bsc#1182719)
* Sat Feb 13 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.30.5 (boo#1182286):
    + Bring back the WebKitPluginProcess installation that was
      removed by mistake.
    + Fix RunLoop objects leaked in worker threads.
    + Fix aarch64 llint build with JIT disabled.
    + Use Internet Explorer quirk for Google Docs.
    + Security fixes: CVE-2020-13558.
  - Drop gir-multilib.patch: fixed upstream.
* Wed Jan 20 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Add gir-multilib.patch: Fix multilib conflict in gir files.
  - Disable gold linker for ppc64le
* Tue Jan 19 2021 Atri Bhattacharya <badshah400@gmail.com>
  - Add webkit-font-scaling.patch: Fix system font scaling not
    applied to 'font-size: XXXpt'; patch taken from upstream and
    rebased to apply cleanly
    (https://bugs.webkit.org/show_bug.cgi?id=218450).
  - Pass `-q` to setup to disable printing long list of files
    extracted from source tarball.

Files

/usr/lib64/libjavascriptcoregtk-4.1.so.0
/usr/lib64/libjavascriptcoregtk-4.1.so.0.5.6
/usr/share/licenses/libjavascriptcoregtk-4_1-0
/usr/share/licenses/libjavascriptcoregtk-4_1-0/COPYING.LIB


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Jul 9 10:53:35 2024