Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

cyradm-2.4.19-lp152.3.9 RPM for ppc64le

From OpenSuSE Ports Leap 15.2 for ppc64le

Name: cyradm Distribution: openSUSE:Leap:15.2:PowerPC / ports
Version: 2.4.19 Vendor: openSUSE
Release: lp152.3.9 Build date: Sat May 16 14:53:53 2020
Group: Productivity/Networking/Email/Utilities Build host: obs-power8-05
Size: 18739 Source RPM: cyrus-imapd-2.4.19-lp152.3.9.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.cyrusimap.org
Summary: Administration tool for the Cyrus IMAP server
This package contains an administration tool for the Cyrus IMAP server.

Provides

Requires

License

BSD-3-Clause

Changelog

* Thu Nov 23 2017 rbrown@suse.com
  - Replace references to /var/adm/fillup-templates with new
    %_fillupdir macro (boo#1069468)
* Wed Oct 25 2017 rhafer@suse.de
  - Removed "cyrus-imapd-2.4.19_drac_auth.patch" and dropped drac
    from the BuildRequires. DRAC's upstream is bascially dead nowadays,
    and the drac patch in cyrus-imapd is also largely unmaintained.
    Rebased cyrus-imapd-2.4.17_openslp.patch and
    cyrus-imapd-2.4.19_autocreate-0.10-0.patch as a result of the
    removal.
* Mon Jul 10 2017 jengelh@inai.de
  - Remove filler wording from description.
  - Improve find commands.
* Sun Jun 25 2017 aj@ajaissle.de
  - Add cyrus-imapd-2.4.19-lmtpd_crash.patch:
    * lmtpd: fix uninitialised variable crash [boo#1045899]
* Wed Jun 21 2017 aj@ajaissle.de
  - Rebased patch:
    * cyrus-imapd-2.4.18-implicit_definitions.patch as cyrus-imapd-2.4.19-implicit_definitions.patch
      Add fix for implicit-fortify-decl in ldap.c
* Wed Jun 14 2017 aj@ajaissle.de
  - Update to 2.4.19
    * Complete backport of the new (2.5 and later) IMAP IDLE implementation (thanks Thomas Jarosh). This fixes a bunch of bugs and race conditions that were inherent to the older implementation
    * New option “imapidletimeout” overrides “timeout” specifically for connections in IDLE state
    * OpenSSL 1.1.0 is now supported
    * Fixed: imap ENABLED doesn’t print * ENABLED when nothing new enabled
    * Fixed: mailbox lock management over rename (thanks Thomas Jarosh)
    * Fixed: added overflow protection to urlfetch range checks
    * Fixed: lmtpd can now deliver when mupdate server isn’t available (thanks Michael Menge)
    * Fixed task 227: service processes no longer divide by zero when invoked with -T 0 argument (thanks Ian Batten and Jens Erat)
    * Fixed task 229: ctl_cyrusdb now uses database paths from imapd.conf (thanks Simon Matter)
    * Fixed bug #3862: mailbox database changes now rolled back on mupdate failure during rename (thanks Michael Menge)
    * Fixed: XFER to 2.5 and later no longer downgrades index to oldest version
    * Fixed: nonsensical “TEXT.MIME” section now handled as “HEADER”
    * Fixed: added missing ‘auditlog: ‘ prefix to backend connections (thanks Wolfgang Breyha)
    * Fixed: IMAP SEARCH crash on some platforms
    * Fixed: memory leaks in IMAP SEARCH and IMAP APPEND
    * Fixed Issue #1967: EXISTS count reported earlier if fetching past size of previous message set
  - Rebased patches:
    * cyrus-imapd-2.4.17_drac_auth.patch as cyrus-imapd-2.4.19_drac_auth.patch
    * cyrus-imapd-2.4.17_autocreate-0.10-0.patch as cyrus-imapd-2.4.19_autocreate-0.10-0.patch
  - Removed patches:
    - cyrus-imapd-2.4.18-CVE-2015-8077.patch (upstream)
    - cyrus-imapd-2.4.18-CVE-2015-8078.patch (upstream)
  - Added cyrus-imapd-2.4.19.tar.gz.sig
* Fri May 27 2016 tchvatal@suse.com
  - Try to cleanup with spec-cleaner
  - Remove exit 0 in pre that stopped execution of the rest of the code
  - Update pre/post requires to be acutally correct
  - Disable stict-aliasing to avoid some problems
* Mon Dec 21 2015 aj@ajaissle.de
  - Add cyrus-imapd-2.4.18-D19-Outlook_2013_XLIST.patch to add
    Outlook 2013-compatible XLIST behaviour.
* Sun Nov 15 2015 aj@ajaissle.de
  - Added cyrus-imapd-2.4.18-CVE-2015-8077.patch:
    boo#954200, CVE-2015-8077: Integer overflow in range checks
  - Added cyrus-imapd-2.4.18-CVE-2015-8078.patch:
    boo#954201, CVE-2015-8078: Integer overflow in index_urlfetch
* Sun Aug 23 2015 aj@ajaissle.de
  - Update to 2.4.18 [boo#945844]
    * Security fix: handle urlfetch range starting outside message range
    * A bunch of cleanups and fixes to compiling
    * A bunch of sieve cleanups
    * Enhanced SSL/TLS configuration options
    * Disable use of SSLv2/SSLv3
    * Allow SQL backend for mboxlist and statuscache (thanks Julien Coloos)
    * Fixed Task #116: correct LIST response for domains starting with ‘inbox.’
    * Fixed Task #76: fixed lmtpd userdeny db checks (thanks Leena Heino)
    * Fixed bug #3856: lmtpd now performs userdeny checks
    * Fixed bug #3848: support charset aliases in encoded headers
    * Fixed bug #3853: disconnect_on_vanished_mailbox: release mailbox lock before exiting (thanks Wolfgang Breyha)
    * Fixed bug #3415: fixed nntpd LIST/GROUP bug
    * Fixed bug #3784: no longer crash in THREAD REFERENCES when messages reference themselves
    * Fixed bug #3757: don’t segfault on mailbox close with no user
    * New ssl/tls configuration options
      tls_compression: 0
      Enable TLS compression. Disabled by default.
      tls_eccurve: prime256v1
      Select the elliptic curve used for ECDHE.
      tls_prefer_server_ciphers: 0
      Prefer the cipher order configured on the server-side.
      tls_versions: tls1_0 tls1_1 tls1_2
      Disable SSL/TLS protocols not in this list.
  - Removed the following patches (included upstream):
    - cyrus-imapd-2.4.17_tls-session-leak.patch
    - cyrus-imapd.tls_options.patch
  - Added patch cyrus-imapd-2.4.18-implicit_definitions.patch:
    - Have the correct #include when using implicit definitions
* Mon Dec 08 2014 aj@ajaissle.de
  - Changed cyrus-imapd-rc-2.tar.gz/cron.daily.cyrus to use 'su -s
    /bin/bash - cyrus', as the default shell is now /sbin/nologin
    [boo#908014]
  - Changed cyrus-imapd-rc-2.tar.gz/rc.cyrus to set
    /var/run/cyrus-master.pid as the PID file (was: /var/run/cyrus.pid)
    [boo#908006]
* Fri Nov 21 2014 tchvatal@suse.com
  - Drop unused patch:
    * KOLAB_cyrus-imapd-2.3.18_cross-domain-acls.patch
* Fri Nov 14 2014 rhafer@suse.com
  - Replace the TLS/POODLE patch with what was merged into the upstream
    git repo:
    * cyrus-imapd.tls_options.patch
    * Obsoletes patches cyrus-imapd.tls_tlsonly.patch and
      cyrus-imapd.tls_ec.patch
  - Add a default tls_versions settings to imapd.conf which disables
    POODLE affected SSL versions.
* Sat Oct 18 2014 johannes@lst.de
  - Add two patches from Kristian Kraemmer Nielsen found on the info-cyrus mailing list
    (http://lists.andrew.cmu.edu/pipermail/info-cyrus/2014-October/037708.html)
    * cyrus-imapd.tls_ec.patch		- adding tls_ec for Perfect Forward Secrecy
    * cyrus-imapd.tls_tlsonly.patch	- add tlsonly config option to fix POODLE vulnerability

Files

/usr/bin/cyradm
/usr/share/man/man1/cyradm.1.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon May 9 13:31:33 2022