Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libdrumstick-rt-plugins-1.1.3-lp152.1.1 RPM for aarch64

From OpenSuSE Ports Leap 15.2 for aarch64

Name: libdrumstick-rt-plugins Distribution: openSUSE Leap 15.2
Version: 1.1.3 Vendor: openSUSE
Release: lp152.1.1 Build date: Wed Feb 19 19:05:18 2020
Group: System/Libraries Build host: obs-arm-2
Size: 825046 Source RPM: drumstick-1.1.3-lp152.1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: http://drumstick.sourceforge.net/
Summary: MIDI Sequencer C++ Library
MIDI Sequencer C++ Library Bindings for Qt5 and ALSA.
This package contains input/output plugins for libdrumstick-rt1.

Provides

Requires

License

GPL-2.0-or-later AND GPL-3.0-or-later AND Apache-2.0

Changelog

* Sun Oct 20 2019 Christophe Giboudeaux <christophe@krop.fr>
  - Update to 1.1.3
    * IPv6 support added
    * Avoid endless loops on unexpected end of input.
    * Generate SMFError when the parser finds unexpected end of input.
    * general cleanups and bringing back the fluidsynth backend
    * migration to full GNUInstallDirs support
    * modernization started of the CMake build system
    * Library includes reorganization
    * Fixed drumstick-file unit test
    * Custom commandline parser replaced by standard Qt5 QCommandLineParser
    * fixed spurious error message for ALSA input
  - Drop Dont-use-QOverload.patch. No longer needed.
  - Update the libdrumstick-rt-plugins license tag, eassynth contains
    Apache-2.0 files.
* Tue Dec 18 2018 wbauer@tmo.at
  - Add Dont-use-QOverload.patch to make it build on Leap 42.3
* Tue Dec 18 2018 wbauer@tmo.at
  - Update to 1.1.2
    * Fix for ticket #13 - some macOS input events lost
    * Added some bundle metadata for macOS
    * Solution for ticket #8: Path for plugins hardcoded
  - Add pkgconfig(libpulse-simple) BuildRequires to enable building
    of libdrumstick-rt-eassynth.so (boo#1119734)
  - Move rt input/output plugins to a separate
    libdrumstick-rt-plugins package that's required by
    libdrumstick-rt1
* Fri May 25 2018 christophe@krop.fr
  - Update to 1.1.1
    * fixed tab order on forms
    * rt: fixed pitch bend events on several output backends
    * removed ALSA/Linux dependency where possible.
    * disabled fluidsynth output driver
  - Split libdrumstick-rt from the main package.
* Mon Dec 18 2017 christophe@krop.fr
  - Update to 1.1.0
    * guiplayer accepts a single file argument in the command line:
      mid, kar, wrk and ove
    * documentation updated
    Check the installed ChangeLog file for the complete changelog.
  - Drop gcc6-fix.patch. Merged upstream.
* Fri Jun 17 2016 jengelh@inai.de
  - Drop archaic sections, set rpm groups
* Fri Jun 17 2016 wbauer@tmo.at
  - The devel package requires libQt5Core-devel now, not libqt4-devel
* Fri Jun 17 2016 wbauer@tmo.at
  - Add gcc6-fix.patch to fix build with gcc6
* Wed Jun 15 2016 wbauer@tmo.at
  - Use shared-mime-database macros (boo#979301)
* Tue Apr 12 2016 tittiatcoke@gmail.com
  - Update to version 1.0.2
    * Qt5 port.
  - Drop x11.diff. No longer required.

Files

/usr/lib64/drumstick
/usr/lib64/drumstick/libdrumstick-rt-alsa-in.so
/usr/lib64/drumstick/libdrumstick-rt-alsa-out.so
/usr/lib64/drumstick/libdrumstick-rt-eassynth.so
/usr/lib64/drumstick/libdrumstick-rt-net-in.so
/usr/lib64/drumstick/libdrumstick-rt-net-out.so
/usr/lib64/drumstick/libdrumstick-rt-oss-in.so
/usr/lib64/drumstick/libdrumstick-rt-oss-out.so
/usr/share/licenses/libdrumstick-rt-plugins
/usr/share/licenses/libdrumstick-rt-plugins/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Jul 9 12:55:53 2022