Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

setools-java-3.3.8-lp150.1.2 RPM for ppc64le

From OpenSuSE Ports Leap 15.0 for ppc64le

Name: setools-java Distribution: openSUSE Leap 15.0
Version: 3.3.8 Vendor: openSUSE
Release: lp150.1.2 Build date: Wed May 9 23:13:11 2018
Group: Development/Languages Build host: obs-power8-05
Size: 910330 Source RPM: setools-3.3.8-lp150.1.2.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/TresysTechnology/setools3/wiki
Summary: Java bindings for SELinux policy analysis
SETools is a collection of graphical tools, command-line tools, and
libraries designed to facilitate SELinux policy analysis.

This package includes Java bindings for the following libraries:

  libapol       policy analysis library
  libpoldiff    semantic policy difference library
  libqpol       library that abstracts policy internals
  libseaudit    parse and filter SELinux audit messages in log files
  libsefs       SELinux file contexts library

Provides

Requires

License

LGPL-2.0

Changelog

* Sat Sep 30 2017 coolo@suse.com
  - Move to minimum java target of 1.6, 1.5 is no longer supported
* Mon Jun 26 2017 jsegitz@suse.com
  - Added implicit-fortify-decl.patch to prevent warnings about implicit
    declarations
* Thu Aug 25 2016 jsegitz@novell.com
  - Deleted setools-3.3.7-libselinux-2.3.patch, we have a
    current libselinux now
* Mon Jul 18 2016 jsegitz@novell.com
  - Patch to work with current libsepol, libselinux
    Added: setools-tclass.patch
* Mon Mar 23 2015 p.drouand@gmail.com
  - Update to version 3.3.8
    * Fix bug preventing seaudit from starting
    * Add python bindings for seinfo and sesearch
    * seinfo exits with an error status
    * Support for named file transition rules
    * Add support for default types in sesearch
    * Man page updates for seinfo, seaudit, and sediff
    * Fix file type drop down list for open/close Apol query
    * Fix compile errors on new parameter in libsepol role_set_expand().
  - Update home project and download Urls
  - Remove merged patches
    * setools-python.patch
    * 0003-Since-we-do-not-ship-neverallow-rules-all-always-fai.patch
    * 0006-Changes-to-support-named-file_trans-rules.patch
    * 0007-Remove-unused-variables.patch
  - Update setools-3.3.6-libsepol.patch > setools-libsepol.patch
  - Remove redundant %clean section
* Mon May 26 2014 ro@suse.de
  - add patch: setools-3.3.7-libselinux-2.3.patch
    fix build with libselinux-2.3
* Fri Oct 11 2013 vcizek@suse.com
  - don't fail if there are no never-allow rules in the policy
  - remove dangling symlink /usr/bin/seaudit (bnc#812285)
    * added 0003-Since-we-do-not-ship-neverallow-rules-all-always-fai.patch
* Fri Sep 13 2013 pgajdos@suse.com
  - javapackages-tools in buildrequires
* Tue Mar 12 2013 vcizek@suse.com
  - added patches:
    * 0006-Changes-to-support-named-file_trans-rules.patch
    * 0007-Remove-unused-variables.patch
    - these two add support for named file trans rules
    * add-to-header-define_cond_filename_trans.patch
    - add missing define_cond_filename_trans() declaration
* Thu Oct 25 2012 coolo@suse.com
  - add explicit buildrequire on libbz2-devel
* Tue Aug 28 2012 idonmez@suse.com
  - Add setools-3.3.6-libsepol.patch to fix compilation with new
    libsepol
* Sun Aug 05 2012 meissner@suse.com
  - updated to version 3.3.7
  - removed 2 upstream patches
* Tue Jul 03 2012 coolo@suse.com
  - add setools-am121.patch to fix build with automake 1.12.1
* Thu Jun 14 2012 mls@suse.de
  - fix build with swig-2.0.7 (untested, though)
* Mon Feb 13 2012 coolo@suse.com
  - patch license to follow spdx.org standard
* Wed Nov 23 2011 coolo@suse.com
  - add libtool as buildrequire to avoid implicit dependency
* Thu May 26 2011 idonmez@novell.com
  - Add setools-swig-2x.patch: correctly detect swig 2.x
* Thu Feb 25 2010 prusnak@suse.cz
  - updated to 3.3.6
* Sat Sep 05 2009 dmueller@suse.de
  - remove libselinux requires, it does not exist and
    autorequires will do the right thing anyway
* Wed Jul 15 2009 prusnak@suse.cz
  - disable Requires: usermode
* Tue Jun 23 2009 prusnak@suse.cz
  - require libsepol-devel-static

Files

/usr/lib64/libjapol.so.4
/usr/lib64/libjapol.so.4.4
/usr/lib64/libjpoldiff.so.1
/usr/lib64/libjpoldiff.so.1.3.3
/usr/lib64/libjqpol.so.1
/usr/lib64/libjqpol.so.1.7
/usr/lib64/libjseaudit.so.4
/usr/lib64/libjseaudit.so.4.5
/usr/lib64/libjsefs.so.4
/usr/lib64/libjsefs.so.4.0.4
/usr/share/java/apol.jar
/usr/share/java/poldiff.jar
/usr/share/java/qpol.jar
/usr/share/java/seaudit.jar
/usr/share/java/sefs.jar
/usr/share/setools-3.3/apol.jar
/usr/share/setools-3.3/poldiff.jar
/usr/share/setools-3.3/qpol.jar
/usr/share/setools-3.3/seaudit.jar
/usr/share/setools-3.3/sefs.jar


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 10:26:55 2021