Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libvshadow-tools-0~20170902-lp150.1.2 RPM for ppc64le

From OpenSuSE Ports Leap 15.0 for ppc64le

Name: libvshadow-tools Distribution: openSUSE Leap 15.0
Version: 0~20170902 Vendor: openSUSE
Release: lp150.1.2 Build date: Wed May 9 14:27:10 2018
Group: System/Filesystems Build host: obs-power8-05
Size: 206231 Source RPM: libvshadow-0~20170902-lp150.1.2.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/libyal/libvshadow/wiki
Summary: Tools to access the Volume Shadow Snapshot (VSS) format
Tools to access the Volume Shadow Snapshot (VSS) format. The VSS format is used by Windows, as of Vista, to maintain copies of data on a storage media volume.

Provides

Requires

License

LGPL-3.0+

Changelog

* Mon Nov 06 2017 Greg.Freemyer@gmail.com
  - add python3 binding subpackage
* Wed Oct 04 2017 Greg.Freemyer@gmail.com
  - rename python-libvshadow to python2-libshadow as expected by singlespec
  - remove Provides pyvshadow as it is not versioned
* Mon Oct 02 2017 Greg.Freemyer@gmail.com
  - update to v0~20170902
    * applied 2017 update
    * worked on tests
* Thu Feb 16 2017 Greg.Freemyer@gmail.com
  - update to v0~20161111
  - rename Volume_Shadow_Snapshot_VSS_format.pdf to meet new OBS naming rules
  - clean up BuildRequires
* Mon Jan 25 2016 Greg.Freemyer@gmail.com
  - update to v0~20160110
    * worked on Python 3 support
    * worked on win2k3 format support
    * introduced new function has_in_volume_data
* Thu Jan 08 2015 Greg.Freemyer@gmail.com
  - update to v0~20150106
    * 2015 update - minimal changes
  - remove ifdef macros around buildrequires
    * The ifdefs are no longer needed now that all of libyal is in security:forensics
  - update BuildRequires based on new packages in OBS
* Thu Dec 11 2014 Greg.Freemyer@gmail.com
  - update to v0~20141023
    * bug fix in Python-bindings
    * update man page / info page
  - update URL to point to new home on github
  - update Source: field to a full URL referring to github
  - delete DL-URL comment
  - add several BuildRequires to use libyal packages from OBS
* Wed Aug 20 2014 Greg.Freemyer@gmail.com
  - add "Requires:  %lname = %version" to tools sub-project
  - add "Provice:  pyvshadow" to match upstream requires
* Wed Aug 13 2014 Greg.Freemyer@gmail.com
  - update to v0~20140731
    * updated dependencies
    * worked on Python bindings
    * worked on setup.py
    * changed return value check of libvshadow_store_read_buffer to allow for
    on read size valid read count values
    * subtle bug fix where python file-like object returns an int object
    instead of long object
    * improved error reporting
* Thu Oct 03 2013 Greg.Freemyer@gmail.com
  - update to 0~20131003
    * Primarily Windows related improvements
  - add libcthread as a standalone BuildRequires
  - update BuildRequires for post 13.1 builds
* Fri Aug 02 2013 Greg.Freemyer@gmail.com
  - add version levels to BuildRequires to due to a build failure with older libyal packages
* Sat Jul 27 2013 Greg.Freemyer@gmail.com
  - update to 0~20130723
    * Changes for stand-alone libbfio build
    * remove unnecessary restriction in library include headers
    * updated dependencies
    * worked on multi-threading support
    * added libvshadow_volume_get_store_identifier function
    * added libcthreads
    * changes to read block descriptors on demand improves vshadowinfo preformance
    * fixes for multiple open/close on the same volume object
    * fixed issue in read buffer due to recent changes
    * added store read from file IO handle function
    * vshadowmount small changes
    * worked on tests
    * worked on vshadowmount Dokan support
  - Added buildrequires for gcc
  - Use factory libyal packages if possible
  - Add BuildRequires for fuse-devel.  Required for vshadowmount in libvshadow-tools to work correctly.
* Wed Apr 17 2013 Greg.Freemyer@gmail.com
  - update to 0~20130413
  - make specfile more consistent with the other Joachim Metz packages in openSUSE
    * change version from 0.0.0~%{timestamp} to 0~%{timestamp}
    * move developer docs to devel package
    * add BuildRequires for the internally provided libs
  - add Volume_Shadow_Snapshot_(VSS)_format.pdf to devel package
* Wed Mar 27 2013 Greg.Freemyer@gmail.com
  - initial package 0~20130304

Files

/usr/bin/vshadowdebug
/usr/bin/vshadowinfo
/usr/bin/vshadowmount
/usr/share/man/man1/vshadowinfo.1.gz
/usr/share/man/man1/vshadowmount.1.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 10:26:55 2021