Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

abiword-3.0.2-lp150.2.2 RPM for ppc64le

From OpenSuSE Ports Leap 15.0 for ppc64le

Name: abiword Distribution: openSUSE Leap 15.0
Version: 3.0.2 Vendor: openSUSE
Release: lp150.2.2 Build date: Wed May 9 18:04:12 2018
Group: Productivity/Office/Word Processor Build host: obs-power8-01
Size: 295164 Source RPM: abiword-3.0.2-lp150.2.2.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.abisource.com/
Summary: A Multiplatform Word Processor
AbiWord is a multiplatform word processor with a GTK+ interface on the
UNIX platform.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Wed Mar 21 2018 dimstar@opensuse.org
  - Drop --with-pic configure parameter: since we disable static
    libs, it has no effect.
* Sun Mar 18 2018 bjorn.lie@gmail.com
  - Add missing pkgconfig(libjpeg) BuildRequires: Previously pulled
    in by libwmf.
  - Stop handling desktop_database_post(un) in post(un), no longer
    needed since file-triggers takes care of this now.
  - Drop update-desktop-files BuildRequires and stop passing
    suse_update_desktop_file macro.
  - Run spec-cleaner, modernize spec.
* Mon May 01 2017 dufresnep@gmail.com
  - Add abiword-fix-black-overlay.patch: Remove the black covering
    full window and make all unreadable, patch from upstream.
* Tue Jan 17 2017 adam.majer@suse.de
  - Add boost_asio.patch: Add support for boost::asio.
  - Drop asio-devel BuildRequires, merged into boost 1.62.
  - Replace boost-devel with libboost_headers-devel BuildRequires.
  - Drop obsolete conditional for post(un) handling.
* Wed Jan 04 2017 zaitor@opensuse.org
  - Update to version 3.0.2:
    + See http://www.abisource.com/release-notes/3.0.2.phtml for an
      overview of all bugs fixed in this release.
  - Drop abiword-3.0.0-linkgrammar.patch and
    abiword-3.0.1-gcc6.patch: Fixed upstream.
* Fri Jun 17 2016 normand@linux.vnet.ibm.com
  - Add abiword-3.0.1-gcc6.patch: Fix build with gcc6 (boo#985070).
* Mon May 09 2016 dimstar@opensuse.org
  - Re-add abiword-librevenge.patch that was wrongly dropped when
    upgrading to Abiword 3.0.1.
  - Add libtool BuildRequires and an injected copy of abiword's
    autogen.sh, as above patch touches the build system.
  - Add abiword-libwps-0.4.patch: Port to libwps 0.4.
  - Change pkgconfig(libwps-0.3) BuildRequires to
    pkgconfig(libwps-0.4) in order to enable Microsoft Works Document
    support again.
  - Drop explicit libabiword-3_0 and link-grammar Requires: they are
    auto-detected.
* Wed Feb 25 2015 dimstar@opensuse.org
  - Drop loudmouth-devel BuildRequires: loudmouth is dead upstream
    and not worth to be maintained.
* Wed Jan 28 2015 dimstar@opensuse.org
  - Update to version 3.0.1:
    + See http://www.abiword.org/release-notes/3.0.1.phtml for an
      overview of all bugs fixed in this release.
  - Drop upstream fixed patches: abiword-3.0.0-html_segfault.patch,
    abiword-boost.patch, abiword-gcrypt-1.6.0.patch and
    abiword-librevenge.patch.
  - Drop libtool, autogen and automake BuildRequires: we don't touch
    the buildsystem anymore.
  - Drop the in-file copy of upstream's autogen.sh: as we don't have
    to bootstrap, there is no need to preserve this code piece. If
    we ever need it again, we better sync up with upstreams changes
    at that moment again.
* Mon Oct 06 2014 dimstar@opensuse.org
  - Add abiword.appdata.xml to the package.
* Wed Jul 23 2014 dimstar@opensuse.org
  - Update old-style -devel BuildRequires with pkgconfig()-style,
    matching what configure checks for:
    + Old: libgsf-devel, fribidi-devel, wv-devel, libxslt-devel,
      enchant-devel, gtk3-devel.
    + New pkgconfig(): libgsf-1, fribidi,, wv-1.0, libxslt, enchant,
      gtk+-3.0, cairo.
* Tue Jul 22 2014 fstrba@suse.com
  - Add abiword-3.0.0-html_segfault.patch:
    + upstream patch to fix segfault in the html conversion.
    + this will fix build of abiword-docs on some platforms.
* Tue Jul 22 2014 fstrba@suse.com
  - Add abiword-3.0.0-linkgrammar.patch:
    + upstream patch to fix building with newer versions of
      linkgrammar.
* Wed May 28 2014 fstrba@suse.com
  - Add abiword-librevenge.patch:
    + upstream patch to build against libwpd 0.10.x, libwpg 0.3.x
      and libwps 0.3.x that have different ABI from their
      predecessors.
  - Add pkgconfig(librevenge-0.0) BuildRequires: the new base
    framework library for the 3 above-mentioned libraries
  - Replace old-style -devel BuildRequires with pkgconfig() style:
    + old: libpwd-devel, libwpg-devel, libwps-devel.
    + new: pkgconfig(libwpd-0.10,libwpg-0.3,libwps-0.3).
  - As above patches touch the build system:
    - Add libtool, autoconf and automake BuildRequires.
    - Add copy of autogen-common.sh to correctly bootstrap the
      sources.
* Thu May 01 2014 dimstar@opensuse.org
  - Add abiword-boost.patch: Fix build with boost: missing includes.
* Sun Jan 19 2014 zaitor@opensuse.org
  - Drop psiconv-devel BuildRequires, as I doubt there are any users
    left of this.
* Sun Jan 05 2014 dimstar@opensuse.org
  - Add abiword-gcrypt-1.6.0.patch: Fix build with gcrypt 1.6.0.
* Thu Oct 24 2013 cornelis@solcon.nl
  - Update to final release 3.0.0:
    + Besides porting to GTK+ 3.x, the AbiWord 3.0 release has a heck
      of a lot of bug-fixes, much-improved internationalization, RDF
      drag-and-drop, double-buffering of drawings to reduce screen
      flickering, and numerous other changes throughout the entire
      code-base.
* Sat Sep 21 2013 dimstar@opensuse.org
  - Change RPM Group of shared library package to System/Libraries.
* Wed Aug 14 2013 cornelis@solcon.nl
  - Update to svn.
* Fri Jun 14 2013 cornelis@solcon.nl
  - gtk2 is not supported, so back to gtk3, now done everywhere in
    spec file:
    + Replace gtk2-devel BuildRequires with gtk3-devel.
* Fri Jun 14 2013 cornelis@solcon.nl
  - Use gtk2 again:
    + Replace gtk3-devel BuildRequires with gtk2-devel.
* Sun Jun 02 2013 cornelis@solcon.nl
  - Update to svn 3_0_0 branch
    + Switch to GTK3.
  - Replace gtk2-devel BuildRequires with gtk3-devel.
  - Add libxslt-devel BuildRequires: new dependency.
  - Replace pkgconfig(libgoffice-0.8) BuildRequires with
    pkgconfig(libgoffice-0.10).
  - Rename libabiword-2_8 subpackage to libabiword-3_0 and
    libabiword-2_8-devel to libabiword-3_0-devel
  - Remove all patches (are upstream now):
    + abiword-gcc46.patch
    + abiword-glib-2.31.patch
    + abiword-libpng15.patch
* Wed Oct 03 2012 pgajdos@suse.com
  - build also with libpng15
    * libpng15.patch
* Thu Jan 19 2012 vuntz@opensuse.org
  - Change goffice-devel BuildRequires to pkgconfig(libgoffice-0.8)
    to prepare for goffice bump to 0.9 and new goffice-0_8 source
    package.
* Mon Jan 09 2012 vuntz@opensuse.org
  - Add libgcrypt-devel BuildRequires: gcrypt.h is being included in
    some code, even if configure doesn't look for libgcrypt yet. Not
    that in the current development releases, libgcrypt is being
    explicitly checked for in configure, so this is a change we'd
    have to do in the future anyway.
* Mon Nov 28 2011 dimstar@opensuse.org
  - Add abiword-glib-2.31.patch: Fix build with glib 2.31.
* Sat Sep 17 2011 jengelh@medozas.de
  - Remove redundant tags/sections from specfile
  - Use %_smp_mflags for parallel build
* Mon May 16 2011 dimstar@opensuse.org
  - Add abiword-gcc46.patch: Fix build with gcc 4.6.
* Sat Feb 12 2011 vuntz@opensuse.org
  - Call relevant macros in %post/%postun:
    + %desktop_database_post/postun because the package ships at
      least one desktop file.
  - Improve descriptions by removing outdated references.
* Tue Jul 27 2010 andrea@opensuse.org
  - Update to version 2.8.6:
    + Preserve character properties when typing.
  - Changes from version 2.8.5:
    + Fix paste of rich text from HTML and ODT, where previously some
      formatting properties were not closed properly
    + Add a number of robustness fixes to the layout engine
    + Fix a table selection bug
    + OpenDocument Import/Export:
    - Significant OpenDocument filter improvements
    + Collaboration Plugin:
    - Fix a potential crash when more than 2 people are
      collaborating on a document and one of the collaborators
      disconnects
    - Don't include document names that a buddy does not have
      access to in the list of available shared documents that is
      sent to him
    - Fix some small memory leaks in the *.abicollab importer
    - Honor SRV DNS records when collaborating over XMPP
    + MS Write Plugin:
    - Improved MS Write filter support
  - Changes from version 2.8.4:
    + Fix a bug where deleting a character in non-Western scripts
      caused a random number of characters to be deleted.
    + Fix cursor movement for complex scripts, as text cluster
      boundaries are now honored.
    + Fix the text rendering of complex scripts when text is selected
    + Fix text rendering errors when font substitution was involved
    + GNOME Office Plugin:
    - Use double click to select a component type and close the
      dialog
  - Changes from version 2.8.3:
    + Fix random crashes mostly observed on Linux/Unix platforms
      coupled with PulseAudio (it's not Pulse's fault!)
    + Abiword Format Import/Export:
    - Meta data is escaped twice in the AbiWord exporter
    + OpenDocument Import/Export:
    - Fix crash in OpenDocument importer
    - Add tabstop/tableader/tab default interval support to the
      OpenDocument import/export filters
    - Support opening password protected OpenDocument files
    - Add application/vnd.oasis.opendocument.text-web as a
      supported mimetype in the ODF importer. Also add
      application/vnd.oasis.opendocument.text-{template,web} to
      abiword.desktop.
    - Add AbiWord's version and platform in the meta:generator
      field.
* Sat Feb 13 2010 vuntz@opensuse.org
  - Update to version 2.8.2:
    + See http://abisource.com/changelogs/2.8.2.phtml for the full
      list of changes.
    + Fix German smart-quote support
    + Fix landscape printing on GTK+ platforms
    + Improved OpenDocument compatibility
    + Add an abiword(1) manpage
  - Remove gnome-vfs2-devel BuildRequires and Requires in devel
    package: it's only needed if gio is not there.
  - Remove gucharmap-devel BuildRequires and Requires in devel
    package: the support has been removed because of unstable API.
  - Add goffice-devel to Requires of devel package since it's now
    successfully used in the build.
* Sat Dec 05 2009 vuntz@opensuse.org
  - Update to version 2.8.1:
    + See http://abisource.com/release-notes/2.8.0.phtml for the list
      of major changes in the 2.8 series.
    + Improved Collaboration support, with abicollab.net
    + Annotation / Comment support
    + Proper Smart Quote support
    + Multi-Page View
    + True Scalable Vector Graphics (SVG) support
    + Improved OpenDocument Format (.odt) support
    + Improved Office Open XML (.docx) support
    + New printing framework
  - Add gnome-vfs2-devel, goffice-devel, gtk2-devel, gucharmap-devel,
    libsoup-devel, libwmf-devel, libwpg-devel, libwps-devel
    BuildRequires.
  - Add cairo-devel, gucharmap-devel, librsvg-devel to Requires of
    devel package.
  - Remove gtkmathview-devel, libglade2-devel, libgnomeprintui-devel,
    nautilus-devel BuildRequires
  - Remove fontconfig-devel, freetype2-devel, libglade2-devel,
    libgnomeprint-devel, libgnomeprintui-devel, libgnomeui-devel,
    libpng-devel, xorg-x11-devel Requires of devel
    package.
  - Drop abiword-plugins-glibc-const.patch: fixed upstream.
  - Drop abiword-plugins-ncurses.patch: not needed anymore.
  - Remove py_requires macro, there's no python here.
  - Remove --enable-libabiword from configure, and instead pass
    - -enable-dynamic to configure, as recommended for pyabiword.
  - Pass --enable-plugins, --enable-clipart, --enable-templates to
    configure.
  - Pass --enable-emacs-keybinding and --enable-vi-keybinding to
    configure.
  - Fix self-obsoletion of libabiword-devel.
  - Use fdupes.
  - The abiword-extras and abiword-plugins tarballs have been merged
    with the main abiword package, and the abiword-doc tarball will
    move to another package, so adapt the build for this.
* Wed Jun 10 2009 vuntz@novell.com
  - Add abiword-plugins-glibc-const.patch to fix build failure with
    latest glibc.
* Fri May 22 2009 vuntz@novell.com
  - Add bison, flex, gtkmathview-devel BuildRequires for the plugins.
* Fri Apr 24 2009 vuntz@novell.com
  - Completely reorganize the spec file to make it clearer what
    applies to abiword, and what applies to abiword-plugins.
    (Note: we can't split abiword and abiword-plugins in two source
    packages since abiword-plugins needs to be built with abiword
    source code)
  - Also compile abiword-extras and abiword-docs in the package,
    since it's useful stuff for the user.
  - Add some BuildRequires: dbus-1-glib-devel, libglade2-devel
  - Comment some BuildRequires that won't work for various reasons:
    goffice-devel, gucharmap-devel, libgda-4_0-devel,
    libgnomedb-devel
  - Remove unneeded BuildRequires: aspell-devel, gnutls-devel,
    libtiff-devel, libwnck-devel, mDNSResponder-devel
  - Add some notes about missing BuildRequires for libraries that are
    not in openSUSE.
  - Add missing requires to the devel package: enchant-devel,
    fontconfig-devel, fribidi-devel, gnome-vfs2-devel, libgsf-devel,
    libpng-devel, wv-devel, xorg-x11-devel.
  - Pass --with-abicollab-sugar-backend to the configure of
    abiword-plugins to get the sugar backend of abicollab too.
  - Do not add categories to the desktop files.
  - Remove checks for old versions of openSUSE.
  - Move the plugins and data files in the libabiword-2_6 package
    instead of just the abiword package since other applications
    using libabiword-2_6 need them.
  - Add abiword-plugins-ncurses.patch to make the abicommand plugin
    compile.
* Sat Apr 11 2009 mboman@suse.de
  - Update to version 2.6.8:
    + See http://www.abisource.com/changelogs/2.6.8.phtml for what's
      new in this version
  - Remove abiword-fixes.patch. Fixed upstream
  - Merge -devel into libabiword-2_6-devel
  - Clean up requires for libabiword-2_6-devel
  - Remove %if statements <= 10.2
  - Use CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"

Files

/usr/bin/abiword
/usr/share/appdata
/usr/share/appdata/abiword.appdata.xml
/usr/share/applications/abiword.desktop
/usr/share/doc/packages/abiword
/usr/share/doc/packages/abiword/AUTHORS
/usr/share/doc/packages/abiword/COPYRIGHT.TXT
/usr/share/icons/hicolor/16x16/apps/abiword.png
/usr/share/icons/hicolor/22x22/apps/abiword.png
/usr/share/icons/hicolor/256x256/apps/abiword.png
/usr/share/icons/hicolor/32x32/apps/abiword.png
/usr/share/icons/hicolor/48x48/apps/abiword.png
/usr/share/icons/hicolor/512x512/apps/abiword.png
/usr/share/icons/hicolor/scalable/apps/abiword.svg
/usr/share/licenses/abiword
/usr/share/licenses/abiword/COPYING
/usr/share/man/man1/abiword.1.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 10:26:55 2021