Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python3-fife-0.4.2-bp153.1.15 RPM for aarch64

From OpenSuSE Leap 15.3 for aarch64

Name: python3-fife Distribution: SUSE Linux Enterprise 15 SP3
Version: 0.4.2 Vendor: openSUSE
Release: bp153.1.15 Build date: Sat Mar 6 22:48:24 2021
Group: Amusements/Games/Other Build host: obs-arm-9
Size: 18639727 Source RPM: fife-0.4.2-bp153.1.15.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.fifengine.de
Summary: Python 3 extensions for the FIFE engine
FIFE stands for Flexible Isometric Free Engine and is a cross platform
game creation framework. It provides the ability to create a
game using Python interfaces.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Wed Sep 18 2019 Simon Puchert <simonpuchert@alice.de>
  - Add swig4.patch: Remove flags that are not supported with swig 4.
* Tue Feb 19 2019 Guillaume GARDET <guillaume.gardet@opensuse.org>
  - Add _constraints file to avoid build failures
* Sun Feb 03 2019 Matthias Bach <marix@marix.org>
  - Add missing runtime dependency to python3-futures.
* Sun Jan 13 2019 Jan Engelhardt <jengelh@inai.de>
  - Update descriptions.
* Sun Jan 13 2019 Michael Vetter <mvetter@suse.com>
  - Enable building share library again (also fixes build)
  - Remove project.diff and move content into changes file
* Sun Jan 13 2019 marix@marix.org
  - Update to fifengine 0.4.2
    * Compatiblity with fifechan 0.1.5
    * Python bindings are now provided for Python 3
    * Joystick and Gamepad support
  - Ship both, Python 3 and Python 2 bindings to not instantly break
    all downstream packages.
  - Dropped installation-directories.patch which has been integrated
    upstream.
  - Dropped install-rocket-header.patch which has been integrated
    upstream.
  - Dropped link-cegui.patch which has been integrated
    upstream.
* Wed Feb 22 2017 rpm@fthiessen.de
  - Update to version 0.4.1
  - Now build with cmake instead of scons
  - Added patches from upstream: install-rocket-header.patch,
    installation-directories.patch and link-cegui.patch
* Sun Jan 11 2015 mailaender@opensuse.org
  - FIFE is incompatible with swig version 3

Files

/usr/lib64/python3.6/site-packages/fife
/usr/lib64/python3.6/site-packages/fife/__init__.py
/usr/lib64/python3.6/site-packages/fife/_fife.so
/usr/lib64/python3.6/site-packages/fife/_fifechan.so
/usr/lib64/python3.6/site-packages/fife/extensions
/usr/lib64/python3.6/site-packages/fife/extensions/__init__.py
/usr/lib64/python3.6/site-packages/fife/extensions/basicapplication.py
/usr/lib64/python3.6/site-packages/fife/extensions/fife_compat.py
/usr/lib64/python3.6/site-packages/fife/extensions/fife_settings.py
/usr/lib64/python3.6/site-packages/fife/extensions/fife_timer.py
/usr/lib64/python3.6/site-packages/fife/extensions/fife_utils.py
/usr/lib64/python3.6/site-packages/fife/extensions/fifelog.py
/usr/lib64/python3.6/site-packages/fife/extensions/librocket
/usr/lib64/python3.6/site-packages/fife/extensions/librocket/__init__.py
/usr/lib64/python3.6/site-packages/fife/extensions/librocket/rocketbasicapplication.py
/usr/lib64/python3.6/site-packages/fife/extensions/loaders.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/__init__.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/attrs.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/autoposition.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/compat.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/dialog
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/dialog/__init__.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/dialog/filebrowser.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/dialogs.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/events.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/exceptions.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/fife_pychansettings.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/fontfileparser.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/fonts.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/internal.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/properties.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/pychanbasicapplication.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/tools.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/__init__.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/adjustingcontainer.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/animationicon.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/bargraph.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/basictextwidget.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/buttons.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/checkbox.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/common.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/containers.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/curvegraph.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/dockarea.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/dropdown.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/ext
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/ext/__init__.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/flowcontainer.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/icon.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/iconprogressbar.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/imageprogressbar.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/label.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/layout.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/linegraph.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/listbox.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/panel.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/passwordfield.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/percentagebar.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/piegraph.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/pointgraph.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/radiobutton.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/resizablewindow.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/scrollarea.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/slider.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/spacer.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/tabbedarea.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/textbox.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/textfield.py
/usr/lib64/python3.6/site-packages/fife/extensions/pychan/widgets/widget.py
/usr/lib64/python3.6/site-packages/fife/extensions/pythonize.py
/usr/lib64/python3.6/site-packages/fife/extensions/savers.py
/usr/lib64/python3.6/site-packages/fife/extensions/serializers
/usr/lib64/python3.6/site-packages/fife/extensions/serializers/__init__.py
/usr/lib64/python3.6/site-packages/fife/extensions/serializers/simplexml.py
/usr/lib64/python3.6/site-packages/fife/extensions/serializers/xml_loader_tools.py
/usr/lib64/python3.6/site-packages/fife/extensions/serializers/xmlanimation.py
/usr/lib64/python3.6/site-packages/fife/extensions/serializers/xmlmap.py
/usr/lib64/python3.6/site-packages/fife/extensions/serializers/xmlmapsaver.py
/usr/lib64/python3.6/site-packages/fife/extensions/serializers/xmlobject.py
/usr/lib64/python3.6/site-packages/fife/fife.py
/usr/lib64/python3.6/site-packages/fife/fifechan.py


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 18:27:03 2021