Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

net6-devel-1.3.14-bp153.1.17 RPM for aarch64

From OpenSuSE Leap 15.3 for aarch64

Name: net6-devel Distribution: SUSE Linux Enterprise 15 SP3
Version: 1.3.14 Vendor: openSUSE
Release: bp153.1.17 Build date: Sat Mar 6 05:55:01 2021
Group: Development/Libraries/GNOME Build host: obs-arm-9
Size: 107973 Source RPM: net6-1.3.14-bp153.1.17.src.rpm
Packager: https://bugs.opensuse.org
Url: http://gobby.0x539.de/
Summary: Network access framework for IPv4/IPv6
net6 is a library which eases the development of network-based
applications as it provides a TCP protocol abstraction for C++. It is
portable to both the Windows and Unix-like platforms.

Provides

Requires

License

LGPL-2.1+

Changelog

* Thu Apr 23 2015 zaitor@opensuse.org
  - Add net6-gnutls30.patch: Fix build with gnutls30, patch taken
    from Arch linux.
* Wed May 23 2012 vuntz@opensuse.org
  - Move to pkgconfig()-style BuildRequires:
    + Old ones: libgnutls-devel, libsigc++2-devel.
    + New ones: gnutls, sigc++-2.0.
* Mon May 21 2012 badshah400@gmail.com
  - Use libgnutls-devel BuildRequires instead of gnutls-devel for
    openSUSE > 12.1: gnutls-devel has been removed from Factory.
* Mon Nov 07 2011 dimstar@opensuse.org
  - Update to version 1.3.14:
    + Ensure that overflows on the user ID assigned to each
      connection do not yield one that is already in use.
      [CVE-2011-4093]
    + Do not leak information about logged-in users. [CVE-2011-4091]
    + Fix build failures with GnuTLS 3.0 and above
    + Updated translations
  - Drop net6-gnutls-3.0.3.patch and net6-gnutls-3.0.patch: fixed
    upstream.
* Wed Sep 28 2011 vuntz@opensuse.org
  - Add net6-gnutls-3.0.3.patch: fix build with gnutls 3.0.3.
* Mon Sep 05 2011 vuntz@opensuse.org
  - Add net6-gnutls-3.0.patch: fix build with gnutls 3.0.
* Tue Apr 26 2011 dimstar@opensuse.org
  - Update to version 1.3.13:
    + Updated translations.
* Thu Dec 24 2009 vuntz@opensuse.org
  - Update to version 1.3.12:
    + Allow non-blocking sockets on *nix.
    + Updated translations.
* Tue Dec 08 2009 dimstar@opensuse.org
  - Update to version 1.3.11:
    + Fix possible TLS lockup on Windows
    + Updated translations.
* Tue Aug 25 2009 dimstar@opensuse.org
  - Update to version 1.3.10:
    + Ensure compatibility with GnuTLS >= 2.7.x by relying on
      pkg-config.
    + Set SO_REUSEADDR on server sockets to ensure fast server
      restarts
    + Updated translations.

Files

/usr/include/net6
/usr/include/net6/address.hpp
/usr/include/net6/client.hpp
/usr/include/net6/common.hpp
/usr/include/net6/connection.hpp
/usr/include/net6/default_accumulator.hpp
/usr/include/net6/encrypt.hpp
/usr/include/net6/enum_ops.hpp
/usr/include/net6/error.hpp
/usr/include/net6/gettext_package.hpp
/usr/include/net6/host.hpp
/usr/include/net6/local.hpp
/usr/include/net6/main.hpp
/usr/include/net6/non_copyable.hpp
/usr/include/net6/object.hpp
/usr/include/net6/packet.hpp
/usr/include/net6/queue.hpp
/usr/include/net6/select.hpp
/usr/include/net6/serialise.hpp
/usr/include/net6/server.hpp
/usr/include/net6/socket.hpp
/usr/include/net6/user.hpp
/usr/lib64/libnet6.so
/usr/lib64/pkgconfig/net6-1.3.pc


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 18:27:03 2021