Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libgnomeui-2.24.6+20170807.30334c28-2.36 RPM for aarch64

From OpenSuSE Leap 15.3 for aarch64

Name: libgnomeui Distribution: SUSE Linux Enterprise 15
Version: 2.24.6+20170807.30334c28 Vendor: SUSE LLC <https://www.suse.com/>
Release: 2.36 Build date: Thu May 31 21:34:01 2018
Group: Development/Libraries/GNOME Build host: ibs-arm-1
Size: 832731 Source RPM: libgnomeui-2.24.6+20170807.30334c28-2.36.src.rpm
Packager: https://www.suse.com/
Url: http://www.gnome.org/
Summary: The GNOME User Interface Library
This library contains all the user interface-related functions for
GNOME-based software. You need the libgnomeui-devel package if you want
to develop GNOME 2.x Desktop software.

Provides

Requires

License

GPL-2.0-or-later AND LGPL-2.1-or-later

Changelog

* Tue Mar 20 2018 dimstar@opensuse.org
  - Unconditionally enable translation-update-upstream: on
    Tumbleweed, this results in a NOP and for Leap in SLE paid
    translations being used (boo#1086036).
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner
* Fri Sep 08 2017 jengelh@inai.de
  - Update old boilerplate summaries and macros.
* Wed Aug 16 2017 zaitor@opensuse.org
  - Update to version 2.24.6+20170807.30334c28:
    + Fix compiler warnings.
    + Add DOAP file.
    + Doap category deprecated.
    + Explicitly link against libm for floor().
    + gnome-scores.h: Convert to UTF-8.
    + Updated translations.
  - Switch to source service git based checkout.
  - Following the above, add gnome-common BuildRequires and pass
    NOCONFIGURE=1 ./autogen.sh, we need to bootstrap.
  - Also add export CFLAGS="%{optflags} -Wno-error=format-nonliteral"
    as some warnings are fatal when building a gitcheckout.
  - Pass --enable-gtk-doc to configure, needed now to build docs.
  - Drop conditionals for obsolete versions of openSUSE.
  - Add Url, silence rpmlint.
  - Modernize spec.
  - Conditionally apply translations-update-upstream BuildRequires
    and macro for non-openSUSE only.
* Wed Jun 01 2016 jengelh@inai.de
  - Drop --with-pic, it is only relevant for static libs (which
    are not built). Trim trailing dots from summary. Drop redundant
    %clean section. Use %_smp_mflags for parallel building.
* Fri May 27 2016 idonmez@suse.com
  - Update to GNOME 3.20.2 FATE#318572
* Tue Jul 22 2014 dimstar@opensuse.org
  - Drop gnome-icon-theme Requires: no longer required after the
    merging of the themes into Adwaita theme, which in turn is a
    dependency to GTK+ 3.0.
* Mon Apr 15 2013 mmeister@suse.com
  - Added url as source.
    Please see http://en.opensuse.org/SourceUrls
* Fri Mar 01 2013 dimstar@opensuse.org
  - Spec-cleanup using format_spec_file service.
* Tue Feb 21 2012 vuntz@opensuse.org
  - Remove explicit Requires in devel subpackage, that will
    automatically be added the pkgconfig() way: gconf2-devel,
    gnome-vfs2-devel, gtk2-devel, libart_lgpl-devel,
    libbonoboui-devel, libgnome-devel, libgnome-keyring-devel,
    libgnomecanvas-devel.
  - Remove unneeded Requires from devel subpackage: libjpeg-devel,
    popt-devel, pkg-config.
  - Add explicit Requires for pkgconfig(ice) and pkgconfig(sm) in
    devel package: the pkgconfig file references some libraries in
    Libs (and not Requires), so we need to depend on them.
* Mon Feb 20 2012 vuntz@opensuse.org
  - Add explicit pkgconfig(ice), pkgconfig(sm) and pkgconfig(x11)
    BuildRequires, to avoid issues after the big xorg-x11 packaging
    change.
* Wed May 04 2011 vuntz@opensuse.org
  - Update to version 2.24.5:
    + Fix typo (G_TYPE_INSTANCE_CHECK_TYPE ->
      G_TYPE_CHECK_INSTANCE_TYPE)
    + Updated translations.
* Wed Sep 29 2010 aj@suse.de
  - Change lang package Requires to Recommends since it is not
    mandatory at runtime.
* Mon Sep 27 2010 vuntz@opensuse.org
  - Update to version 2.24.4:
    + Updated translations.
* Sat Apr 24 2010 coolo@novell.com
  - buildrequire pkg-config to fix provides
* Tue Mar 30 2010 vuntz@opensuse.org
  - Update to version 2.24.3:
    + Enable silent build using AM_SILENT_RULES
    + Fix the build with ATK_DISABLE_SINGLE_INCLUDES
    + Updated translations.
  - Remove en@shaw translations on 11.2 and earlier.
* Wed Dec 23 2009 vuntz@opensuse.org
  - Change gnome-keyring-devel BuildRequires and Requires to
    libgnome-keyring-devel, following the module split upstream.
* Thu Dec 17 2009 jengelh@medozas.de
  - Add baselibs.conf as a source
  - Make doc subpackage a noarch package
* Wed Dec 02 2009 vuntz@opensuse.org
  - Update the way we remove the la locale for old versions of
    openSUSE.
* Wed Sep 23 2009 dimstar@opensuse.org
  - Update to version 2.24.2:
    + Updated translations.
* Mon Mar 16 2009 sbrabec@suse.cz
  - Added support for translation-update-upstream (FATE#301344).
* Mon Mar 09 2009 vuntz@novell.com
  - Exclude locale files for la for openSUSE <= 11.1.
* Fri Mar 06 2009 vuntz@novell.com
  - Update to version 2.24.1:
    + Make it work with deprecations enabled in glib/gtk+
    + Fix leaks
    + Updated translations
  - Remove unneeded BuildRequires: gnome-common, perl-XML-Parser
  - Remove AutoReqProv: it's default now.
  - Remove unneeded call to autoreconf.
  - Remove -fno-strict-aliasing from CFLAGS.

Files

/usr/lib64/libglade/2.0/libgnome.so
/usr/lib64/libgnomeui-2.so.0
/usr/lib64/libgnomeui-2.so.0.2400.6
/usr/share/licenses/libgnomeui
/usr/share/licenses/libgnomeui/COPYING.LIB
/usr/share/pixmaps/gnome-about-logo.png


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 18:27:03 2021