Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libabiword-3_0-devel-3.0.2-bp153.1.21 RPM for aarch64

From OpenSuSE Leap 15.3 for aarch64

Name: libabiword-3_0-devel Distribution: SUSE Linux Enterprise 15 SP3
Version: 3.0.2 Vendor: openSUSE
Release: bp153.1.21 Build date: Sat Mar 6 12:14:26 2021
Group: Development/Libraries/GNOME Build host: obs-arm-8
Size: 25361 Source RPM: abiword-3.0.2-bp153.1.21.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.abisource.com/
Summary: A Multiplatform Word Processor - Development files
AbiWord is a multiplatform word processor with a GTK+ interface on the
UNIX platform.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Wed Mar 21 2018 dimstar@opensuse.org
  - Drop --with-pic configure parameter: since we disable static
    libs, it has no effect.
* Sun Mar 18 2018 bjorn.lie@gmail.com
  - Add missing pkgconfig(libjpeg) BuildRequires: Previously pulled
    in by libwmf.
  - Stop handling desktop_database_post(un) in post(un), no longer
    needed since file-triggers takes care of this now.
  - Drop update-desktop-files BuildRequires and stop passing
    suse_update_desktop_file macro.
  - Run spec-cleaner, modernize spec.
* Mon May 01 2017 dufresnep@gmail.com
  - Add abiword-fix-black-overlay.patch: Remove the black covering
    full window and make all unreadable, patch from upstream.
* Tue Jan 17 2017 adam.majer@suse.de
  - Add boost_asio.patch: Add support for boost::asio.
  - Drop asio-devel BuildRequires, merged into boost 1.62.
  - Replace boost-devel with libboost_headers-devel BuildRequires.
  - Drop obsolete conditional for post(un) handling.
* Wed Jan 04 2017 zaitor@opensuse.org
  - Update to version 3.0.2:
    + See http://www.abisource.com/release-notes/3.0.2.phtml for an
      overview of all bugs fixed in this release.
  - Drop abiword-3.0.0-linkgrammar.patch and
    abiword-3.0.1-gcc6.patch: Fixed upstream.
* Fri Jun 17 2016 normand@linux.vnet.ibm.com
  - Add abiword-3.0.1-gcc6.patch: Fix build with gcc6 (boo#985070).
* Mon May 09 2016 dimstar@opensuse.org
  - Re-add abiword-librevenge.patch that was wrongly dropped when
    upgrading to Abiword 3.0.1.
  - Add libtool BuildRequires and an injected copy of abiword's
    autogen.sh, as above patch touches the build system.
  - Add abiword-libwps-0.4.patch: Port to libwps 0.4.
  - Change pkgconfig(libwps-0.3) BuildRequires to
    pkgconfig(libwps-0.4) in order to enable Microsoft Works Document
    support again.
  - Drop explicit libabiword-3_0 and link-grammar Requires: they are
    auto-detected.
* Wed Feb 25 2015 dimstar@opensuse.org
  - Drop loudmouth-devel BuildRequires: loudmouth is dead upstream
    and not worth to be maintained.
* Wed Jan 28 2015 dimstar@opensuse.org
  - Update to version 3.0.1:
    + See http://www.abiword.org/release-notes/3.0.1.phtml for an
      overview of all bugs fixed in this release.
  - Drop upstream fixed patches: abiword-3.0.0-html_segfault.patch,
    abiword-boost.patch, abiword-gcrypt-1.6.0.patch and
    abiword-librevenge.patch.
  - Drop libtool, autogen and automake BuildRequires: we don't touch
    the buildsystem anymore.
  - Drop the in-file copy of upstream's autogen.sh: as we don't have
    to bootstrap, there is no need to preserve this code piece. If
    we ever need it again, we better sync up with upstreams changes
    at that moment again.
* Mon Oct 06 2014 dimstar@opensuse.org
  - Add abiword.appdata.xml to the package.

Files

/usr/include/abiword-3.0
/usr/include/abiword-3.0/abiwidget.h
/usr/include/abiword-3.0/libabiword.h
/usr/include/abiword-3.0/xap_UnixTableWidget.h
/usr/lib64/pkgconfig/abiword-3.0.pc


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 18:27:03 2021