Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

glib-networking-32bit-2.62.3-lp152.1.4 RPM for x86_64

From OpenSuSE Leap 15.2 for x86_64

Name: glib-networking-32bit Distribution: openSUSE Leap 15.2
Version: 2.62.3 Vendor: openSUSE
Release: lp152.1.4 Build date: Thu Jun 25 17:14:29 2020
Group: Development/Libraries/C and C++ Build host: build70
Size: 157436 Source RPM: glib-networking-2.62.3-lp152.1.4.src.rpm
Packager: https://bugs.opensuse.org
Url: https://www.gnome.org
Summary: Network-related GIO modules for glib
This package contains network-related GIO modules for glib.

Currently, there is only a proxy module based on libproxy.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Sat Jan 25 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - No longer recommend -lang: supplements are in use
* Sun Jan 05 2020 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.62.3:
    + Fix leak of base iostream (or base datagram socket), 2.62
      regression.
    + Fix duplicate notifies of peer-certificate and
      peer-certificate-errors.
    + Fix obscure corner case where SNI might not work.
* Tue Dec 10 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.62.2:
    + Fix handshake_context crashes.
* Sat Oct 05 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.62.1:
    + Fix two memory leaks.
* Sat Sep 07 2019 mgorse@suse.com
  - Update to version 2.62.0:
    + Revert broken queued data fix for
      glgo#GNOME/glib-networking#15.
* Mon Sep 02 2019 Michael Gorse <mgorse@suse.com>
  - Update to version 2.61.92:
    + Discard queued data after interrupted writes.
    + Verify socket timeouts are respected.
    + Fix a couple broken error messages.
    + Changes in version 2.61.90:
    + Fix translations of certain error messages
    + Changes in version 2.61.2:
    + Improve certain handshake error messages.
    + Fix regressions introduced in 2.61.1.
    + Changes in version 2.61.1:
    + This release contains a major refactoring of the TLS
      codebase. The GnuTLS backend now shares the same base classes
      as the OpenSSL backend, to avoid duplicating as much code as
      possible. The base classes, previously used only by the
      OpenSSL backend and originally forked from glib-networking
      several years ago, have been enhanced to achieve feature-parity
      with the current state of the GnuTLS backend.  Please note
      that the OpenSSL backend remains experimental. Further planned
      work is required before this backend will be production-ready.
* Wed Aug 28 2019 kukuk@suse.de
  - Move LICENSE_EXCEPTION to %license.
* Sun Jun 09 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.60.3:
    + Fix clobbering of the thread-default main context after
      certificate verification failure during async handshakes since
      2.60.1.
    + Fix GTlsDatabase initialization failures in OpenSSL backend due
      to uninitialized memory use.
    + Fix minor leak of ALPN protocols.
* Fri May 03 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.60.2:
    + OpenSSL backend now defaults to system trust store.
    + Fix client auth failure error with GnuTLS 3.6.7 (bsc#1134795).
  - Drop 0001-gnutls-Handle-new-GNUTLS_E_CERTIFICATE_REQUIRED.patch:
    fixed upstream.
* Fri Apr 05 2019 Vítězslav Čížek <vcizek@suse.com>
  - Handle new GnuTLS error GNUTLS_E_CERTIFICATE_REQUIRED
    + https://gitlab.gnome.org/GNOME/glib-networking/issues/70
    + add 0001-gnutls-Handle-new-GNUTLS_E_CERTIFICATE_REQUIRED.patch
* Tue Apr 02 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.60.1:
    + Improve reliability of client auth failure tests.
    + Fix excessive CPU usage after sync handshake.
* Tue Mar 12 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.60.0.1:
    + Fix build with OpenSSL pkg-config unavailable.
* Mon Mar 11 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.60.0:
    + This is the first stable release featuring the new OpenSSL
      backend. Please be advised that this new backend is still
      experimental and known to not work on some systems, including
      Debian. Linux distributions are encouraged to stick to the
      default build options, where OpenSSL is not yet enabled.
    + Fix build with GnuTLS disabled.
* Tue Mar 05 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.59.92:
    + GnuTLS: reject sync operations during handshake to avoid
      deadlocks.
    + Temporarily disable DTLS and OpenSSL tests due to bugs.
* Thu Feb 21 2019 bjorn.lie@gmail.com
  - Update to version 2.59.91:
    + Update OpenSSL SSL struct when certificate is changed.
    + Fix tests build when GnuTLS is disabled.
    + Remove Fedora-specific PROFILE=SYSTEM default cipher list.
    + Fix some problems with the connection tests.
* Thu Feb 14 2019 bjorn.lie@gmail.com
  - Update to version 2.59.90:
    + This release adds an OpenSSL backend, obsoleting the
      glib-openssl project.
    + The OpenSSL backend seems to be mature, though it is less
      well-tested for desktop usage than the GnuTLS backend. It will
      remain disabled by default at build time due to the
      GPL-incompatible nature of the OpenSSL license -- and the
      GPLv2-incompatible nature of the Apache license that will be
      used by future versions of OpenSSL -- and because the GnuTLS
      backend is sufficient for Linux distros.
    + Use the OpenSSL backend if you are building an embedded system
      where (GPLv2+ or LGPLv3+) dependencies are unacceptable (e.g.
      nettle or GMP, both dependencies of GnuTLS) and you are OK with
      the GPL-incompatible OpenSSL license. If the OpenSSL backend is
      enabled at build time, you should probably disable build of the
      GnuTLS backend, or it will take precedence over the OpenSSL
      backend at runtime.
* Tue Jan 08 2019 bjorn.lie@gmail.com
  - Update to version 2.59.2:
    + Add support for application layer protocol negotiation.
* Sat Jan 05 2019 bjorn.lie@gmail.com
  - Update to version 2.59.1:
    + This release removes the gnutls-pkcs11 backend, which was
      disabled in 2.57.2, due to lack of any feedback whatsoever
      regarding its disablement. If you think it is still useful to
      you, given that the normal gnutls backend now supports PKCS#11,
      speak up now.
    + This release also includes several changes to properly support
      TLS 1.3.
    + Other changes:
    - Perform certificate verification during, not after, TLS
      handshake.
    - Dramatically improve the reliability of the non-DTLS tests.
      (DTLS is still having problems).
    - Regenerate test certificates to prepare for OpenSSL support.
    - Several meson build system improvements to prepare for
      OpenSSL support.
* Wed Sep 26 2018 bjorn.lie@gmail.com
  - Update to version 2.58.0:
    + Updated translations.
* Wed Aug 29 2018 bjorn.lie@gmail.com
  - Update to version 2.57.92:
    + Revert fixes for glgo#GNOME/glib-networking#4 and
      glgo#GNOME/glib-networking#6 due to regression
      glgo#GNOME/glib-networking#43.
    + Fix installed tests glgo#GNOME/glib-networking!7.
* Mon Aug 13 2018 bjorn.lie@gmail.com
  - Update to version 2.57.90:
    + Properly check for server errors in connection tests.
    + Perform certificate verification during, not after, TLS
      handshake.
    + Avoid trailing dots in SNI hostnames.
    + Send fallback SCSV with fallback connection attempts.
    + Fail unsafe rehandshake attempts initiated by API request.
* Thu Jul 26 2018 bjorn.lie@gmail.com
  - Update to version 2.57.3:
    + Fix memory leaks when calling
      g_tls_connection_gnutls_get_certificate().
    + Use .so for modules on macOS instead of dylib.
    + Fix build with MSVCC.
* Wed Jun 06 2018 luc14n0@linuxmail.org
  - Update to version 2.57.2:
    + No visible changes for the user.
  - Drop pkgconfig(p11-kit-1) BuildRequires: it's now not enabled by
    default, and even when it was being enabled the backend would
    only work if the env GIO_USE_TLS=gnutls-pkcs11 would be set.
* Sat Jun 02 2018 luc14n0@linuxmail.org
  - Update to version 2.57.1:
    + Use GnuTLS system trust (bgo#753260).
    + Fix criticals when child streams outlast the parent
      GTlsConnection (bgo#792219).
    + Fix crash when setting client cert without private key
      (bgo#793712).
* Tue May 22 2018 bjorn.lie@gmail.com
  - Update to version 2.56.1:
    + Fix build with PKCS#11 backend disabled (bgo#794292).
    + Various meson build system fixes (bgo#794358 and bgo#794372).
    + Tests are now compatible with GnuTLS 3.6 (bgo#794286).
* Tue Mar 20 2018 dimstar@opensuse.org
  - Unconditionally enable translation-update-upstream: on
    Tumbleweed, this results in a NOP and for Leap in SLE paid
    translations being used (boo#1086036).
* Sun Mar 11 2018 dimstar@opensuse.org
  - Update to version 2.56.0:
    + Updated translations.
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner
* Tue Feb 13 2018 dimstar@opensuse.org
  - Update to version 2.55.90:
    + Fix unit tests when SSLv3 is unavailable (bgo#782853).
    + Allow static linking (bgo#791100).
    + Fix issues found by coverity (bgo#792402).
    + Remove TLS build option; it is now mandatory.
    + Try to ensure that GnuTLS is only initialized if TLS is
      actually used.
    + Update use of GObject to follow current best practices.
    + Use XDG_CURRENT_DESKTOP to determine which proxy module to
      load.
* Sun Dec 17 2017 luc14n0@linuxmail.org
  - Update to version 2.55.2:
    + Fix glib-pacrunner.service installation directory (bgo#790367).
    + Updated translations.
  - Drop glib-networking-Fix-build-failure-on-64bit-platforms.patch:
    fixed upstream.
  - Drop intltool BuildRequires as this is no longer used anymore
    once upstream migrated to gettext long ago.
  - Add pkgconfig(glib-2.0) BuildRequires. Note that it was being
    pulled with gio-2.0 pkgconfig module and used already as both of
    them live in glib2-devel package.
* Mon Dec 04 2017 dimstar@opensuse.org
  - Add pkgconfig(systemd) BuildRequires: new dependency after the
    port to meson.
* Tue Nov 14 2017 fezhang@suse.com
  - Update to version 2.55.1:
    + Implement DTLS support (bgo#697908).
    + Port to Meson build system (bgo#786639).
    + Updated translations.
  - Add ca-certificates-mozilla BuildRequires: new dependency.
  - Add meson BuildRequires and switch autotools macros configure,
    make and makeinstall to meson, meson_build and meson_install
    following upstream switch to Meson build system.
  - Add glib-networking-Fix-build-failure-on-64bit-platforms.patch:
    Fix a build failure (bgo#790367).
* Fri Oct 27 2017 luc14n0@linuxmail.org
  - Update to version 2.54.1:
    + gnutls: Fix using different client certs for different
      connections (bgo#781578).
    + Updated translations.
* Tue Sep 12 2017 luc14n0@linuxmail.org
  - Update to version 2.54.0:
    + Updated translations.
* Fri Sep 08 2017 jengelh@inai.de
  - Replace old macros and fixup RPM group.
* Tue Aug 15 2017 zaitor@opensuse.org
  - Update to version 2.53.90:
    + gnutls: Stop using %LATEST_RECORD_VERSION in priority string,
      since that gives better compatibility with current gnutls /
      current real world (bgo#782218).
    + gnutls: Provide a better error message when a TLS alert is
      received (bgo#782218).
    + Updated translations.
  - Conditionally apply translations-update-upstream BuildRequires
    and macro for non-openSUSE only.
* Mon Sep 19 2016 zaitor@opensuse.org
  - Update to version 2.50.0:
    + Updated translations.
* Tue Aug 16 2016 dimstar@opensuse.org
  - Update to version 2.49.90:
    + Ported to use upstream gettext rather than
      intltool/glib-gettext (bgo#768708).
    + Updated po files for future gettext versions.
    + Fixed translation lookup on Windows (bgo#765466).
    + Updated translations.
* Tue May 17 2016 mgorse@suse.com
  - Update to GNOME 3.20.2  Fate#318572
* Mon May 09 2016 zaitor@opensuse.org
  - Update to version 2.48.2:
    + gnutls: Fixed an infinite loop if a server sent two identical
      copies of its CA certificate (bgo#765317).
    + Updated translations.
* Tue Apr 26 2016 zaitor@opensuse.org
  - Update to version 2.48.1:
    + Fixed translations in non-UTF-8 domains (bgo#765466).
    + Fixed bash-ism in configure (bgo#765396).
    + Updated translations.
  - Stop passing V=1 to make, we do debugging locally.
  - Add default http://www.gnome.org as Url: Silence rpmlint.
* Tue Mar 22 2016 dimstar@opensuse.org
  - Update to version 2.48.0:
    + New stable release. (No changes since 2.47.90).
* Tue Feb 16 2016 dimstar@opensuse.org
  - Update to version 2.47.90:
    + gnutls: The non-PKCS#11 TLS plugin now uses gnutls's
      certificate validation code directly, rather than attempting to
      build a certificate chain itself first (bgo#753260 and others).
    + gnutls: Fixed a leak when closing a connection during an
      implicit handshake (bgo#736809).
    + gnutls: Fixed "make check" without PKCS#11 support
      (bgo#728977).
    + gnutls: Various changes in preparation for DTLS support (but
      not the actual DTLS support itself) (bgo#697908, bgo#735754).
    + Updated translations.
* Tue Nov 24 2015 zaitor@opensuse.org
  - Update to version 2.47.1:
    + Added a systemd service file for glib-pacrunner (bgo#755740).
* Mon Oct 12 2015 zaitor@opensuse.org
  - Update to version 2.46.1:
    + Fixed a certificate chain validation problem that affected
      Facebook in Epiphany (bgo#750457).
* Mon Sep 21 2015 dimstar@opensuse.org
  - Update to version 2.46.0:
    + Various minor cleanups and small memory leak fixes.
    + Added a new test case for client certificate chain handling
      (bgo#754129).
    + Updated translations.
* Fri May 01 2015 zaitor@opensuse.org
  - Update to version 2.45.1:
    + tls/gnutls: Implement
      g_tls_client_connection_copy_session_state(), to allow
      implementing FTP-over-TLS in gvfs (bgo#745255).
* Mon Mar 23 2015 dimstar@opensuse.org
  - Update to version 2.44.0:
    + Stable release, no changes since 2.43.92.
* Tue Mar 17 2015 dimstar@opensuse.org
  - Update to version 2.43.92:
    + Fix TLS session caching when using session tickets
      (bgo#745099).
    + Updated translations.
* Tue Mar 03 2015 dimstar@opensuse.org
  - Update to version 2.43.91:
    + tls/gnutls: Removed a workaround for connecting to servers with
      weak DH parameters, which was apparently only needed because
      gnutls was prioritizing DHE over RSA (rh#1177964#c8).
    + tls/gnutls: We now require gnutls 3.x again. (In fact, 2.42.1
      and 2.43.1 accidentally used a 3.x-only function, so we already
      required it, we were just failing to declare that fact).
    + tls/tests: Skip certain tests when running against old gnutls
      or GLib releases. (glib-networking 2.43.91 itself does not
      require GLib 2.43, but one of the test cases does).
    + Updated translations.
* Wed Dec 17 2014 zaitor@opensuse.org
  - Update to version 2.43.1:
    + The GTlsClientConnection "use-ssl3" property now falls back to
      TLS 1.0 if SSL 3.0 has been disabled, rather than just failing.
      Also, we now use the gnutls %LATEST_RECORD_VERSION option by
      default (to allow connecting to certain servers that were
      incorrectly patched for the POODLE attack), but also make sure
      to remove that option in the fallback ("use-ssl3") mode (to
      allow connecting to other servers that are differently broken)
      (bgo#738633, bgo#740087).
    + tls/gnutls: Miscellaneous warning, debugging, and leak fixes
      (bgo#736757, bgo#736809, bgo#737106).
    + Updated translations.
* Wed Dec 17 2014 zaitor@opensuse.org
  - Update to version 2.42.1:
    + The GTlsClientConnection "use-ssl3" property now falls back to
      TLS 1.0 if SSL 3.0 has been disabled, rather than just failing.
      Also, we now use the gnutls %LATEST_RECORD_VERSION option by
      default (to allow connecting to certain servers that were
      incorrectly patched for the POODLE attack), but also make sure
      to remove that option in the fallback ("use-ssl3") mode (to
      allow connecting to other servers that are differently broken).
      (bgo#738633, bgo#740087).
    + tls/gnutls: Miscellaneous warning, debugging, and leak fixes
      (bgo#736757, bgo#736809, bgo#737106).
    + Updated translations.

Files

/usr/lib/gio
/usr/lib/gio/modules
/usr/lib/gio/modules/libgiognomeproxy.so
/usr/lib/gio/modules/libgiognutls.so
/usr/lib/gio/modules/libgiolibproxy.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Oct 9 13:58:38 2021