Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

read-only-root-fs-1.0+git20190206.586e9f1-lp152.2.2 RPM for noarch

From OpenSuSE Leap 15.2 for noarch

Name: read-only-root-fs Distribution: openSUSE Leap 15.2
Version: 1.0+git20190206.586e9f1 Vendor: openSUSE
Release: lp152.2.2 Build date: Fri Sep 20 22:25:49 2019
Group: System/Fhs Build host: lamb27
Size: 19566 Source RPM: read-only-root-fs-1.0+git20190206.586e9f1-lp152.2.2.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/openSUSE/read-only-root-fs
Summary: Files and Scripts for a RO root fileystem
Files, scripts and directories to run the system with a
read-only root filesystem with /etc writeable via overlayfs.

This package should never be installed in an already running
system! It should only be selected by a system role for a
read-only root filesystem with transactional updates.
The package will create / modify entries for mounting /etc and /var.
Those entries are used by dracut to mount the overlay file systems
during the early boot phase.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Wed Feb 06 2019 iforster@suse.com
  - Update description to reflect new behaviour
  - Fix creation of overlay directories
* Wed Feb 06 2019 kukuk@suse.de
  - Fix file list
* Wed Feb 06 2019 fvogt@suse.com
  - Update to version 1.0+git20190206.586e9f1:
    * Remove migration code, only handle the initial setup here
    * Drop use of fstab.sys
    * Use a dracut config file instead of a module
* Wed Jun 06 2018 kukuk@suse.de
  - Update to version 1.0+git20180606.046b099:
    * Fix missing shebang
    * Make scripts executeable
    * Enable create-dirs-from-rpmdb.service by default
* Wed Apr 18 2018 fvogt@suse.com
  - Update to version 1.0+git20180418.4373cf9:
    * Fix 99volatile-overlay
    * proper shell escaping in mount-overlay.sh (#3)
* Mon Apr 16 2018 fvogt@suse.com
  - Update to version 1.0+git20180416.825ad6c:
    * Add new 99volatile-overlay dracut module
  - BuildRequire/Require dracut for proper directory ownership
  - Fix posttrans if zypper is not installed
* Wed Mar 21 2018 kukuk@suse.de
  - Disable multiversion feature of libzypp at install time
  - Document, that this package should never be installed in a
    running system, only during installation
* Wed Mar 21 2018 kukuk@suse.de
  - Update to version 1.0+git20180321.a5b34ab:
    * Disable purge-kernels.service, does not work with read-only
      root filesystem
    * Enable man-db-create.service, man cannot create cache in %post
    * Fix OBS URL
* Fri Mar 02 2018 rbrown@suse.com
  - Add Requires(post) for coreutils & grep to ensure post script has
    what it needs (boo#1083526)
* Tue Feb 27 2018 kukuk@suse.de
  - Update to version 1.0+git20180227.44d5e8a:
    * Initial import of read-only-root-fs stuff from caasp-tools
* Tue Feb 27 2018 kukuk@suse.de
  - Initial version

Files

/usr/lib/dracut/dracut.conf.d/10-read-only-root-fs.conf
/usr/lib/systemd/system-preset/50-read-only-root-fs.preset
/usr/sbin/setup-fstab-for-overlayfs
/usr/share/licenses/read-only-root-fs
/usr/share/licenses/read-only-root-fs/COPYING
/var/lib/overlay
/var/lib/overlay/work-etc


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon May 9 12:54:53 2022