Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

ocaml-4.10.0-4.mga8 RPM for aarch64

From Mageia 8 for aarch64 / media / core / release

Name: ocaml Distribution: Mageia
Version: 4.10.0 Vendor: Mageia.Org
Release: 4.mga8 Build date: Mon Jan 11 21:17:10 2021
Group: Development/OCaml Build host: localhost
Size: 0 Source RPM: ocaml-4.10.0-4.mga8.src.rpm
Packager: pterjan <pterjan>
Url: http://caml.inria.fr
Summary: The OCaml compiler and programming environment
OCaml is a high-level, strongly-typed, functional and object-oriented
programming language from the ML family of languages.

Provides

Requires

License

QPL with exceptions and LGPLv2 with exceptions

Changelog

* Mon Jan 11 2021 pterjan <pterjan> 4.10.0-4.mga8
  + Revision: 1671186
  - Add BuildRequires binutils-devel
* Fri Aug 21 2020 umeabot <umeabot> 4.10.0-3.mga8
  + Revision: 1617556
  - Rebuild for new ocaml deps generator
* Thu Apr 16 2020 pterjan <pterjan> 4.10.0-2.mga8
  + Revision: 1567884
  - Drop RISC-V support, this causes a segfault on i586
  + tv <tv>
  - update the building conditions
  - Update all OCaml dependencies for RPM 4.16
  - Fix RISC-V backend
  - remove useless workaround
* Thu Feb 27 2020 pterjan <pterjan> 4.10.0-1.mga8
  + Revision: 1551103
  - Update to 4.10.0 final
* Wed Feb 19 2020 umeabot <umeabot> 4.10.0-0.beta1.3.mga8
  + Revision: 1543227
  - Mageia 8 Mass Rebuild
  + tv <tv>
  - provides ocaml-ocamldoc
* Sun Jan 19 2020 tv <tv> 4.10.0-0.beta1.2.mga8
  + Revision: 1481491
  - drop deps on ocaml-x11 which was dropped
* Sun Jan 19 2020 tv <tv> 4.10.0-0.beta1.1.mga8
  + Revision: 1481475
  - non bootstrap build now that we've deps with proper version
* Sun Jan 19 2020 tv <tv> 4.10.0-0.beta1.mga8
  + Revision: 1481469
  - bootstrap
  - make sure to use just built ocaml to generate deps!
  - OCaml 4.10.0+beta1
* Sun Jan 19 2020 tv <tv> 4.09.0-1.mga8
  + Revision: 1481452
  - OCaml 4.09.0 final.
  - Use autosetup, remove old setup line.
  - Remove ocamloptp binaries.
  - Rename target_camlheader[di] -> camlheader[di] files.
  - Remove vmthreads - old threading library which is no longer built.
  - Remove x11 subpackage which is obsolete.
  - Further fixes to CFLAGS and annobin.
  - Emacs subpackage has been dropped (from upstream)
  - Better fix for armv7
  - Disable underlinking
  - we don't support alpha...

Files

No Filelist in the Package !

Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Dec 6 04:23:49 2022