Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

nvidia-current-cuda-opencl-460.32.03-1.mga7.nonfree RPM for x86_64

From Mageia 7 for x86_64 / media / nonfree / updates

Name: nvidia-current-cuda-opencl Distribution: Mageia
Version: 460.32.03 Vendor: Mageia.Org
Release: 1.mga7.nonfree Build date: Sun Jan 10 23:58:34 2021
Group: System/Kernel and hardware Build host: localhost
Size: 216140366 Source RPM: nvidia-current-460.32.03-1.mga7.nonfree.src.rpm
Packager: ghibo <ghibo>
Url: https://www.nvidia.com/object/unix.html
Summary: CUDA and OpenCL libraries for NVIDIA proprietary driver
Cuda and OpenCL libraries for NVIDIA proprietary driver. This package is not
required for normal use, it provides libraries to use NVIDIA cards for High
Performance Computing (HPC).

Provides

Requires

License

Freeware

Changelog

* Sun Jan 10 2021 ghibo <ghibo> 460.32.03-1.mga7
  + Revision: 1671013
  - Update to release 460.32.03.
  - Drop patch5, merged upstream.
  - Update to release 455.45.0.1.
  - Fill in the branch 450
  - Add temporary workaround for bug #27029.
  - Build modules with IGNORE_CC_MISMATCH to avoid building fails when a compiler is updated past kernel.
  - Update to release 450.57
  - Don't fix cards group name, revert to previous 635 to keep in sync with previous choice (for ldetect-lst).
  - Drop ftp flag as alternative sources (no longer works).
  - Update to release 440.100.
  - Drop patch5 and patch6 (merged upstream).
  - Fix minimal cardname to GT 630 instead of GT 635 (according to https://www.nvidia.com/Download/driverResults.aspx/160175/en-us).
  - temporary disable glvnd work to let driver works as before.
  - rename nvidia-settings-kernel-5.7.patch (as not related to nvidia-settings).
  - introduce conditional flag to swap to and from nvidia-current as package name.
  - add conditional flag to build libglvnd internally thus overlapping the nvidia ones.
  - add some entry to the parser classifier.
  - add libGLX to requires exceptions.
  - Upgrade to release 367.44.
  - Add nvidia-drm missed module (credit goes to proyvind, thanks).
  - Removed Patch4 and Patch5, merged upstream (sort of).
  + neoclust <neoclust>
  - Add P6 to add kernel 5.7 support
  + cheeseeboi <cheeseeboi>
  - Modified file paths to fit standards better
  - Removed possible conflicts with libglvnd, mesa, xorg, (etc)
  - Fixed some dependencies (note that nvidia-current-devel needs more work, see comment on line 203)
  - Fixed some macros and added some more files, the package should BUILD now. More testing with libglvnd needs to be done to allow for installation
  - Updated package to 440.82
  - Fixed some old makefile macros
  - Package now requires libglvnd
  + tmb <tmb>
  - rebuild with gcc 10.1
  - fix build with kernel 5.6
  - rebuild with gcc 9.3.0
  - fix build with 5.5 series kernels (Arch)
  - fix mis-detection of NV_SET_MEMORY_ARRAY_UC_PRESENT in 5.4 series kernels (mga#25890)
  - rollback to R430 branch for non-glvnd support, and update to 430.64
  - update to 440.31
  - update to 430.50
  - rebuild with gcc 9.2
  - update to 430.40
  - update to 430.34
  - more headless cuda fixes
  - update ldetect-lst deps
  - update to 430.26
  - fix post scripts in cuda-opencl and utils package
  - more cuda fixes
  - move nvidia-smi and nvidia-persistenced to separate nvidia-current-utils package for headless cuda
  - move cuda libs and tools to correct package
  - drop ancient nvidia97xx alternatives stuff
  - allow devel and doc stuff to be installed without x11-driver-video-nvidia-current
  - update to 430.14 (new long lived branch)
  - recreate initrd of running kernel so the new module gets added in the initrd
  - update to 418.74
  - fix build with kernel 5.1
  - update to 418.56
  - drop obsolete provides/obsoletes/conflicts
  - update requires on ldetect-lst for latest pci ids
  - update to 418.43 from new R418 longterm branch
  - x11-driver: provide x11-driver-video-nvidia-bumblebee
  - update to 410.93
  - add libglx compat symlinks (mga#23901)
  - update to 410.78
  - update to 410.73
  - update to 410.66
  - require ldetect-lst >= 0.5.1-1 for fixed pci ids
  - Fix ldetect Card++ name for backports
  - this driver is for GeForce 635 and later (64bit only)
  - update filelists
  - nvidia-current is now x86_64 only
  - update to 410.57 for RTX 20xx (Turing) support
  - update to 390.87
  - rebuild with gcc 8.2
  - set up Vulkan ICD
  - update to 390.77
  - update to 390.67
  - rebuild for xorg 1.20
  - fix videodrv_abi to match xorg 1.20
  - update to 390.59 (xorg 1.20 support)
  - update to 390.48
  - update filelist
  - update to 390.42
  - update to 390.25 from new R390 long lived branch
  - update to 384.111
  - fix build with 4.14.9-rc1 (noted by Juan Magallon on dev ml)
  - update to 384.98
  - update nvidia-modprobe/persistenced/settings/xconfig helper packages to final revisions
  - update to 384.90
  - rebuild with new gcc/binutils
  - update to 384.69
  - update to 384.59 from new R384 long lived branch
  - update to 375.82
  - really upload new nvidia-modprobe
  - update nvidia-settings and nvidia-modprobe tarballs to final versions
  - update to 375.66
  - disable broken phys_to_dma() check on i586 (mga#20192)
  - fix dkms post script
  - classic install: do add the driver to dkms list or it wont be built on boot
  - do trigger dkms build on dkms package update (now where is that brown paper bag...)
  - dont trigger dkms build during classical install
  - update to 375.39
  - update to 375.26
  - remove duplicated lines in .manifest only needed on x86_64
  - remove duplicated lines in .manifest
  - update filelists
  - update to 375.20 (official xorg 1.19 support)
  - arrange module order in dkms.conf so it builds properly on 32bit (mga#19654)
  - update to 367.57
    * drop obsoleted buildfixes
  - doh... use correct patch for kernel 4.8 support
  - fix build with 4.8 series kernels
  - rebuild for xorg-server 1.18.4
  - update to 367.35
  - fix build with kernel 4.7 series
  - hook into dkms parallel build support
  - update to 367.27 (new Long Lived branch)
  - update to 361.45.11
  - obsolete prebuilt kmods as they violate GPL
  - ad missing 4.6 fixes for get_user_pages() changes
  - submit to /release
  - split out uvm fix from P10 as its 64bit only (P11)
  - update to 361.42
  - fix build with kernel 4.6 (P10)
  - handle new GLVND_* & GLX_CLIENT_* .manifest targets
  - use 'old' GLX drivers by default
  - install 'new' GLVND drivers
  - rework handling of subdirs in KERNEL_MODULE_SRC .manifest target
  - update dkms.conf for new module build layout
  - update filelists
  - update to 352.79
  - nvidia-current-devel: run ldconfig on post due to a non-standard library directory (mga#14462)
  - rebuild with gcc 5.3 final
  - fix filelists
  - update to 352.63 (supports xorg 1.18)
  - update to 352.41 (CVE-2015-5950)
  - rebuild for new gcc
  - rebuild with gcc 5.2.1
  - update to 352.30
  - update to 352.21 (new long lived branch)
  - 346.72 (maintenance/bugfix release)
  - update to 346.59 -longterm
  - update to 346.47 (maintenance release)
  - fix drm trace in logs (dropped by mistake in 346.35 update)
  - fix broken dkms.conf
  - uvm module is available only on x86_64
  - handle OPENCL_* and XORG_OUTPUTCLASS_CONFIG in manifest
  - build gtk+3 UI too
  - BR: vdpau-devel >= 0.9
  - update to 346.35 (new Long Lived branch)
  - really fix drm trace with kernel 3.18 (mga#14769, mga#14832)
  - fix drm trace with kernel 3.18 (mga#14769, mga#14832)
  - update to 340.65 (improved kernel and xorg support)
  - supports X.Org xserver ABI 19
  - update to 340.58
  - filter out 32bit requires on x86_64
  - update to 340.46 from long lived branch (bugfixes)
  - adapt to new kmod provides
  - fix up spec conversion mess
  - update to 340.32
  - update filelists
  - this now supports X.org xserver ABI 18 (xorg server 1.16)
  - update to 337.25
  - update to 331.79
  - rebuild with gcc 4.9
  - update to 331.67
  - update to 331.49
  - drop P4 (uvm buildfix, not needed anymore)
  - handle EXPLICIT_PATH target in .manifest
  - drop duplicated files in filelist
  - update fillists
  - update to 331.38
  - xserver 1.15 is now supported
  - rediff P4 (uvm buildfix)
  - rebuild for testing
  - fix install of uvm module too
  - restore old install path as its hardcoded in service_harddrake, making it break installs (#11693)
  - rebuild for new mesa
  - push to /release
  - properly escape the dkms_tree variable
  - use dkms_tree variable in KBUILD_EXTMOD
  - make KBUILD_EXTMOD path relative so it works on buildsystem
  - fix uvm build when CONFIG_UIDGID_STRICT_TYPE_CHECKS is set
  - add nvidia-uvm module to dkms build
  - push to /release
  - fix filelist
  - update to 331.20 (new longterm branch)
  - drop merged / obsolete P1, P4, P6, P7
  - dont build uvm module for now (broken build)
  - update filelists
  - use upstream fix for num_physpages change in kernel 3.11
  - Mageia 4 rebuild
  - fix build with kernel-3.12
  - update to 319.60
  - fix rel
  - handle new NVIFR_LIB (OpenGL-based Inband Frame Readback library)
  - update to 319.49 (official kernel-3.10 support)
  - rebuild with new gcc
  - force gcc 4.8.2 build
  - fix build with 3.11 series kernels (P6)
  - fix build with kernel 3.10 (P5, gentoo)
  - update to 319.32
  - push to nonfree/release
  - 310.44 (CVE-2013-0131)
  - update to 310.40 (bugfixes, more hw support)
  - cd
  - drop P5 (kernel 3.8 buildfix, merged)
  - update to 310.32
  - include uapi headers to fix build with kernel-3.8 (P5)
  - add ENCODEAPI_LIB* symbols, update filelists
  - update to 310.19
  - update to 304.60
  - update to 304.51
  - update to 304.43
  - replace nVidia provided dkms.conf with our own customized one
  - add provides kmod(nvidia-current) as upstream now has provides kmod(nvidis) (mga #7113)
  - update filelists
  - update to 304.37 (long lived branch)
  - drop merged patches (P0, P5)
  - update to 295.71 (CVE-2012-4225)
  - move libnvidia-ml.so.1 from nvidia-current-cuda-opencl to
    x11-driver-video-nvidia-current as it is needed by
    /usr/bin/nvidia-smi (reported on irc by Berxwedan)
  - update to 295.59
  - rebuild for nonfree/release
  - fix build with 3.4 series kernels (P5)
  - submit to release
  - update to 295.49 (performance regression fixes)
  - fix build with 3.3 series kernels (J.A. Magallon)
  + umeabot <umeabot>
  - Mageia 8 Mass Rebuild
  - Mageia 7 Mass Rebuild
  + ngompa <ngompa>
  - Remove unneeded %pretrans
  + luigiwalser <luigiwalser>
  - do not require specific version of update-alternatives
  + tv <tv>
  - rebuild for new xserver
  - rebuild for xserver 1.17
  - auto convert _exclude_files_from_autoreq
  - use %global for req/prov exclude
  - autoconvert to new prov/req excludes
  - s/uggests:/Recommends:/
  - submit to core/release
  - rebuild for new xserver RC
  - rebuild for new xserver
  - rebuild for new perl
  - submit to nonfree/release
  - rebuild with xserver-1.14
  - rebuild for new x11-server
  - rebuild for new xserver
  - bump release
  - bump X11 ABI require
  - rebuild for new X.org server
  + anssi <anssi>
  - fix libnvidia-gtk*.so* name not matching their SONAME, causing
    nvidia-settings to fail to load
  - remove extra unneeded __provides_exclude_from added in auto-conversion
  - add backward-compatibility definitions for dependency exclusions
  - alternativeszificate /usr/share/nvidia as there are now unversioned files
    in there
  - use the self-built versions of libnvidia-gtk*.so
  - adapt simple mode pcitable generation for new version and new ldetect-lst
  - update cards definition as support was dropped for some cards
  - fix nvidia-ifr symlink targets
  - handle arch for UTILITY_SYMLINK
  - fix requires filtering for NVIFR library
  - new long-lived maintenance version 319.17
  - update files
  - add missing alternatives
  - fix pcitable.d generation (when backporting)
  - move all alternativeszificated binaries to main driver package
    to avoid broken symlinks
  - update file lists (XvMC dropped as all cards it supported have been
    dropped)
  - handle optional subdir for NVCUVID_LIB and ENCODEAPI_LIB
  - update target card string
    o NOTE: this driver now only supports GeForce 8xxx based cards and above
  - workaround linking issue of libnvidia-encode.so
  - new version 290.40
    o fixes CVE-2012-0946 (arbitrary system memory access by users)
  - new version 295.33
  - drop now unneeded kernel 3.3 support patch
  - new version 295.20
  - depend on the correct range of the newly provided xserver-abi(videodrv)
    in x11-server-common
  - add support for new file types of 295.17 in %install
  - drop old unneeded mdv category from .desktop file (#2449)
  - new stable version 290.10
  - run ldconfig explicitely in cuda-opencl package
  - new prerelease
    o adds X.org server 1.11 support
  - remove dependency on X11 driver package from dkms-nvidia-current (it is
    not needed for CUDA/OpenCL usage) (Mandriva #63207)
  - replace dependency on X11 driver package with a dependency on DKMS
    module package in nvidia-current-cuda-opencl (Mandriva #63207)
  - fix display-driver.conf alternative name
  - replace "alias" entry with "install" entry in modprobe.conf to follow
    upstream module-init-tools behavior
  - disable conflicts on videodrv ABI, as it may cause X server to be
    uninstalled instead
  - remove now unneeded modprobe.preload.d entry
  + ahmad <ahmad>
  - Update to 280.13
  - Make it possible to download the sources from http://us.download.nvidia.com
    when ftp://download.nvidia.com doesn't have the latest driver.
  - Update to 280.11
  - Update to 280.04
  - Update to current official release 275.09.07
  - Update to 275.09.04
  - Rediff the kernel-rt patch
  - update to 270.41.19
  - Update to 270.41.06
  - update to 270.41.03, new official release
  - restore the xserver driver ABI conflicts wrongly removed during removing
    old mdv scriptles/macros
  - rename modprobe config file to display-driver.conf (Anssi)
  - update to 270.30
  - bump videodrv_abi to 10
  - resubmit so that nvidia-current-cuda-opencl becomes available
  - update to 270.26
  - update the file list
  - rename dyntwinview patch and modify it to say Mageia Control Center
  - drop old/unneeded scriptlets
  - rename .desktop file to mandriva-*
  - imported package nvidia-current

Files

/etc/OpenCL
/etc/OpenCL/vendors
/etc/OpenCL/vendors/nvidia.icd
/etc/ld.so.conf.d/nvidia-current-cuda.conf
/etc/nvidia-current/nvidia.icd
/usr/bin/nvidia-cuda-mps-control
/usr/bin/nvidia-cuda-mps-server
/usr/lib/.build-id
/usr/lib/.build-id/02
/usr/lib/.build-id/02/1eb0bd930570323cb94ca2f47464ccc3a49525
/usr/lib/.build-id/16
/usr/lib/.build-id/16/cdcc01901a9ae3f2219750ece5487e8971740a
/usr/lib/.build-id/1d
/usr/lib/.build-id/1d/4651d684717457777ff5ace7cdb46fbd63830c
/usr/lib/.build-id/25
/usr/lib/.build-id/25/1beac2ccc36aa7ad654bf4e60830dbac6c19e6
/usr/lib/.build-id/2f/d4860875af4895d49bb0fd028f76b163f94f22
/usr/lib/.build-id/37
/usr/lib/.build-id/37/9b03a2c33bb763f39ca3afd5dc7f85b454710a
/usr/lib/.build-id/53
/usr/lib/.build-id/53/228645380955ed6638899908bbc3ddcf492a49
/usr/lib/.build-id/6c
/usr/lib/.build-id/6c/14869bb8a4926da8368507bc9da74093ce5049
/usr/lib/.build-id/76/f6131fcbec6e7249b0eb49f89bb1de3c816f71
/usr/lib/.build-id/9b
/usr/lib/.build-id/9b/2e4820ba64fa0f14d330360576d2f0707d5a51
/usr/lib/.build-id/a0
/usr/lib/.build-id/a0/7e55f0ed52d4336f343d9045da3138264d6ad3
/usr/lib/.build-id/a9
/usr/lib/.build-id/a9/ca47f78e5d4acc7440ba4784dd1b6903a81fa8
/usr/lib/.build-id/bc
/usr/lib/.build-id/bc/3535f184ee5008ba6f39a67a67abfd7c39bb7b
/usr/lib/.build-id/c3
/usr/lib/.build-id/c3/b793fc11d200a9905fbfc1e671312946a1b32e
/usr/lib/.build-id/e9
/usr/lib/.build-id/e9/04498014c11de2384348898d17a649b1d40419
/usr/lib/.build-id/f6
/usr/lib/.build-id/f6/e3929b61637b496bc6d1fac38db6c96270d299
/usr/lib/nvidia-current/libOpenCL.so.1
/usr/lib/nvidia-current/libOpenCL.so.1.0
/usr/lib/nvidia-current/libOpenCL.so.1.0.0
/usr/lib/nvidia-current/libcuda.so
/usr/lib/nvidia-current/libcuda.so.1
/usr/lib/nvidia-current/libcuda.so.460.32.03
/usr/lib/nvidia-current/libnvcuvid.so.1
/usr/lib/nvidia-current/libnvcuvid.so.460.32.03
/usr/lib/nvidia-current/libnvidia-compiler.so.460.32.03
/usr/lib/nvidia-current/libnvidia-encode.so.1
/usr/lib/nvidia-current/libnvidia-encode.so.460.32.03
/usr/lib/nvidia-current/libnvidia-ml.so.1
/usr/lib/nvidia-current/libnvidia-ml.so.460.32.03
/usr/lib/nvidia-current/libnvidia-opencl.so.1
/usr/lib/nvidia-current/libnvidia-opencl.so.460.32.03
/usr/lib/nvidia-current/libnvidia-opticalflow.so.1
/usr/lib/nvidia-current/libnvidia-opticalflow.so.460.32.03
/usr/lib/nvidia-current/libnvidia-ptxjitcompiler.so
/usr/lib/nvidia-current/libnvidia-ptxjitcompiler.so.1
/usr/lib/nvidia-current/libnvidia-ptxjitcompiler.so.460.32.03
/usr/lib64/nvidia-current/bin/nvidia-cuda-mps-control
/usr/lib64/nvidia-current/bin/nvidia-cuda-mps-server
/usr/lib64/nvidia-current/libOpenCL.so.1
/usr/lib64/nvidia-current/libOpenCL.so.1.0
/usr/lib64/nvidia-current/libOpenCL.so.1.0.0
/usr/lib64/nvidia-current/libcuda.so
/usr/lib64/nvidia-current/libcuda.so.1
/usr/lib64/nvidia-current/libcuda.so.460.32.03
/usr/lib64/nvidia-current/libnvcuvid.so.1
/usr/lib64/nvidia-current/libnvcuvid.so.460.32.03
/usr/lib64/nvidia-current/libnvidia-compiler.so.460.32.03
/usr/lib64/nvidia-current/libnvidia-encode.so.1
/usr/lib64/nvidia-current/libnvidia-encode.so.460.32.03
/usr/lib64/nvidia-current/libnvidia-ml.so.1
/usr/lib64/nvidia-current/libnvidia-ml.so.460.32.03
/usr/lib64/nvidia-current/libnvidia-opencl.so.1
/usr/lib64/nvidia-current/libnvidia-opencl.so.460.32.03
/usr/lib64/nvidia-current/libnvidia-opticalflow.so.1
/usr/lib64/nvidia-current/libnvidia-opticalflow.so.460.32.03
/usr/lib64/nvidia-current/libnvidia-ptxjitcompiler.so
/usr/lib64/nvidia-current/libnvidia-ptxjitcompiler.so.1
/usr/lib64/nvidia-current/libnvidia-ptxjitcompiler.so.460.32.03
/usr/share/man/man1/alt-nvidia-current-cuda-mps-control.1.xz
/usr/share/man/man1/nvidia-cuda-mps-control.1.xz


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon May 9 12:10:11 2022