Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

pki-servlet-4.0-api-9.0.30-1.module_el8.4.0+595+e59c9af2 RPM for noarch

From CentOS 8-stream AppStream for aarch64 / Packages

Name: pki-servlet-4.0-api Distribution: CentOS
Version: 9.0.30 Vendor: CentOS
Release: 1.module_el8.4.0+595+e59c9af2 Build date: Sat Dec 19 23:29:31 2020
Group: Development/Libraries Build host: x86-01.mbox.centos.org
Size: 340081 Source RPM: pki-servlet-engine-9.0.30-1.module_el8.4.0+595+e59c9af2.src.rpm
Packager: CentOS Buildsys <bugs@centos.org>
Url: http://tomcat.apache.org/
Summary: Apache Tomcat Java Servlet v4.0 API Implementation Classes
Apache Tomcat Servlet API Implementation Classes.

Provides

Requires

License

ASL 2.0

Changelog

* Thu Apr 23 2020 Coty Sutherland <csutherl@redhat.com> - 1:9.0.30-1
  - Resolves: rhbz#1721684 Rebase pki-servlet-engine to 9.0.30
  - Update to JWS 5.3.0 distribution
  - Remove new dependencies that PKI doesn't need (and are not provided by RHEL 8)
* Fri May 31 2019 Endi S. Dewata <edewata@redhat.com> - 1:9.0.7-16
  - Obsoleted pki-servlet-container
* Tue Apr 23 2019 Endi S. Dewata <edewata@redhat.com> - 1:9.0.7-15
  - Rename pki-servlet-container into pki-servlet-engine
* Mon Mar 04 2019 Coty Sutherland <csutherl@redhat.com> - 1:9.0.7-14
  - Update to JWS 5.0.2 distribution
  - Resolves: rhbz#1658846 CVE-2018-8034 pki-servlet-container: tomcat: host name verification missing in WebSocket client
  - Resolves: rhbz#1579614 CVE-2018-8014 pki-servlet-container: tomcat: Insecure defaults in CORS filter enable 'supportsCredentials' for all origins
  - Resolves: rhbz#1619232 - CVE-2018-8037 pki-servlet-container: tomcat: Due to a mishandling of close in NIO/NIO2 connectors user sessions can get mixed up
  - Resolves: rhbz#1641874 - CVE-2018-11784 pki-servlet-container: tomcat: Open redirect in default servlet
* Fri Aug 03 2018 Fraser Tweedale <ftweedal@redhat.com> - 1:9.0.7-13
  - Reinstate Maven artifacts and fix maven-metadata JAR path
* Fri Jul 20 2018 Jean-Frederic Clere <jclere@redhat.com> - 1:9.0.7-12
  - Add missing BuildRequires: systemd-units
* Fri Jun 22 2018 Coty Sutherland <csutherl@redhat.com> - 1:9.0.7-11
  - Resolves: rhbz#1594139 Cleanup Provides and Requires
* Thu Jun 07 2018 Coty Sutherland <csutherl@redhat.com> - 1:9.0.7-10
  - Create packages for FreeIPA that wrap the JWS distribution of Tomcat

Files

/usr/share/doc/pki-servlet-4.0-api
/usr/share/doc/pki-servlet-4.0-api/LICENSE
/usr/share/java/tomcat-servlet-4.0-api.jar
/usr/share/maven-metadata/tomcat-servlet-api.xml
/usr/share/maven-poms/JPP-tomcat-servlet-api.pom


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Aug 9 14:43:49 2022