Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

NetworkManager-vpnc-1.2.6-3.1 RPM for x86_64

From OpenSuSE Tumbleweed for x86_64

Name: NetworkManager-vpnc Distribution: openSUSE Tumbleweed
Version: 1.2.6 Vendor: openSUSE
Release: 3.1 Build date: Sat May 2 23:28:48 2020
Group: Productivity/Networking/System Build host: goat05
Size: 118461 Source RPM: NetworkManager-vpnc-1.2.6-3.1.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.gnome.org/projects/NetworkManager
Summary: NetworkManager VPN Support for vpnc
NetworkManager-vpnc provides VPN support to NetworkManager for vpnc.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Fri May 01 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - Set the path for the VPN service name file correctly to
    %_vpnservicedir (provided by macros.NetworkManager).
* Sat Jan 25 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - No longer recommend -lang: supplements are in use
* Fri Jul 20 2018 bjorn.lie@gmail.com
  - Updatet to version 1.2.6:
    + Fix for a local authenticated privileged escalation bug
      (CVE-2018-10900). All users are advised to upgrade.
    + The CA file is now hidden from the configuration dialog if
      hybrid auth is disabled.
    + Updated translations.
* Sat Apr 14 2018 bjorn.lie@gmail.com
  - Following changes in NetworkManager: pass without-libnm-glib to
    configure, no longer build deprecated libnm-glib support.
  - Following the above changes: Drop no longer needed
    pkgconfig(NetworkManager), pkgconfig(libnm-glib),
    pkgconfig(libnm-glib-vpn), pkgconfig(libnm-gtk) and
    pkgconfig(libnm-util) BuildRequires. Add explicit
    pkgconfig(libnm) BuildRequires.
  - Package missing COPYING file.
  - Stop handling icon_theme_cache_post(un) in post(un).
  - Drop unneeded and unused update-desktop-files BuildRequires.
  - Drop unneeded NetworkManager-gnome Requires from gnome
    sub-package, it is no longer of use for us.
* Tue Mar 20 2018 dimstar@opensuse.org
  - Unconditionally enable translation-update-upstream: on
    Tumbleweed, this results in a NOP and for Leap in SLE paid
    translations being used (boo#1086036).
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner
* Mon Jan 23 2017 dimstar@opensuse.org
  - Enable build for s390x: the entire dependency chain is in place.
* Mon Oct 03 2016 zaitor@opensuse.org
  - Update to version 1.2.4:
    + Prefer building against stable libsecret API.
    + Split libnm-vpn-plugin-vpnc.so into a GTK-free core plugin
      usable by nmcli and a UI plugin for nm-applet and gnome
      components.
    + Support NM_VPN_LOG_LEVEL environment variable to control debug
      logging from NetworkManager.
    + Support multiple concurrent VPNC connections.
    + Various cleanups.
    + Updated translations.
  - Conditionally apply translations-update-upstream BuildRequires
    and macro for non-openSUSE only.
  - Replace pkgconfig(libsecret-unstable) for pkgconfig(libsecret-1)
    BuildRequires following upstreams changes.
  - Drop obsolete clean section.
* Sat May 14 2016 zaitor@opensuse.org
  - Update to version 1.2.2:
    + Use a proper name for the AppStream metadata.
    + Updated translations.
  - Stop passing --disable-more-warnings to configure, no longer
    needed.
* Tue May 10 2016 dimstar@opensuse.org
  - Update to version 1.2.0:
    + build: don't include the full path to a plugin by default.
    + Updated translations.

Files

/etc/dbus-1/system.d/nm-vpnc-service.conf
/usr/lib/NetworkManager/VPN/nm-vpnc-service.name
/usr/lib/nm-vpnc-service
/usr/lib/nm-vpnc-service-vpnc-helper
/usr/lib64/NetworkManager/libnm-vpn-plugin-vpnc.so
/usr/share/licenses/NetworkManager-vpnc
/usr/share/licenses/NetworkManager-vpnc/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat May 30 23:39:49 2020