Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

chrome-gnome-shell-10.1-2.4 RPM for i586

From OpenSuSE Tumbleweed for i586

Name: chrome-gnome-shell Distribution: openSUSE Tumbleweed
Version: 10.1 Vendor: openSUSE
Release: 2.4 Build date: Wed Jun 12 19:37:08 2019
Group: Productivity/Networking/Web/Browsers Build host: lamb57
Size: 76336 Source RPM: chrome-gnome-shell-10.1-2.4.src.rpm
Packager: https://bugs.opensuse.org
Url: https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome
Summary: GNOME Shell integration for Chrome Extension compatible browsers
Browser extension for Google Chrome/Chromium, Firefox, Vivaldi, Opera (and other
Browser Extension, Chrome Extension or WebExtensions capable browsers) and native
host messaging connector that provides integration with GNOME Shell and the
corresponding extensions repository https://extensions.gnome.org.

Provides

Requires

License

GPL-3.0-or-later

Changelog

* Mon Jun 04 2018 dimstar@opensuse.org
  - BuildRequires p7zip-full, now that 7z was split out.
* Wed Mar 21 2018 bjorn.lie@gmail.com
  - Update to version 10.1:
    + Firefox: multiple fixes of GNOME Shell extensions
      synchronization.
    + Firefox 56 is minimum supported version now. ESR users should
      use browser extension version 10.0.1.
    + Known issues:
    - In Firefox with enabled synchronization of GNOME Shell
      extensions all Shell extensions may be removed after screen
      got locked because of missed support of "locked" idle state
      in WebExtensions API implementation.
    - Chrome extension may be auto uninstalled after upgrade to
      connector version 10. It can be restored using inline
      installation link at https://extensions.gnome.org or using
      Chrome Store.
    - Firefox can consume a lot of CPU and sometime crash on quit
      because of Mozilla's bug bmo#1349874.
    + Updated translations.
  - Stop using source service, upstream now does regular releases.
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner
* Mon Feb 05 2018 bjorn.lie@gmail.com
  - Update to version 10:
    + FreeBSD is supported again.
    + Enabled GNOME Shell extensions synchronization in Firefox.
    + Added option to check updates of enabled only GNOME Shell
      extensions.
    + Added GNOME proxy support for update checks.
    + Update errors will not produce desktop notifications anymore.
      All errors now goes to browser console.
    + Chrome managed policies no longer got installed so browser
      extensions will not be force installed along with connector.
    + It's possible to use inline installation of browser extensions
      through https://extensions.gnome.org website now.
    + Added light icon for dark browser themes. Use options page to
      switch icon.
    + Various fixes for options page in Firefox.
    + Updated translations.
  - Drop chrome-gnome-shell-nb-translation.patch: Fixed upstream.
  - No longer rm chrome-gnome-shell.json, upstream stopped installing
    it.
* Fri Nov 24 2017 zaitor@opensuse.org
  - Add chrome-gnome-shell-nb-translation.patch: Add Norwegian
    Bokmål translation.
* Mon Nov 06 2017 dimstar@opensuse.org
  - Allow the plugin to be disabled by removing the force-enabled
    policy from upstream (boo#1061278).
* Thu Nov 02 2017 dimstar@opensuse.org
  - Port to python3:
    + BuildRequire python3-base: /usr/bin/python3 is not implicit
      available in the buildroot yet.
    + Replace python-requests Requires with python3-requests.
    + Pass -DPYTHON_EXECUTABLE to cmake, pointing to
      /usr/bin/python3.
  - Drop icon_theme_cache_post/postun scriptlets: no longer needed,
    since file triggers hancdle icon cache updates now.
  - Add gobject-introspection BuildRequires: allow rpm to find/add
    typelib() dependencies.
* Thu May 18 2017 zaitor@opensuse.org
  - Update to version 9:
    + connector:
    - Handle command line argument outside of GApplication.
    - Fix gsettings GNOME Shell schema lookup.
    - Fixed possible AttributeError.
    - Fixed Ctrl spelling.
    + compatibility:
    - Fixed external messaging for Firefox 54.
    - Updated to Firefox 52.
    + Removed redundant line forgotten in previous commit.
    + firefox:
    - Restrict maximum version to 53.
    - Show usefull error message in case native connector not
      installed.
    + api: show errror instead of warning in case initialization
      failure.
    + Improved error handling when GNOME Shell is not installed or
      not running.
    + options: allow html in error messages.
    + sync:
    - Avoid synchronization of disabled extensions during sleep
      state.
    - Increased idle queue timeout.
    + update-check: make python-requests dependency optional.
    + constants: drop old string.
    + doap: fix JavaScript spelling.
    + extension: open Shell extensions website on icon click.
    + i18n:
    - Regenerate template.
    - Explicitly distinguish "browser extension" and "Shell
      extension".
    - Fix error message.
    - Update list of supported locales.
    - Regenerate locales.
    + Updated translations.
* Sat Mar 04 2017 zaitor@opensuse.org
  - Update to version 8.2:
    + ubuntu:
    - Added control.in that is needed for gnome-pkg-tools.
    - Fixed python 3 detection.
    + notifications: Fixed inter-frame communication.
    + api:
    - Do not expose api if GNOME Shell is not running.
    - Do not expose api version on initialize failure.
    + update-check: Fixed in-frame communication.
    + i18n: Regenerate locales.
    + Updated translations.
* Sun Feb 12 2017 zaitor@opensuse.org
  - Update to version 8.1:
    + Added check to make sure that "enabled-extensions" GNOME Shell
      setting does not contains duplicated values (bgo#777650).
    + Fixed error that breaks update check if there was extension
      installed without "version" key in manifest.
    + Fixed error that prevents error message to be shown when update
      check is failed.
    + Fixed connector segfault on browser close.
    + Fixed possible error in synchronization process that may delete
      some extensions.
    + Updated translations.
  - Drop chrome-gnome-shell-commit-dca4a35.patch: Fixed upstream.
  - Use conditional to allow packaging for older versions of
    openSUSE.
* Sat Feb 04 2017 duncansreeves@gmail.com
  - Added chrome-gnome-shell-commit-dca4a35.patch: Fix connector: do
    not use get_dbus_connection after GApplication was released
    (gh#nE0sIghT/chrome-gnome-shell-mirror#27).
* Wed Jan 25 2017 dimstar@opensuse.org
  - Initial package, version 8.

Files

/etc/chromium
/etc/chromium/native-messaging-hosts
/etc/chromium/native-messaging-hosts/org.gnome.chrome_gnome_shell.json
/etc/opt/chrome
/etc/opt/chrome/native-messaging-hosts
/etc/opt/chrome/native-messaging-hosts/org.gnome.chrome_gnome_shell.json
/usr/bin/chrome-gnome-shell
/usr/lib/mozilla
/usr/lib/mozilla/native-messaging-hosts
/usr/lib/mozilla/native-messaging-hosts/org.gnome.chrome_gnome_shell.json
/usr/lib/python3.7/site-packages/chrome_gnome_shell-0.0.0-py3.7.egg-info
/usr/share/applications/org.gnome.ChromeGnomeShell.desktop
/usr/share/dbus-1
/usr/share/dbus-1/services
/usr/share/dbus-1/services/org.gnome.ChromeGnomeShell.service
/usr/share/doc/packages/chrome-gnome-shell
/usr/share/doc/packages/chrome-gnome-shell/NEWS
/usr/share/doc/packages/chrome-gnome-shell/README.md
/usr/share/icons/gnome
/usr/share/icons/gnome/128x128
/usr/share/icons/gnome/128x128/apps
/usr/share/icons/gnome/128x128/apps/org.gnome.ChromeGnomeShell.png
/usr/share/icons/gnome/16x16
/usr/share/icons/gnome/16x16/apps
/usr/share/icons/gnome/16x16/apps/org.gnome.ChromeGnomeShell.png
/usr/share/icons/gnome/48x48
/usr/share/icons/gnome/48x48/apps
/usr/share/icons/gnome/48x48/apps/org.gnome.ChromeGnomeShell.png
/usr/share/licenses/chrome-gnome-shell
/usr/share/licenses/chrome-gnome-shell/LICENSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Apr 9 00:22:56 2020