Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libavahi-core7-0.8-34.1 RPM for armv6hl

From OpenSuSE Ports Tumbleweed for armv6hl

Name: libavahi-core7 Distribution: openSUSE Tumbleweed
Version: 0.8 Vendor: openSUSE
Release: 34.1 Build date: Thu Apr 4 15:44:36 2024
Group: System/Libraries Build host: reproducible
Size: 206290 Source RPM: avahi-0.8-34.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://www.avahi.org/
Summary: D-Bus Service for Zeroconf and Bonjour
Avahi is an implementation of the DNS Service Discovery and Multicast
DNS specifications for Zeroconf Computing.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Thu Apr 04 2024 Dominique Leuenberger <dimstar@opensuse.org>
  - Tag hardening patches as PATCH-FEATURE-OPENSUSE
* Tue Mar 26 2024 Xiaoguang Wang <xiaoguang.wang@suse.com>
  - Add avahi-CVE-2023-38471.patch: Extract host name using
    avahi_unescape_label (bsc#1216594, CVE-2023-38471).
  - Add avahi-CVE-2023-38469.patch: Reject overly long TXT resource
    records (bsc#1216598, CVE-2023-38469).
* Tue Mar 12 2024 pgajdos@suse.com
  - remove dependency on /usr/bin/python3 using
    %python3_fix_shebang macro, [bsc#1212476]
* Thu Nov 30 2023 Alynx Zhou <alynx.zhou@suse.com>
  - Add avahi-CVE-2023-38472.patch: Fix reachable assertion in
    avahi_rdata_parse (bsc#1216853, CVE-2023-38472).
* Mon Nov 27 2023 Dominique Leuenberger <dimstar@opensuse.org>
  - Reformat avahi-gacdir.patch to apply as patch -p1.
  - Use %autopatch instead of deprecated %patchN format.
* Thu Nov 23 2023 Dominique Leuenberger <dimstar@opensuse.org>
  - avahi-autoipd: drop the post script part migrating the user
    owning files in /var/lib/avahi-autoipd: the code was aiding
    migrations from SLE<=11/openSUSE<=12.3, which are no longer in
    scope for upgrades nowadays.
* Wed Nov 22 2023 Dominique Leuenberger <dimstar@opensuse.org>
  - avahi-autoipd: guard %post chown with -h, to not follow symlinks
    (boo#1217398).
* Mon Nov 13 2023 Dominique Leuenberger <dimstar@opensuse.org>
  - avahi-autoipd: only migrate files owned by avahi user if said
    user exists: if the user does not exist (fresh installs), then
    there is no chance any file is owned by the user (boo#1216730).
* Wed Nov 01 2023 Alynx Zhou <alynx.zhou@suse.com>
  - Add avahi-CVE-2023-38470.patch: Ensure each label is at least one
    byte long (bsc#1215947, CVE-2023-38470).
* Thu Oct 26 2023 Xiaoguang Wang <xiaoguang.wang@suse.com>
  - Add avahi-CVE-2023-38473.patch: derive alternative host name from
    its unescaped version (bsc#1216419 CVE-2023-38473).
* Wed Sep 20 2023 Ludwig Nussel <lnussel@suse.com>
  - Don't require sudo. There is no indication it's actually used for
    anything.
* Tue Apr 11 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Use ldconfig_scriptlets macro.
* Tue Apr 11 2023 Michael Gorse <mgorse@suse.com>
  - Add avahi-CVE-2023-1981.patch: emit error if requested service
    is not found (boo#1210328 CVE-2023-1981).
* Mon Dec 19 2022 Dominique Leuenberger <dimstar@opensuse.org>
  - Drop %{_sysconfdir}/sysconfig/network/if-{up,down}.d scripts:
    they are not used, or supported, in a while already.
* Thu Dec 08 2022 Thorsten Kukuk <kukuk@suse.com>
  - Remove avahi-daemon-check-dns.sh, avahi-daemon-check-dns-suse.patch
    and avahi-daemon.if-up
    Doesn't work since about 9 years and will not be executed on a
    fresh default installation anymore
* Mon Dec 05 2022 Johannes Segitz <jsegitz@suse.com>
  - Added hardening to systemd service(s) (bsc#1181400). Added patch(es):
    * harden_avahi-daemon.service.patch
    * harden_avahi-dnsconfd.service.patch
* Sun Sep 04 2022 Andreas Stieger <andreas.stieger@gmx.de>
  - avahi-daemon-check-dns.sh: convert obsolete egrep call to grep -E
    (boo#1203092)
* Sat Jul 09 2022 Callum Farmer <gmbr3@opensuse.org>
  - Move the dbus-1 system.d file to /usr (bsc#1201345)
* Fri Apr 15 2022 Jan Engelhardt <jengelh@inai.de>
  - Stop requiring "avahi" from "libavahi-devel". The devel package
    ought to facilitate building programs with avahi, not run the
    whole deamon.
* Wed Feb 23 2022 Dirk Müller <dmueller@suse.com>
  - switch to use _multibuild
  - delete _avahi_spec-prepare.sh, pre_checkin.sh: obsolete
  - use https urls
* Thu Feb 17 2022 Dirk Müller <dmueller@suse.com>
  - remove avahi-mono* subspecfiles, they are no longer required
    by anything. this makes the spec file slightly more readable.
* Wed Feb 16 2022 Michael Gorse <mgorse@suse.com>
  - Replace avahi-0.6.31-systemd-order.patch with
    avahi-add-resolv-conf-to-inotify.patch: re-read configuration
    when resolv.conf changes, per discussion on the bug
    (boo#1194561).
* Fri Jan 21 2022 Callum Farmer <gmbr3@opensuse.org>
  - Change to systemd-sysusers
* Mon Jan 17 2022 Michael Gorse <mgorse@suse.com>
  - Reinstate avahi-0.6.31-systemd-order.patch (boo#1194561).
    This can probably go away if/when gh#lathiat/avahi#118 is fixed.
  - Drop avahi-0.6.32-suppress-resolv-conf-warning.patch: we should
    no longer need this given the above patch.
  - Add several patches from git:
    0001-man-fix-reference-to-avahi-autoipd.action-8-in-avahi.patch
    0005-avahi-dnsconfd.service-Drop-Also-avahi-daemon.socket.patch
    0006-man-add-missing-bshell.1-symlink.patch
    0007-Ship-avahi-discover-1-bssh-1-and-bvnc-1-also-for-GTK.patch
    0009-fix-bytestring-decoding-for-proper-display.patch 0010-avahi_dns_packet_consume_uint32-fix-potential-undefi.patch
  - Build manpages with xmltoman. Currently needed for bssh.
  - Minor spec file clean-up.
  - Require python-rpm-macros for all builds (boo#1194744 boo#1194745).
* Wed Jan 12 2022 Michael Gorse <mgorse@suse.com>
  - Move sftp-ssh and ssh services to the doc directory. They allow
    a host's up/down status to be easily discovered and should not
    be enabled by default (boo#1179060).
* Mon Oct 25 2021 Yifan Jiang <yfjiang@suse.com>
  - Change %python38_version_nodots to %suse_version which is
    compatible with Leap and SLE. See also:
    https://github.com/openSUSE/python-rpm-macros/issues/107
* Tue Oct 19 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Add rpmlintrc: Filter shlib-policy-name-error for libdns_sd
    (boo#1191750).
* Thu Sep 16 2021 Stanislav Brabec <sbrabec@suse.com>
  - Remove obsolete translation-update-upstream support
    (jsc#SLE-21105).
* Mon Aug 02 2021 Yifan Jiang <yfjiang@suse.com>
  - Obsolete the same version of mDNSResponder-lib and mDNSResponder
    in baselib.conf and spec.
* Fri Jul 02 2021 Michael Gorse <mgorse@suse.com>
  - Add avahi-CVE-2021-3502.patch: fix NULL pointer crashes
    (boo#1184846 CVE-2021-3502).
* Wed Jun 02 2021 Christophe Giboudeaux <christophe@krop.fr>
  - Fix libavahi-devel requirements. The devel package installs
    libavahi-libevent.so but didn't require the library it's
    pointing to.
* Tue Apr 20 2021 Michael Gorse <mgorse@suse.com>
  - Add avahi-CVE-2021-3468.patch: avoid infinite loop by handling
    HUP event in client_work (boo#1184521 CVE-2021-3468).
    https://github.com/lathiat/avahi/pull/330
* Tue Feb 16 2021 Michael Gorse <mgorse@suse.com>
  - Update avahi-daemon-check-dns.sh from Debian. Our previous
    version relied on ifconfig, route, and init.d.
  - Rebase avahi-daemon-check-dns-suse.patch, and drop privileges
    when invoking avahi-daemon-check-dns.sh (boo#1180827
    CVE-2021-26720).
  - Add sudo to requires: used to drop privileges.
* Wed Feb 10 2021 Jan Engelhardt <jengelh@inai.de>
  - Drop configure --libexecdir variable as it does not appear
    to be used by the source archive.
* Sun Jan 31 2021 Ben Greiner <code@bnavigator.de>
  - Build python bindings subpackages for all flavors
    * use the python-rpm-macros singlespec system: The macro
      %python_subpackages together with %python_subpackage_only
      creates the pythonXY-avahi bindings package for all python
      flavors on Tumbleweed (currently python36, python38)
    * Put the avahi-bookmarks command under updates-alternatives
      control to avoid package conflicts between flavors
    * outside of build_core, the build continues to use but not
      install everything in the primary python3 flavor.
    * For distros without multiple python3 flavors and/or older
      python-rpm-macros, the status quo is unchanged.

Files

/usr/lib/libavahi-core.so.7
/usr/lib/libavahi-core.so.7.1.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Jun 23 00:05:43 2024