Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libICE6-1.0.10-1.2 RPM for armv6hl

From OpenSuSE Ports Tumbleweed for armv6hl

Name: libICE6 Distribution: openSUSE Tumbleweed
Version: 1.0.10 Vendor: openSUSE
Release: 1.2 Build date: Wed Nov 27 07:41:24 2019
Group: System/Libraries Build host: armbuild25
Size: 84460 Source RPM: libICE-1.0.10-1.2.src.rpm
Packager: http://bugs.opensuse.org
Url: http://xorg.freedesktop.org/
Summary: X11 Inter-Client Exchange Library
The Inter-Client Exchange (ICE) protocol is intended to provide a
framework for building such protocols, allowing them to make use of
common negotiation mechanisms and to be multiplexed over a single
transport connection.

Provides

Requires

License

MIT

Changelog

* Mon Jul 15 2019 Stefan Dirsch <sndirsch@suse.com>
  - Update to version 1.0.10
    * This release provides a fix for CVE-2017-2626 for platforms
      which don't have arc4random_buf() in their default libraries
      but do have getentropy(), such as Linux platforms with a kernel
      version of 3.17 or newer and a glibc version of 2.25 or newer.
      (libICE 1.0.9 already ensured that arc4random_buf() is used on
      platforms that have it to provide sufficient entropy in ICE
      key generation, but left other platforms with the weaker methods.
      Linux platforms could also have linked against libbsd to use
      arc4random_buf() with libICE 1.0.9 for stronger keys.)
  - supersedes U_Use-getentropy-if-arc4random_buf-is-not-available.patch
* Sun Jun 11 2017 sndirsch@suse.com
  - U_Use-getentropy-if-arc4random_buf-is-not-available.patch
    * Use getentropy() if arc4random_buf() is not available
      (bnc#1025068, CVE-2017-2626)
  - tagged baselibs.conf as source in specfile
* Tue Jun 10 2014 sndirsch@suse.com
  - Update to version 1.0.9
    * This release fixes a number of issues found by static analysis and
      compiler warnings, and other minor code cleanups.  On systems with
      arc4random() in either libc or libbsd, it will now use that function
      for generating authentication cookies.
* Sun Feb 17 2013 jengelh@inai.de
  - Use more robust make install call
* Wed Apr 11 2012 vuntz@opensuse.org
  - Update to version 1.0.8:
    + Fix a number of issues found by static analysis and compiler
      warnings
    + Large set of cleanups and improvements to the DocBook format
      specs for the protocol and docs for the API.
* Sat Feb 11 2012 jengelh@medozas.de
  - Fix typo in baselibs.conf: should be libICE, not libFS
  - Provide package descriptions and update homepage URL
  - Add Obsoletes/Provides to baselibs.conf as well
* Fri Feb 10 2012 sndirsch@suse.com
  - back to previous provides/obsoletes for xorg-x11-libICE(-devel)
* Fri Feb 10 2012 sndirsch@suse.com
  - provide/obsolete xorg-x11-libICE(-devel), no matter which version
    number
* Thu Feb 09 2012 jengelh@medozas.de
  - Rename xorg-x11-libICE to libICE and utilize shlib policy
* Sun Nov 20 2011 coolo@suse.com
  - add libtool as buildrequire to avoid implicit dependency

Files

/usr/lib/libICE.so.6
/usr/lib/libICE.so.6.3.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Feb 12 00:09:11 2020