Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

pluma-1.20.0-lp150.1.1 RPM for armv7hl

From OpenSuSE Ports Leap 15.0 for armv7hl

Name: pluma Distribution: openSUSE Leap 15.0
Version: 1.20.0 Vendor: openSUSE
Release: lp150.1.1 Build date: Fri May 11 01:49:43 2018
Group: System/GUI/Other Build host: armbuild22
Size: 2874370 Source RPM: pluma-1.20.0-lp150.1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: https://mate-desktop.org/
Summary: Text editor for the MATE desktop
Pluma is a small, but powerful text editor designed specifically
for the MATE desktop. It has most standard text editor functions
and fully supports international text in Unicode. Advanced features
include syntax highlighting and automatic indentation of source
code, printing and editing of multiple documents in one window.

Pluma is extensible through a plugin system, which currently
includes support for spell checking, comparing files, viewing VCS
ChangeLogs, and adjusting indentation levels.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Fri Mar 09 2018 sor.alexei@meowr.ru
  - Update to version 1.20.0:
    * Require GTK+ 3.22 and GLib 2.50.
    * Double click to the right of the last open tab to open a new
      tab.
    * Support new location of the Gtk bookmarks file.
    * docs: We have encodings combobox, not option menu.
    * Remove references to PlumaStatus.
    * docs: Remove some references to nonexistent stuff.
    * filebrowser: Don't parse .hidden files - GIO does it since
      2.36.
    * Don't request to save documents with no changes.
    * Add a gsettings key to hide/show(default) tabs with the side
      pane.
    * Hide tabs if the sidebar is used.
    * Enable the ability to save the document if it was changed
      externally.
    * Disable the ability to save the document if it has no changes.
    * pluma-window: Have GtkRecentData on stack instead of allocating
      it.
    * An implementation of WidthOfScreen and HeightOfScreen.
    * Fix regexp replacement with backreferences (e.g. "\0").
    * Make sure pluma opens in the same window of the workspace.
    * Add a gsettings key: Show save confirmation if the files have
      changes.
    * Put "peas_engine_enable_loader" in the correct pl.
    * Make the list of recently used files work again.
    * Fix some deprecations.
    * Silent some build warnings.
    * Update translations.
  - Add pluma-gtk-3.20.patch: Restore GLib 2.48 and GTK+ 3.20 support.
* Tue Nov 14 2017 sor.alexei@meowr.ru
  - Update to version 1.18.3:
    * Fix pluma closing tabs unexpectedly with the [right+middle]
      click.
    * Fix wrong behaviour when holding down a [middle + right] click.
    * Fix pluma closing tabs unexpectedly with a middle click.
    * Update translations.
* Sun May 07 2017 sor.alexei@meowr.ru
  - Update to version 1.18.2:
    * Improve the close-confirm dialogue.
    * Update translations.
* Tue Apr 04 2017 sor.alexei@meowr.ru
  - Update to version 1.18.1:
    * Fix running under Wayland.
    * modelines: Fix random crash on closing one of several Pluma
      windows.
* Tue Mar 14 2017 sor.alexei@meowr.ru
  - Update to version 1.18.0:
    * NEWS: Use consistent, project wide, markdown-like formatting to
      make generating release announcements easier.
    * Move to GTK+3 (require GTK+ >= 3.14), drop the GTK+2 code and
    - -with-gtk build option.
    * Build: Actually build GObject introspection data.
    * Build: Remove the --enable-deprecations option - it actually
      disables all deprecated stuff.
    * Add the ability to search/replace text using regular expressions.
    * Drop Python bindings and the --enable-python build option.
    * Port the plugin system and both C and Python plugins to libpeas.
    * Snippets plugin: Stop exposing functions on Pluma message bus
      (doesn't work with GObject introspection).
    * Snippets plugin: Fix snippet parts staying after Ctrl-Z.
    * Fix an unexpected closing of the first tab with middle-click
      under the line numbers column.
    * Fix some runtime warnings in plugins.
    * Some more fixes and cleanups in code and docs.
    * Update translations.
* Tue Sep 20 2016 sor.alexei@meowr.ru
  - Update to version 1.16.0:
    * Use GtkAboutDialog instead of MateAboutDialog.
    * Drop dependency on libmate-desktop and --without-matedesktop
      build option.
    * GTK+3: Fix lots of deprecations.
    * Some more fixes and cleanups.
    * Update translations.
* Sun Aug 14 2016 sor.alexei@meowr.ru
  - Update to version 1.14.1:
    * Enable spell checking for new documents when Always Autocheck
      option is selected in Spell Check plugin.
    * Fix restoring cursor position when loading a document.
    * Install externaltools plugin only with Python support enabled.
    * Make distcheck use currently selected GTK+ version.
    * Update translations.
* Sat Apr 09 2016 sor.alexei@meowr.ru
  - Update to version 1.14.0:
    * Update translations.
    * Fix Changelog generation.
* Mon Feb 22 2016 sor.alexei@meowr.ru
  - Update to version 1.13.1:
    * Make switch-c tool in external tools work, fix security a issue.
    * GTK+3: Add style class pluma-window and pluma-print-preview.
* Fri Feb 19 2016 sor.alexei@meowr.ru
  - Update to version 1.13.0:
    * GTK+3: Fix several deprecations.
    * Implement middle-click tab closing.
    * Drop MateConf migration script.
    * Add a new Configure dialog for the Spell Check plugin.
* Thu Feb 18 2016 sor.alexei@meowr.ru
  - Update to 1.12.2:
    * Python console plugin: Fix missing icon in plugin list.
    * Fix possible use-after-free during incremental search.
    * GTK+3: Fix incremental search entry colour when text isn't
      found.
* Mon Nov 30 2015 sor.alexei@meowr.ru
  - Update to 1.12.1:
    * Add --without-matedesktop option to enable build without
      dependency on libmate-desktop.
* Thu Nov 05 2015 sor.alexei@meowr.ru
  - Update to 1.12.0.
* Wed Oct 14 2015 sor.alexei@meowr.ru
  - Update to 1.11.0:
    * Add --enable-tests option to enable/disable running tests
      during the build.
    * Add plugin to strip trailing spaces on saving.
    * Bring back active plugins listing in bugreport script.
    * Drop support for win32/osx and checkupdate plugin.
    * Retrieve strings directly from gschema (requires intltool
      0.50.1).
    * Capitalise Pluma in window titles and desktop file.
    * Some annotation fixes.
    * Some minor fixes and cleanups.
* Wed Jul 15 2015 sor.alexei@meowr.ru
  - Update to 1.10.2:
    * Window title: display full path to files on mounted drives.
    * Close confirmation dialog: make text unfocusable.
    * Quickopen plugin: fix filebrowser plugin support.
    * Time plugin: GTK+3 fix.
    * Multiple help fixes.
* Fri Jun 19 2015 sor.alexei@meowr.ru
  - Update to 1.10.1:
    * Fix gschema translations.
    * Gtk3 fixes.
    * Fix man page formatting.
    * Build system fixes.
* Thu May 07 2015 sor.alexei@meowr.ru
  - Update to 1.10.0 (changes since 1.9.1):
    * Fix GLib >= 2.43 compatibility.
    * Update translations.
  - Spec cleanup.
* Thu Jan 22 2015 p.drouand@gmail.com
  - Update to version 1.9.1 (unstable)
    * Bug fixes release
* Fri Nov 28 2014 p.drouand@gmail.com
  - Fix boo#906911,add mate-desktop-gsettings-schemas as a
    dependency
* Tue Nov 25 2014 hillwood@opensuse.org
  - Fix boo#906911,add mate-desktop-gsettings-schemas as a
    dependency
* Sun Nov 23 2014 p.drouand@gmail.com
  - Add pkgconfig(mate-desktop-2.0) build dependency; new build
    requirement
* Mon Jul 14 2014 p.drouand@gmail.com
  - Update to version 1.9.0 (unstable)
    + Use MateAboutDialog from libmate-desktop
  - Move from GTK2 to GTK3
    + Replace pkgconfig(gtk+-2.0) with pkgconfig(gtk+-3.0) requirement
    + Remove pkgconfig(pygtk-2.0) and pkgconfig(pygtksourceview-2.0)
      build require
    + Replace pkgconfig(pygobject-2.0) with pkgconfig(pygobject-3.0)
      requirement
    + Pass "with-gtk=3.0" in configure
* Thu May 01 2014 p.drouand@gmail.com
  - Update to version 1.8.1
    + fix go to line crash
    + translations updates
* Wed Mar 12 2014 p.drouand@gmail.com
  - Obsolete mate-text-editor-lang to avoid conflicts with this one
* Mon Mar 10 2014 p.drouand@gmail.com
  - Obsolete mate-text-editor-devel with pluma-devel; add a Obsoletes
    tag
* Wed Mar 05 2014 p.drouand@gmail.com
  - Update to version 1.8.0
    + no changes since version 1.7.90
* Thu Feb 20 2014 p.drouand@gmail.com
  - Update to version 1.7.90 (unstable)
    + add GTK3 support
    + use yelp-tools instead of mate-doc-utils
    + move user plugin dir from config_dir to data_dir. Plugins should have
      never been installed in the config dir as they are not part of the
      configuration. This means user will need to move the plugins directory
      from: $HOME/.config/pluma/ to $HOME/.local/share/pluma/.
* Fri Feb 14 2014 p.drouand@gmail.com
  - Update to version 1.7.2 (unstable)
    + update translation
    + bugs fixed
    + add tool to generate plugin templates
* Sun Jan 19 2014 p.drouand@gmail.com
  - Update to version 1.7.1 (unstable)
    + update translations
    + fix Sun GNOME Documentation Team references
    + fix search fields in GTK3
    + fix make dist
    + add the primary-toolbar style class to the primary toolbar
    + add section for running tests
    + update bug tracker url
    + gtk3: fix implicit declaration: gtk_source_language_get_id
    + use Caja GSettings schema optionally
      This makes Caja dependency optional.
    + bump required glib version number to 2.32
      It's required for the GSettingsSchemaSource API.
    + Add  to ACLOCAL_AMFLAGS for user added flags
    + plumadirs: Cleanup config dir usage
      Remove backwards compatibility for < glib 2.6 as we require glib
      2.22 at
      a minimum now.
      Use g_get_user_config_dir instead of custom logic.
      Use pluma_dirs_get_user_config_dir in pluma_dirs_get_user_accels_file.
    + pluma-dirs: Fix accel file location
    + move user plugins dir to data_dir
      Plugins don't belong in config_dir so we move them to data_dir.
      User will need to move the plugin dir to the new location, see NEWS.
    + update translations
* Fri Jan 17 2014 p.drouand@gmail.com
  - Initial release (version 1.7.0)

Files

/usr/bin/pluma
/usr/lib/pluma
/usr/lib/pluma/plugins
/usr/lib/pluma/plugins/changecase.plugin
/usr/lib/pluma/plugins/docinfo.plugin
/usr/lib/pluma/plugins/externaltools
/usr/lib/pluma/plugins/externaltools.plugin
/usr/lib/pluma/plugins/externaltools/__init__.py
/usr/lib/pluma/plugins/externaltools/__init__.pyc
/usr/lib/pluma/plugins/externaltools/__init__.pyo
/usr/lib/pluma/plugins/externaltools/capture.py
/usr/lib/pluma/plugins/externaltools/capture.pyc
/usr/lib/pluma/plugins/externaltools/capture.pyo
/usr/lib/pluma/plugins/externaltools/filelookup.py
/usr/lib/pluma/plugins/externaltools/filelookup.pyc
/usr/lib/pluma/plugins/externaltools/filelookup.pyo
/usr/lib/pluma/plugins/externaltools/functions.py
/usr/lib/pluma/plugins/externaltools/functions.pyc
/usr/lib/pluma/plugins/externaltools/functions.pyo
/usr/lib/pluma/plugins/externaltools/library.py
/usr/lib/pluma/plugins/externaltools/library.pyc
/usr/lib/pluma/plugins/externaltools/library.pyo
/usr/lib/pluma/plugins/externaltools/linkparsing.py
/usr/lib/pluma/plugins/externaltools/linkparsing.pyc
/usr/lib/pluma/plugins/externaltools/linkparsing.pyo
/usr/lib/pluma/plugins/externaltools/manager.py
/usr/lib/pluma/plugins/externaltools/manager.pyc
/usr/lib/pluma/plugins/externaltools/manager.pyo
/usr/lib/pluma/plugins/externaltools/outputpanel.py
/usr/lib/pluma/plugins/externaltools/outputpanel.pyc
/usr/lib/pluma/plugins/externaltools/outputpanel.pyo
/usr/lib/pluma/plugins/filebrowser.plugin
/usr/lib/pluma/plugins/libchangecase.so
/usr/lib/pluma/plugins/libdocinfo.so
/usr/lib/pluma/plugins/libfilebrowser.so
/usr/lib/pluma/plugins/libmodelines.so
/usr/lib/pluma/plugins/libsort.so
/usr/lib/pluma/plugins/libspell.so
/usr/lib/pluma/plugins/libtaglist.so
/usr/lib/pluma/plugins/libtime.so
/usr/lib/pluma/plugins/libtrailsave.so
/usr/lib/pluma/plugins/modelines.plugin
/usr/lib/pluma/plugins/pythonconsole
/usr/lib/pluma/plugins/pythonconsole.plugin
/usr/lib/pluma/plugins/pythonconsole/__init__.py
/usr/lib/pluma/plugins/pythonconsole/__init__.pyc
/usr/lib/pluma/plugins/pythonconsole/__init__.pyo
/usr/lib/pluma/plugins/pythonconsole/config.py
/usr/lib/pluma/plugins/pythonconsole/config.pyc
/usr/lib/pluma/plugins/pythonconsole/config.pyo
/usr/lib/pluma/plugins/pythonconsole/console.py
/usr/lib/pluma/plugins/pythonconsole/console.pyc
/usr/lib/pluma/plugins/pythonconsole/console.pyo
/usr/lib/pluma/plugins/quickopen
/usr/lib/pluma/plugins/quickopen.plugin
/usr/lib/pluma/plugins/quickopen/__init__.py
/usr/lib/pluma/plugins/quickopen/__init__.pyc
/usr/lib/pluma/plugins/quickopen/__init__.pyo
/usr/lib/pluma/plugins/quickopen/popup.py
/usr/lib/pluma/plugins/quickopen/popup.pyc
/usr/lib/pluma/plugins/quickopen/popup.pyo
/usr/lib/pluma/plugins/quickopen/virtualdirs.py
/usr/lib/pluma/plugins/quickopen/virtualdirs.pyc
/usr/lib/pluma/plugins/quickopen/virtualdirs.pyo
/usr/lib/pluma/plugins/quickopen/windowhelper.py
/usr/lib/pluma/plugins/quickopen/windowhelper.pyc
/usr/lib/pluma/plugins/quickopen/windowhelper.pyo
/usr/lib/pluma/plugins/snippets
/usr/lib/pluma/plugins/snippets.plugin
/usr/lib/pluma/plugins/snippets/Completion.py
/usr/lib/pluma/plugins/snippets/Completion.pyc
/usr/lib/pluma/plugins/snippets/Completion.pyo
/usr/lib/pluma/plugins/snippets/Document.py
/usr/lib/pluma/plugins/snippets/Document.pyc
/usr/lib/pluma/plugins/snippets/Document.pyo
/usr/lib/pluma/plugins/snippets/Exporter.py
/usr/lib/pluma/plugins/snippets/Exporter.pyc
/usr/lib/pluma/plugins/snippets/Exporter.pyo
/usr/lib/pluma/plugins/snippets/Helper.py
/usr/lib/pluma/plugins/snippets/Helper.pyc
/usr/lib/pluma/plugins/snippets/Helper.pyo
/usr/lib/pluma/plugins/snippets/Importer.py
/usr/lib/pluma/plugins/snippets/Importer.pyc
/usr/lib/pluma/plugins/snippets/Importer.pyo
/usr/lib/pluma/plugins/snippets/LanguageManager.py
/usr/lib/pluma/plugins/snippets/LanguageManager.pyc
/usr/lib/pluma/plugins/snippets/LanguageManager.pyo
/usr/lib/pluma/plugins/snippets/Library.py
/usr/lib/pluma/plugins/snippets/Library.pyc
/usr/lib/pluma/plugins/snippets/Library.pyo
/usr/lib/pluma/plugins/snippets/Manager.py
/usr/lib/pluma/plugins/snippets/Manager.pyc
/usr/lib/pluma/plugins/snippets/Manager.pyo
/usr/lib/pluma/plugins/snippets/Parser.py
/usr/lib/pluma/plugins/snippets/Parser.pyc
/usr/lib/pluma/plugins/snippets/Parser.pyo
/usr/lib/pluma/plugins/snippets/Placeholder.py
/usr/lib/pluma/plugins/snippets/Placeholder.pyc
/usr/lib/pluma/plugins/snippets/Placeholder.pyo
/usr/lib/pluma/plugins/snippets/Snippet.py
/usr/lib/pluma/plugins/snippets/Snippet.pyc
/usr/lib/pluma/plugins/snippets/Snippet.pyo
/usr/lib/pluma/plugins/snippets/SubstitutionParser.py
/usr/lib/pluma/plugins/snippets/SubstitutionParser.pyc
/usr/lib/pluma/plugins/snippets/SubstitutionParser.pyo
/usr/lib/pluma/plugins/snippets/WindowHelper.py
/usr/lib/pluma/plugins/snippets/WindowHelper.pyc
/usr/lib/pluma/plugins/snippets/WindowHelper.pyo
/usr/lib/pluma/plugins/snippets/__init__.py
/usr/lib/pluma/plugins/snippets/__init__.pyc
/usr/lib/pluma/plugins/snippets/__init__.pyo
/usr/lib/pluma/plugins/sort.plugin
/usr/lib/pluma/plugins/spell.plugin
/usr/lib/pluma/plugins/taglist.plugin
/usr/lib/pluma/plugins/time.plugin
/usr/lib/pluma/plugins/trailsave.plugin
/usr/lib/pluma/pluma-bugreport.sh
/usr/share/appdata
/usr/share/appdata/pluma.appdata.xml
/usr/share/applications/pluma.desktop
/usr/share/doc/packages/pluma
/usr/share/doc/packages/pluma/AUTHORS
/usr/share/doc/packages/pluma/NEWS
/usr/share/doc/packages/pluma/README
/usr/share/glib-2.0/schemas/org.mate.pluma.gschema.xml
/usr/share/glib-2.0/schemas/org.mate.pluma.plugins.filebrowser.gschema.xml
/usr/share/glib-2.0/schemas/org.mate.pluma.plugins.spell.gschema.xml
/usr/share/glib-2.0/schemas/org.mate.pluma.plugins.time.gschema.xml
/usr/share/help/C/pluma
/usr/share/help/C/pluma/figures
/usr/share/help/C/pluma/figures/pluma_format_bold.png
/usr/share/help/C/pluma/figures/pluma_format_italic.png
/usr/share/help/C/pluma/figures/pluma_format_strikethrough.png
/usr/share/help/C/pluma/figures/pluma_format_underline.png
/usr/share/help/C/pluma/figures/pluma_recent_files_menu_icon.png
/usr/share/help/C/pluma/figures/pluma_window.png
/usr/share/help/C/pluma/index.docbook
/usr/share/help/C/pluma/legal.xml
/usr/share/licenses/pluma
/usr/share/licenses/pluma/COPYING
/usr/share/man/man1/pluma.1.gz
/usr/share/pluma
/usr/share/pluma/icons
/usr/share/pluma/icons/pluma-plugin.png
/usr/share/pluma/plugins
/usr/share/pluma/plugins/docinfo
/usr/share/pluma/plugins/docinfo/docinfo.ui
/usr/share/pluma/plugins/externaltools
/usr/share/pluma/plugins/externaltools/tools
/usr/share/pluma/plugins/externaltools/tools/build
/usr/share/pluma/plugins/externaltools/tools/open-terminal-here
/usr/share/pluma/plugins/externaltools/tools/remove-trailing-spaces
/usr/share/pluma/plugins/externaltools/tools/run-command
/usr/share/pluma/plugins/externaltools/tools/search-recursive
/usr/share/pluma/plugins/externaltools/tools/switch-c
/usr/share/pluma/plugins/externaltools/ui
/usr/share/pluma/plugins/externaltools/ui/outputpanel.ui
/usr/share/pluma/plugins/externaltools/ui/tools.ui
/usr/share/pluma/plugins/filebrowser
/usr/share/pluma/plugins/filebrowser/pluma-file-browser-widget-ui.xml
/usr/share/pluma/plugins/modelines
/usr/share/pluma/plugins/modelines/language-mappings
/usr/share/pluma/plugins/pythonconsole
/usr/share/pluma/plugins/pythonconsole/ui
/usr/share/pluma/plugins/pythonconsole/ui/config.ui
/usr/share/pluma/plugins/snippets
/usr/share/pluma/plugins/snippets/c.xml
/usr/share/pluma/plugins/snippets/chdr.xml
/usr/share/pluma/plugins/snippets/cpp.xml
/usr/share/pluma/plugins/snippets/css.xml
/usr/share/pluma/plugins/snippets/docbook.xml
/usr/share/pluma/plugins/snippets/fortran.xml
/usr/share/pluma/plugins/snippets/global.xml
/usr/share/pluma/plugins/snippets/haskell.xml
/usr/share/pluma/plugins/snippets/html.xml
/usr/share/pluma/plugins/snippets/idl.xml
/usr/share/pluma/plugins/snippets/java.xml
/usr/share/pluma/plugins/snippets/javascript.xml
/usr/share/pluma/plugins/snippets/lang
/usr/share/pluma/plugins/snippets/lang/snippets.lang
/usr/share/pluma/plugins/snippets/latex.xml
/usr/share/pluma/plugins/snippets/mallard.xml
/usr/share/pluma/plugins/snippets/perl.xml
/usr/share/pluma/plugins/snippets/php.xml
/usr/share/pluma/plugins/snippets/python.xml
/usr/share/pluma/plugins/snippets/ruby.xml
/usr/share/pluma/plugins/snippets/sh.xml
/usr/share/pluma/plugins/snippets/snippets.xml
/usr/share/pluma/plugins/snippets/tcl.xml
/usr/share/pluma/plugins/snippets/ui
/usr/share/pluma/plugins/snippets/ui/snippets.ui
/usr/share/pluma/plugins/snippets/xml.xml
/usr/share/pluma/plugins/snippets/xslt.xml
/usr/share/pluma/plugins/sort
/usr/share/pluma/plugins/sort/sort.ui
/usr/share/pluma/plugins/spell
/usr/share/pluma/plugins/spell/languages-dialog.ui
/usr/share/pluma/plugins/spell/pluma-spell-setup-dialog.ui
/usr/share/pluma/plugins/spell/spell-checker.ui
/usr/share/pluma/plugins/taglist
/usr/share/pluma/plugins/taglist/HTML.tags.gz
/usr/share/pluma/plugins/taglist/Latex.tags.gz
/usr/share/pluma/plugins/taglist/XSLT.tags.gz
/usr/share/pluma/plugins/taglist/XUL.tags.gz
/usr/share/pluma/plugins/time
/usr/share/pluma/plugins/time/pluma-time-dialog.ui
/usr/share/pluma/plugins/time/pluma-time-setup-dialog.ui
/usr/share/pluma/ui
/usr/share/pluma/ui/pluma-encodings-dialog.ui
/usr/share/pluma/ui/pluma-preferences-dialog.ui
/usr/share/pluma/ui/pluma-print-preferences.ui
/usr/share/pluma/ui/pluma-search-dialog.ui
/usr/share/pluma/ui/pluma-ui.xml


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Nov 10 09:52:08 2019