Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libgnomeui-32bit-2.24.6+20170807.30334c28-lp152.4.4 RPM for x86_64

From OpenSuSE Leap 15.2 for x86_64

Name: libgnomeui-32bit Distribution: openSUSE Leap 15.2
Version: 2.24.6+20170807.30334c28 Vendor: openSUSE
Release: lp152.4.4 Build date: Thu Oct 24 10:14:26 2019
Group: Development/Libraries/GNOME Build host: lamb25
Size: 741868 Source RPM: libgnomeui-2.24.6+20170807.30334c28-lp152.4.4.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.gnome.org/
Summary: The GNOME User Interface Library
This library contains all the user interface-related functions for
GNOME-based software. You need the libgnomeui-devel package if you want
to develop GNOME 2.x Desktop software.

Provides

Requires

License

GPL-2.0-or-later AND LGPL-2.1-or-later

Changelog

* Tue Mar 20 2018 dimstar@opensuse.org
  - Unconditionally enable translation-update-upstream: on
    Tumbleweed, this results in a NOP and for Leap in SLE paid
    translations being used (boo#1086036).
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner
* Fri Sep 08 2017 jengelh@inai.de
  - Update old boilerplate summaries and macros.
* Wed Aug 16 2017 zaitor@opensuse.org
  - Update to version 2.24.6+20170807.30334c28:
    + Fix compiler warnings.
    + Add DOAP file.
    + Doap category deprecated.
    + Explicitly link against libm for floor().
    + gnome-scores.h: Convert to UTF-8.
    + Updated translations.
  - Switch to source service git based checkout.
  - Following the above, add gnome-common BuildRequires and pass
    NOCONFIGURE=1 ./autogen.sh, we need to bootstrap.
  - Also add export CFLAGS="%{optflags} -Wno-error=format-nonliteral"
    as some warnings are fatal when building a gitcheckout.
  - Pass --enable-gtk-doc to configure, needed now to build docs.
  - Drop conditionals for obsolete versions of openSUSE.
  - Add Url, silence rpmlint.
  - Modernize spec.
  - Conditionally apply translations-update-upstream BuildRequires
    and macro for non-openSUSE only.
* Wed Jun 01 2016 jengelh@inai.de
  - Drop --with-pic, it is only relevant for static libs (which
    are not built). Trim trailing dots from summary. Drop redundant
    %clean section. Use %_smp_mflags for parallel building.
* Fri May 27 2016 idonmez@suse.com
  - Update to GNOME 3.20.2 FATE#318572
* Tue Jul 22 2014 dimstar@opensuse.org
  - Drop gnome-icon-theme Requires: no longer required after the
    merging of the themes into Adwaita theme, which in turn is a
    dependency to GTK+ 3.0.
* Mon Apr 15 2013 mmeister@suse.com
  - Added url as source.
    Please see http://en.opensuse.org/SourceUrls
* Fri Mar 01 2013 dimstar@opensuse.org
  - Spec-cleanup using format_spec_file service.
* Tue Feb 21 2012 vuntz@opensuse.org
  - Remove explicit Requires in devel subpackage, that will
    automatically be added the pkgconfig() way: gconf2-devel,
    gnome-vfs2-devel, gtk2-devel, libart_lgpl-devel,
    libbonoboui-devel, libgnome-devel, libgnome-keyring-devel,
    libgnomecanvas-devel.
  - Remove unneeded Requires from devel subpackage: libjpeg-devel,
    popt-devel, pkg-config.
  - Add explicit Requires for pkgconfig(ice) and pkgconfig(sm) in
    devel package: the pkgconfig file references some libraries in
    Libs (and not Requires), so we need to depend on them.

Files

/usr/lib/libglade
/usr/lib/libglade/2.0
/usr/lib/libglade/2.0/libgnome.so
/usr/lib/libgnomeui-2.so.0
/usr/lib/libgnomeui-2.so.0.2400.6


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Jan 19 23:33:27 2020